Jump to content
Comet Forums
frankthetank

help: mpcstar played with other audio type automatically

Recommended Posts

just as described above, my mpcstar played a mkv file with another unknown language. Actually, I did not set any playing language searching or anything. When I tried to open a video file, such as mkv or flv, it just played with no vision but the play time was counting, seems it was still playing but i couldnt see anything. Then I waited for a while, it opened with other unknown language not english. I couldnt find any english audio type any more. please help me, Thanks

post-57262-12729936058018.jpg

Share this post


Link to post
Share on other sites

An .mkv file is a container.

It contains encoded streams of audio, video, subtitles, etc. Nothing dictates how any of those streams must be encoded. That's up to the creator.

What matters to you is how those streams are encoded. You must find out, and you must assure that you have the proper filter installed for each of them. If you don't have the right filter, then you can't decode the stream so you won't be able to see/hear/read the contents.

So, to say, 'this is an .mkv file" is to say nothing - to say, "this is a bottle" or "this is a can". What's important is what is IN the bottle or can, yes?

So then, this is an XVid-encoded video stream and that's an AC3-encoded audio stream, these are the important things.

That they happen to be in an .mkv container instead of, say, an .avi container, is not so important.

I will therefore need an XVid codec and an AC3 codec if i want to view and listen to these streams. Unless I use a player with these things built in, then I must have installed them on my system separately. That is what things like the Combined Community Codec Pack - CCCP - are for.

Containers can contain multiple audio streams. These are usually for the different languages that are available. Nothing requires that one of those streams be English, and they might not be. If there are multiple audio streams, you can select the one you desire with your player. But if there is no stream for your preferred language, you're out of luck. If there is only one audio stream, that's the one that will be played.

Your choice has two audio streams as shown in your screenshot: one in Chinese, one in Chuukese. Only a video stream is stated to be in English, which I am going to assume are subtitles. There is no English audio stream to play.

Share this post


Link to post
Share on other sites

Thanks for your explanation, I've learnt a lot. however, I did play this file before using KMP player, I am strongly sure that they said english before. I cant change audio to english back now. This is what I am confused at this time.

Edited by frankthetank (see edit history)

Share this post


Link to post
Share on other sites

Try playing it again in another player and see if you have more audio streams.

Share this post


Link to post
Share on other sites

yes, it came back with english audio again. I checked stream options in KMP and contains "english(FLAC)" and other two language as i saw when use MPCstar, but english stream didnot show in it, how come?

Share this post


Link to post
Share on other sites

Did you check that FLAC decoding is enabled on the ffdshow audio decoder configuration page of MPCStar?

Share this post


Link to post
Share on other sites

That is, I think, a flaw in MPCStar. Whether or not a codec for a stream is installed, the display should still show all of the streams. It should clearly indicate that it can't decode the stream -- or if it can't tell what the stream is without a codec, it should still say that the stream is there and undecodable. It should definitely not just ignore the stream like this.

Developers, please take note.

Share this post


Link to post
Share on other sites

Notes taken! Problem will be reported ASAP. :)

Share this post


Link to post
Share on other sites

Start-->Programs-->MPCStar-->Settings-->Configure ffdshow audio codecs

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...