Jump to content
Comet Forums
Burnerbum

Video Freezes

Recommended Posts

I have been recording some movies with my Hauppauge PVR in .ts format. When I try to play the movie it starts and after a few seconds it freezes. It also won't let me jump ahead.

This is the info from Mediainfo.

Any help would be appreciated.

General

ID : 1

Complete name : F:\Video Capture\Good Witch's Garden, The.ts

Format : MPEG-TS

File size : 6.27 GiB

Duration : 1h 23mn

Overall bit rate : 10.7 Mbps

Video

ID : 4113 (0x1011)

Menu ID : 1 (0x1)

Format : AVC

Format/Info : Advanced Video Codec

Format profile : Main@L4.0

Format settings, CABAC : Yes

Format settings, ReFrames : 4 frames

Duration : 1h 23mn

Bit rate : 9 937 Kbps

Width : 1 920 pixels

Height : 1 080 pixels

Display aspect ratio : 16/9

Frame rate : 29.970 fps

Resolution : 24 bits

Colorimetry : 4:2:0

Scan type : Interlaced

Scan order : Top Field First

Audio

ID : 4352 (0x1100)

Menu ID : 1 (0x1)

Format : AC-3

Format/Info : Audio Coding 3

Bit rate mode : Constant

Bit rate : 384 Kbps

Channel(s) : 6 channels

Channel positions : Front: L C R, Rear: L R, LFE

Sampling rate : 48.0 KHz

Language : English

Share this post


Link to post
Share on other sites

Does it play seamlessly in another video player (e.g. VLC)?

Is your system powerful enough to play 1080p video?

Share this post


Link to post
Share on other sites

These are the usual symptoms of a system that just doesn't have enough speed/memory/resources to decode and play the video.

You could try converting the video stream to, say, XVid and see if that works adequately. If so, then your system probably isn't powerful enough.

You can also see if the device can use a different encoding in the first place so that you don't have to convert everything in the future.

Share this post


Link to post
Share on other sites

That certainly ought to be enough. Are you getting any logged errors or messages during playback?

Look also at the file info, particularly at the filter chain for anything showing an error or strange message.

Also you might try running some system resource monitoring tools while playing the video to see if you're being constrained somewhere.

You may also want to try a different filter than the one you've got installed, just to see if it's more compatible.

Share this post


Link to post
Share on other sites

I don't have MPCStar installed right now (had to scrape all filters and players due to some conflicting filters issues) but AFAIK MPCStar comes with its own internally bundled pack of decoding filters (mainly ffdshow and some few others on the side) so that will be a bit cumbersome.

But kluelos' suggestion IS what you should consider if you want to troubleshoot MPCStar as far as this goes. You'll have to disable H.264 decoding in the ffdshow copy which MPCStar uses and then install a third-party H.264 decoder (CoreAVC is by far the best and warmly-recommended).

Then see if you get the same issue. If you do, then at least you'll know for sure that it's not a decoder issue, and we'll be able to consider this, some sort of bug.

Share this post


Link to post
Share on other sites

I don't have MPCStar installed right now (had to scrape all filters and players due to some conflicting filters issues) but AFAIK MPCStar comes with its own internally bundled pack of decoding filters (mainly ffdshow and some few others on the side) so that will be a bit cumbersome.

But kluelos' suggestion IS what you should consider if you want to troubleshoot MPCStar as far as this goes. You'll have to disable H.264 decoding in the ffdshow copy which MPCStar uses and then install a third-party H.264 decoder (CoreAVC is by far the best and warmly-recommended).

Then see if you get the same issue. If you do, then at least you'll know for sure that it's not a decoder issue, and we'll be able to consider this, some sort of bug.

Thanks,

I did what you suggested and now the files will start to play at 4 seconds on each file the screen flashes green for a second or 2. The files play jerky, and if I try to scroll forward they freeze. If I let them play then they get to a point and lock up.

Thanks for the help, I really appreciate it.

Share this post


Link to post
Share on other sites

There is a menu (under File-->Info if I recall right) which will display the filter chain in MPCStar. Post a screenshot of that.

Let's see what filters MPCStar uses for playing this file.

Share this post


Link to post
Share on other sites

There are a number of items under filter, I wasn't sure which one you needed so I selected this. It this isn't could you let me know under which one it is.

Thanks,

[OUT] Video

- Connected to:

CLSID: {09571A4B-F1FE-4C60-9760-DE6D310C7C31}

Filter: CoreAVC Video Decoder

Pin: Input

- Connection media type:

Video: MPEG4 Video (H264) 1920x1088

AM_MEDIA_TYPE:

majortype: MEDIATYPE_Video {73646976-0000-0010-8000-00AA00389B71}

subtype: Unknown GUID Name {31435641-0000-0010-8000-00AA00389B71}

formattype: FORMAT_MPEG2_VIDEO {E06D80E3-DB46-11CF-B4D1-00805F6CBBEA}

bFixedSizeSamples: 1

bTemporalCompression: 0

lSampleSize: 1

cbFormat: 176

VIDEOINFOHEADER:

rcSource: (0,0)-(0,0)

rcTarget: (0,0)-(0,0)

dwBitRate: 0

dwBitErrorRate: 0

AvgTimePerFrame: 0

VIDEOINFOHEADER2:

dwInterlaceFlags: 0x00000000

dwCopyProtectFlags: 0x00000000

dwPictAspectRatioX: 1920

dwPictAspectRatioY: 1088

dwControlFlags: 0x00000000

dwReserved2: 0x00000000

MPEG2VIDEOINFO:

dwStartTimeCode: 0

cbSequenceHeader: 44

dwProfile: 0x0000004d

dwLevel: 0x00000028

dwFlags: 0x00000004

BITMAPINFOHEADER:

biSize: 40

biWidth: 1920

biHeight: 1088

biPlanes: 0

biBitCount: 0

biCompression: AVC1

biSizeImage: 0

biXPelsPerMeter: 0

biYPelsPerMeter: 0

biClrUsed: 0

biClrImportant: 0

pbFormat:

0000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................

0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................

0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................

0030: 00 00 00 00 00 00 00 00 80 07 00 00 40 04 00 00 ........€...@...

0040: 00 00 00 00 00 00 00 00 28 00 00 00 80 07 00 00 ........(...€...

0050: 40 04 00 00 00 00 00 00 41 56 43 31 00 00 00 00 @.......AVC1....

0060: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................

0070: 00 00 00 00 2c 00 00 00 4d 00 00 00 28 00 00 00 ....,...M...(...

0080: 04 00 00 00|00 24 67 4d 40 28 9a 62 80 f0 08 8f .....$gM@(šb€ð.

0090: bc 05 a8 10 10 12 00 00 07 d2 00 01 d4 c1 d1 80 ¼.¨......Ò..ÔÁÑ€

00a0: 00 8e ec 00 05 f5 e7 e3 1c 14 00 04 68 fe 3c 80 .Žì..õçã....hþ<€

- Enumerated media type 0:

Set as the current media type

Share this post


Link to post
Share on other sites

Well, I said to post a screenshot of that window with the collapsed view of the filters, just to see all the filters present in the filter graph. Details on any one of them wasn't relevant at this point.

Share this post


Link to post
Share on other sites

Looking at the filter chain, you can see that the Video Decoder it is trying to use is ffdshow. However, the media is in the transport stream form (which is what that .ts extension indicates), not the more usual Program stream form, and ffdshow doesn't support ts.

However, ffmpeg does.

What I'd try in your place is to install CCCP and see if just doing that doesn't solve everything.

If not, what's needed is a way to tell MPCStar to use ffmpeg instead. Exactly how is beyond my knowledge, as I don't use the program that much, and clicking on the video decoder for more info inevitably crashes it for me.

Share this post


Link to post
Share on other sites

That's a tad weird. It loads both ffdshow and CoreAVC. What's under the ffdshow entry, when you expand it?

How about the CoreAVC one?

How did you go about disabling H.264 decoding in MPCStar's copy of ffdshow?

Share this post


Link to post
Share on other sites

That's a tad weird. It loads both ffdshow and CoreAVC. What's under the ffdshow entry, when you expand it?

How about the CoreAVC one?

How did you go about disabling H.264 decoding in MPCStar's copy of ffdshow?

I will try that.

I also have the option of recording the file in M2TS or MP4.

I just want to get the best video and most comptable format.

Thanks again for the help.

Share this post


Link to post
Share on other sites

Actually, the quality of the video is determined by the codec used (i.e. H.264 for best quality/compression ratio, these days) not by the container file type. Therefore, I'd warmly recommend MP4. Files with .ts extension stand for MPEG files which use the transport stream format, which is being meant and used mostly in digital broadcasting AFAIK.

As long as you intend to use the files locally or on fixed media (e.g. hard disk, DVD, flash disk, or whatever) you don't need to use .ts files, if you have other choices.

However, I'm still not sure if this a matter of the format of the container (.ts versus MP4 or anything else) or rather a filter/codec conflict. The fact that you have two concurrent video decoding filters in you filter chain surprises me a bit.

So try to find an answer to each of the questions I've posted above.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...