Jump to content
Comet Forums
Nosferatu

Thai Subtitles

Recommended Posts

Can't read Thai subtitles using MpcStar. I have several .ssa files with Thai subtitles but every time I try to play them with a movie (and yes, all those files are renamed to have the same name as the movie) I only can see symbols like @#$%$#@#$%**

Your help would be much appreciated.

Thanks

Share this post


Link to post
Share on other sites

I would first guess at a Windows configuration issue. Subtitle displays use the system's resources, so if they're not configured properly for a language, this will cause problems.

Are you able to display Thai subtitles properly with other players?

Have you looked at the subtitle files themselves to make sure they're ok? Normally you can just look with Notepad, but don't try to edit or save or you might mess up the formatting. Just look to make sure you're able to read them.

Share this post


Link to post
Share on other sites

Thanks Kluelos for your quick reply. I'm using Windows XP and I have since long configured it to work with Asian languages (namely Thai) as my wife is Thai. That's why she's able to chat daily in MSN using Thai language. But I tried to to do what you suggested (open the .ssa file with Notepad) and the odd symbols (@#%*#*) still display. However. let me tell you that when I use my normal subtitles editor (Subtitle Workshop) and change the language settings from ANSI to Thai, it immediately displays on the main window the correct Thai subtitles. The problem is that after trying to save it as a new .ssa file I still can't read the subtitles in MpcStar. Even stranger because I'm able to read Chinese subtitles whenever I got an .avi with multiple subtitles. Any suggestion?

Thanks in advance.

Best Regards

Share this post


Link to post
Share on other sites

Try running the tiger player with AppLocale , then go to File/Open and open your video file, then load the subtitle and see if your subtitles are shown correctly.

Share this post


Link to post
Share on other sites

You should be able to read the text of the subtitle files in notepad. Oh, it won't be wonderful and there will be timestamps that might appear as garbage, but the basic text in the correct language should be there to be read.

If it's not, this strongly suggests that the problem is with the subtitle files themselves, and MPCStar is just showing you what's there.

I haven't done a lot of work with subtitles generally, but I'm not aware of any format that changes the contents radically enough to make it not fundamentally readable in notepad. but I could be wrong about that.

I suggest you try viewing the movie with subtitles in another player, perhaps VLC, and see if the same issue arises. If it does, then you may be able to find another subtitle file somewhere on the Internet, that isn't munged.

Share this post


Link to post
Share on other sites

I have a similar problem. I've combed the web and not a lot of solutions, a lot of suggestions that does not seem to work. I downloaded a Thai language subtitle for my mom to read from Thaisubtitles.com. It originally came is ssa file, but I was able to open it in Subtitle Workshop and save it as an srt file just fine. When I go to view the subtitle in Subtitle Workshop (SW), in settings > General > charset, in the "original Charset" if I pick ANSI, it will display the "gibberish" characters. But if I select "Thai" it displays it just fine, I can see the time code on the left corresponding to what the Thai subtitle is display perfectly. But when I go to marry the subtitle with the video into a VTS file using ConvertXtoDVD, the subtitles go back to gibberish. And when I go back to the Saved srt or ssa file and open it in notepad, it still displays gibberish. I have to capability to display Thai characters as SW has proven, but does anybody know how to save that subtitle file in SW to keep the Thai character in the Charset and not let it go back to ANSI display. Which I feel this is the obstacle that keeps me from displaying the Thai characters/subtitles in the .srt or ssa file. Any advise would be greatly appreciated.

Share this post


Link to post
Share on other sites

It should be pretty obvious that ANSI won't work for you -- the A in ANSI does mean "American", y'know. So it's not, ever, going to display Thai or Farsi or Cyrillic characters.

You need to be using subs in Unicode, and make sure you're using the correct code page for Thai in ConvertXtoDVD.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...