Jump to content
Comet Forums

internet connection not detected during downloads


Recommended Posts

Hi friends. I'm seeing a new behavior during downloads that i'm not familiar with. Running version 1.27 on my newish Win 7 laptop machine through a linksys WRT54G2 wifi router and a comcast provided Motorola cable modem. (can't find ID on model #) For the last week I've been having trouble with the sudden inability to detect the internet connection. This only occurs during torrent downloads, and does not affect the ability to detect the network.(router) Rebooting has no effect. Attempts to troubleshoot using windows fail, and always end with being unable to connect to the network. I have found 2 ways around the problem. First, I can reboot to Linux, and detect the connection with the same machine. (no other network computers are affected when this happens) Second, I can perform a restore using any previous restore point. (including points since the behavior began) If I start BitComet but don't start any downloads, It doesn't occur. One other odd occurence... I have to perform hash checks after a successful restore in order to restart download. Grateful for any ideas.

Link to post
Share on other sites

There is no dialog box, or any other kind of notification when this happens; I'm just no longer connected to the internet. I can't use my browsers, downloads stop, and the little wifi signal indicator in the notifications area develops a pesky little yellow exclamation point. I click on it and it says "limited connectivity." When I go to Network and Sharing Center, It shows that I am connected to the network, but the network isn't connected to the internet. Here's the rub... All other computers on the network show that the network is connected to the internet. All of their browsers work and downloads are uninterrupted. In addition, the affected computer does not have a problem connecting in Linux. Thus, Windows 7 "doesn't detect" the connection between the router and the modem rather than the connection doesn't exist. Sorry about the screen shots, but I couldn't think what to show, other than the erroneous connection loss shown by the wifi signal icon or the big red X between the network and the internet on the network and sharing center. Thanks again for the help.

Link to post
Share on other sites

This sounds like your router is having trouble handling the many connections necessary for p2p downloading. There are several options you can try to deal with this, but the first step I'd take is to bypass your router (as a test), connect direct to your modem with ethernet cable and see if the problem still exists. If it does not, then we can be sure it's your router, then you can try the following.

1. update routers firmware. Many routers have had similar problems and often a firmware update is released to correct this.

2. Reduce the number of connections bitcomet makes until you reach a manageable limit your router can handle (not an optimal solution)

3. Replace your router with one that doesn't have this weakness

ps. I believe your router uses wifi "g" standard with maximum speed of 54mbit and limited range. Wifi "n" routers are becoming very cheap and have speeds upto 450mbit, and greater range. Upgrading your router would be your best option and with "n" speeds, you'd even be able to stream high definition video from one computer to another, or to media player devices. Well worth the investment in my opinion.

Link to post
Share on other sites

Use your WiFi NIC management software to make sure you are connected to the wireless network that you think you are, when this happens.

If your machine is connecting to another wireless router in the neighborhood, and that other router either isn't connected to the internet or doesn't allow you to access it, this is what you'd see.

If your router "drops out" momentarily, and your NIC decides to connect to your neighbor's wireless router, you would have this problem. Rebooting would cause the connection to be reset and presumably go back to the (now working) correct router. A lot of people find that they've been connected to somebody else's router because folks don't take wireless security seriously.

If you find that this is indeed what's happening, try swapping out the NIC and see if the problem follows the card. Otherwise, NIC's are very cheap.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...