Jump to content
Comet Forums
TheWheelOfFate2010

UDP not working & TCP/UDP listen port closed show open?

Recommended Posts

I Posted Pictures To Make This Crystal Clear.

Hi I’m Experienced User Also I’m Not New To BitComet It Is My Favourite Client But There Is Something Strange About It Udp Ports Never Work The Indicator Always Show Yellow Not Green But When I Switch To Statistics Tab It Show Opened?

also when i set a udp port for remote download or as a listen port it never work?

why that?

2vv83yd.png

My TCP Port 10004 Is Opened & It Is Working Great But Bitcomet Show That 10004 udp protocol is opened too although it is closed?

why that?

2wpl1k2.png

All My Softwares Are Updated B.T.W Except BitComet.

All My Ports Are Configured Correclty.

To Ensure That My Ports Are Working I Use PF Port Checker.

Other Info:

BT Client:BitComet v1.35 x64

OS:Windows 7 Ultimate SP1 x64

Protection Suit:Norton 360 v20.3.0.36

Connection:ADSL 512kpps

1 Router 1 desktop Pc

Router Type:TD-8816 v6.0

Sorry For Caps & Bad English It Is A Bad Habit I Know.

Edited by TheWheelOfFate2010 (see edit history)

Share this post


Link to post
Share on other sites

This is highly confusing.

The remote control port is a different thing as compared to the listen port.

It uses TCP not UDP.

As for the listen port, the ports the fact that the ports appear both open if indeed you still have a yellow light, that is odd, I've never seen that behavior.

You'll have to back it up with some more synchronized sshots (where you actually show the status lights), in order for this to be considered a bug report, I guess.

Share this post


Link to post
Share on other sites

opening bitcomet says listen port is blocked,how do i open it--- tanbits

Please do NOT jump into the middle of someone else's topic with unrelated requests.

Start your own in the proper section and with all of the minimum information.

  • Like 2

Share this post


Link to post
Share on other sites

This is highly confusing.

The remote control port is a different thing as compared to the listen port.

It uses TCP not UDP.

As for the listen port, the ports the fact that the ports appear both open if indeed you still have a yellow light, that is odd, I've never seen that behavior.

You'll have to back it up with some more synchronized sshots (where you actually show the status lights), in order for this to be considered a bug report, I guess.

i faced this problem before if you can remember it is been 4 years now since last time i made the same thread here

how can I back it up?

I already did you have the pictures above

sorry but i give up i guess this is your part to check out the problem and report back a solution afterall this is your client and you know it better than anyone else ;)

Edited by TheWheelOfFate2010 (see edit history)

Share this post


Link to post
Share on other sites

TheWheelOfFate2010,

Bitcomet just like any other bittorrent client requires an open connection to the internet. If you elect to install routers or other devices that can block the connection, then you need to have them properly configured. Problems with listening ports being open should be addressed to the network administrator who runs the LAN, if you don't know who that is, then it's probably you. A network admin would then turn to the router manufacturer to get technical help with that product. There are thousands of different routers and we can't possibly know how they all work.

You are talking to bitcomet users who volunteer their time to help you. If we can demonstrate a problem with the client we will pass it on to development to work on, but we need to be able to reproduce the problem and in this case it's probably an issue with router settings and not related to bitcomet at all.

Also, where bitcomet reports that the udp port was opened in firewall or router, in this case it only opened the port in your firewall as you'll also see it says upnp device not found, so it cannot access your router so you'll need to open the ports yourself or troubleshoot why the router is being blocked and cannot be accessed by bitcomet in order to use upnp.

Share this post


Link to post
Share on other sites

my all settings are ok im sure of it because other clients such as utorrent are working just fine

besides i found something strange and maybe this is the issue

BitComet Always Try To Detect TCP Ports And Not UDP Ports here i made some tests

Here is what i see when bitcomet starts:

dhajgk.png

then bitcomet target tcp port and try to detect it wheather it was open or not:

280pc0i.png

bitcomet report it is blocked:

dmbkia.png

mtnlzr.png

Now you see above that the indicator show yellow although my udp port is open and working

I hope this helps to identify the issue

Edited by TheWheelOfFate2010 (see edit history)

Share this post


Link to post
Share on other sites

If you used the same settings for utorrent and bitcomet, it won't work, they each need their own unique rules with unique ports.

You need an open TCP port, the problem is probably with your router or firewall settings, or the port could already be used by another app.

Share this post


Link to post
Share on other sites

If you used the same settings for utorrent and bitcomet, it won't work, they each need their own unique rules with unique ports.

You need an open TCP port, the problem is probably with your router or firewall settings, or the port could already be used by another app.

I Know all of this but my port is not busy with other app im sure of it

i just tell my UDP port 10003 work with all applications "except bitcomet" now this is strange isn’t it?

and you didn’t asnwered my question if my UDP is open as bitcomet say here

280pc0i.png

then why the indicator didn’t turned into green?

Edited by TheWheelOfFate2010 (see edit history)

Share this post


Link to post
Share on other sites

The indicator won't turn green unless it's able to receive an unexpected remote TCP connection from BitComet's servers, a test signal to determine if you're able to listen for peers.

According to your screenshot BitComet was able to add NAT port mapping to your router and it appears to be working with udp, but that isn't conclusive, and it appears there is a problem with tcp, but that too isn't conclusive and even if it was successful in opening your router for both protocols, any firewalls or security software/IP filtering software used could still block the connections.

If you allow it, bitcomet can control the windows firewall and certain routers, but you could have an infinite number of things blocking your incoming connections, all of which have to be open for the port to work. I think you are incorrectly assuming that if bitcomet reports being able to open the port in your router, that it is also opened in all of your other devices/software, but this is not the case. The indicator at the bottom that reports your port is blocked is a functional test and won't read "green" unless all obstacles are clear.

I've found that many members experiencing problems like you are have multiple routers in series. In many cases they don't even realize that a device they assumed was a modem was actually also a router. The most effective way to trouble shoot this is to remove the router/s and see if you can get an open port, this will help to eliminate possible causes as to where the connection is being blocked.

I'd also recommend using a port in the 50,000 to 60,000 range, these aren't reserved for any applications and will have less chance of being in conflict. You can also use an independent method of testing the port, I use http://canyouseeme.org it's a free open port testing utility, just assure bitcomet is running so that the port will be registered and test it on that website, it will tell you if you're able to receive remotely initiated connections.

If you are able to remove the router (as a test) and the port is open, that would confirm the problem is in your router in which case it would probably be easiest to disable uPnP port mapping and open the port manually for both TCP and UDP connections.

Share this post


Link to post
Share on other sites

i have 2 ports are opened 10003 UDP and 10004 TCP

Bitcomet Work Good With 10004 Tcp But Not Working With 10003 UDP

And For utorrent It is working great with 10003 UDP also it work great with 10004 TCP

sorry for wasting your time maybe i should stick to utorrent for now

but what i don’t like it about utorrent it is slower than bitcomet

Share this post


Link to post
Share on other sites

As I mentioned in a prior post, you cannot use the same post for utorrent and bitcomet. Each app needs it's own port number and you can only use ONE port number for both TCP and UDP connections.

Assign a unique port to bitcomet, select any random number between 50,000 and 60,000 and make a portforwarding rule in our router so that port is opened for both TCP and UDP connections for bitcomet. Some routers will allow you to do this with one rule, and some will require two rules, both with the same port number.

Share this post


Link to post
Share on other sites

What I Meant Is I Already Know That i cannot use the same port for 2 different software

but still i wonder why utorrent can use 1 udp port and the indicator turn into green while bitcomet can’t do that?

Share this post


Link to post
Share on other sites

I've been trying to understand what you've been doing to attempt to open your ports and it's very difficult to follow your posts. It looks like you are trying to open two different ports, one for udp and one for tcp... if so, that is probably one of your problems. It's also possible that you don't even have a problem at all, have you tested your listening port at canyouseeme.org as I suggested?

Also are you using any IP filtering software like peerguardian/peerblock or protowall/blocklist manager?

Share this post


Link to post
Share on other sites

First question... but not the first time I've asked this so I'll make it bold...

Why are you testing two different port numbers???

BitComet only uses one port for incoming connections.

If you use peerblock with some of the common block lists your computer will not allow bitcomet to make connections to do things like find you LTseed connections and test your port status. This is why information like this should have been in your very first post. If you want to use PeerBlock you'll need to make an allow list for the IP addresses used by bitcomet. This info is listed in the FAQs at wiki.bitcomet.com.

ps. if canyouseeme.org cannot connect, then your port is not open

Share this post


Link to post
Share on other sites

I Already told you my ports are working 100% with any other software

besides i have tried to use bitcomet without peerblock it still acting the same way

so any ideas to make bitcomet indicator turn into green on this port 10003 UDP Only? Like Utorrent?

Edited by TheWheelOfFate2010 (see edit history)

Share this post


Link to post
Share on other sites

I'm trying to help you but I don't think you are understanding what I am telling you. If you prefer to have someone else help, I'll ignore this topic any any other member is more than welcome to try to explain this to you.

If you do want my help then the first thing you need to do is stop trying to use two different ports, you use the same port for TCP and UDP. Go to

Options>Connection>Listen port

What port number is listed?

Test that port at canyouseeme.org while bitcomet is running, if it cannot see you on that port, then the connection is blocked. It doesn't matter what your PF port checker says, that isn't testing if your port is open to the internet but the canyouseeme.org website is.

If your port is blocked, the most likely cause is in your router so you'll need to make a rule to direct the incoming connections on that port go to the correct computer using both TCP and UDP protocols.

If you use a different port number, it won't work.

Share this post


Link to post
Share on other sites

If you used the same settings for utorrent and bitcomet, it won't work, they each need their own unique rules with unique ports.

You need an open TCP port, the problem is probably with your router or firewall settings, or the port could already be used by another app.

agreed with EAGLE. check setting in router & allow firewall setting for incoming/outgoing for bitcomet.

Norton 360 is one of the best for internet security but it wont let the TCP open especially Norton 360 with patched/cracked.

got to setting in norton 360 allow/excluded bitcomet from protocol filtering. norton still can detect suspicious data during downloading..

but some of the malware can make a handshake & can pass thru if you used default setting for norton.

used port no from 40000 till 60000 you'll get the best speed & more peers.

and agreed with Cassie too, refer previous topics. you'll get the answer

Edited by arigatokuzaimas (see edit history)

Share this post


Link to post
Share on other sites

don’t bother i have used UDP port and it is working good even the indicator is not detected

then you got no issue at all..

Share this post


Link to post
Share on other sites

First off, thanks for all help from this forum & admins/mods

ALSO have the same problem with bitcomet yellow listen port listed as blocked.

I have NO router, only XP firewall only, Bitcomet 1.29 [Did update to new ver but same problem & didn't like the interface so rolledback]

Peers always LOCAL or TCP, green & yellow

Firewall OFF, still blocked, Firewall ON exceptions made for bitcomet AND Bitcomet's TCP & UDP both with same port as Bitcomet

Cable Internet [Nothing wireless]

Modem: Motorola SB5101U surboard modem

Bitcomet 1.29

WinXP SP3

Using Port: 50669 with Bitcomet

CanYouSeeMe.org Error: I could not see your service on 120.29.xx.xx on port (80) Reason: Connection refused

Portforward.com shows a router number even though I have no router and that I have a different public IP then Internal IP???

Bitcomet using the Public IP

Local area connection status using IP 10.59.xx.xxx

2i9kxgo.png

Edited by ranosb (see edit history)

Share this post


Link to post
Share on other sites

First off, thanks for all help from this forum & admins/mods

ALSO have the same problem with bitcomet yellow listen port listed as blocked.

I have NO router, only XP firewall only, Bitcomet 1.29 [Did update to new ver but same problem & didn't like the interface so rolledback]

Peers always LOCAL or TCP, green & yellow

Firewall OFF, still blocked, Firewall ON exceptions made for bitcomet AND Bitcomet's TCP & UDP both with same port as Bitcomet

Cable Internet [Nothing wireless]

Modem: Motorola SB5101U surboard modem

Bitcomet 1.29

WinXP SP3

Using Port: 50669 with Bitcomet

CanYouSeeMe.org Error: I could not see your service on 120.29.xx.xx on port (80) Reason: Connection refused

Portforward.com shows a router number even though I have no router and that I have a different public IP then Internal IP???

Bitcomet using the Public IP

Local area connection status using IP 10.59.xx.xxx

2i9kxgo.png

You do indeed have a router. I'm not sure if your surfboard modem is also a router of if you have another device installed that is a router, but if you did not have a router, you wouldn't have a separate LAN IP address.

Although you made no mention of it I think the most probable case here is that you have a VOIP telephone device that you didn't mention, or your modem has an internal router. If the latter you can probably disable the router or forward the port and you should be fine.

Share this post


Link to post
Share on other sites

I have no VOIP telephone device, or any other device hooked up to the line, except cable tv. Never heard of the modem having a router built in, don't have a clue how to access it if it did which makes it unlikely. I am looking into that now.

Now I did have a DIR-100 router that was removed and sold, and then had no connection, till I informed the internet cable company that it was removed and the connection resumed. Could they still have it set at the company that I have a router, and this is giving me a second IP?

Edited by ranosb (see edit history)

Share this post


Link to post
Share on other sites

Does your modem plug into your cable wire or does it plug into a cable box?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...