Jump to content
Comet Forums
canada

Port detection failed

Recommended Posts

Hi all... I know this is a popular challenge, and I've read many many posts about it before coming here. Hoping you can help - thanks in advance. BitComet is showing "Port Detection Failed" in the lower right corner, with a gray circle. If I "check again" from the right click menu, it stays gray and stays as "Port Detection Failed". No torrents that are added begin downloading. 

Details: 

  • Network
    • Static IP address setup on local computer 
    • VPN service is in use, with verified open port (canyouseeme.org shows OPEN
    • Port forwarding setup on router 
    • Everything else generally working fine... good speeds, Plex and other services all good 
  • Troubleshooting 
    • Have restarted both router and computer 
    • Have verified port is open using several online services 
    • Have verified that an exception is present in Windows Firewall, and have disabled firewall as part of testing with no luck 

I'm medium-level proficient with this kind of stuff but get out of my depth pretty fast. Any ideas? Thanks again in advance. 

Share this post


Link to post
Share on other sites

Does the port open when the VPN is disabled? It could be a problem with the VPN settings

Share this post


Link to post
Share on other sites

Hi @Rhubarb thanks for the quick response. When VPN is disabled, the port checkers show it as NOT open... 

My VPN is Private Internet Access. I did follow their instructions for enabling port forwarding through the VPN, which was a toggle "on" in the settings, and connecting to one of a specific list of location gateways. 

See screenshot of VPN settings panel below - any ideas? 

 

pia_nw_2018_10_08_14_14_32.png

Share this post


Link to post
Share on other sites

Only thing I can think of is to make sure that UPnP mapping is 'on' in preferences and also try setting both TCP and UDP in the VPN.

If you do solve it, please post the fix

Share this post


Link to post
Share on other sites

UPnP is on in BitComet settings, and I tried both TCP and UDP in the VPN - still no luck. No torrents will download, and "Port Detection Failed" still showing with the gray circle. 

Share this post


Link to post
Share on other sites

Update - turns out the torrents I was using for testing were from a private tracker that has banned BitComet as a client. From what I gather the reason is related to the communication of true torrent stats which they use to enforce various ratios and limits. Bummer as I am a big fan of BitComet and it's by far my favorite client so far. 

When using a different (non-private) tracker, everything looks great and is flowing at ~10,000 kB/s. I am happy to have successfully cobbled together this setup with static IP + port forwarding + VPN, but sad to have to choose between the invite-only tracker and BitComet. 

Thanks for the help and responsiveness. 

Share this post


Link to post
Share on other sites

That's always been a problem with private trackers - you're stuck with their settings. It's probably down to the ill-founded rumour that BitComet 'hammered' trackers (it doesn't, but that bit of FUD has been round for quite a while now).

Share this post


Link to post
Share on other sites

Hsheng - it will say on the tracker list if it's a private tracker.

As for the delay - that happens  - no biggy

Share this post


Link to post
Share on other sites

If it's a private tracker you will only get ONE instance showing - it won't connect to anywhere else

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...