Jump to content
Comet Forums
taseron

Kaspersky deleted BitComet saying it's AdWare

Recommended Posts

Hi, I've been using BitComet with Kaspersky AV for more that 2 years without any issues. Today when I run BitCommet, Kaspersky warned me about BitComet beeing an adware (AdWare.Win32.DealPly.eaazj) and removed it.

It also removed 8 copies of bit????.tmp.exe from Windows 7 Temp folder.

Anyone else experienced this recently?

Is it just me or is it a common thing?

 

 

 

Share this post


Link to post
Share on other sites

yes i had same problem, just false positive, you should add bitcomet.exe in threats and exclusions

6v6nA6n.png

not only kaspersky some other antivirus programs treat it as virus, i think this happened after i installed 1.53 update, before that it was working fine, i tried older builds and they doesn't have this problem, 1.45 was fine

Edited by george2018 (see edit history)

Share this post


Link to post
Share on other sites

Thanks for confirming the issue.

The strange thing is, I haven't been updating Bitcomet for months. It kept asking me if i want to update and i remember declining it due to being busy fetching urls at that time.

I wonder if it downloads a copy of the updated exe before asking me to run the update everytime. Since i have 8 copies of bitcomet exe file in win7 temp folder, i guess it does download it, then asks for installation.

Anyone to confirm that?

Share this post


Link to post
Share on other sites

well it has only avast advertisement on start page, i just removed start page tab and it disappeared, maybe some antiviruses treat it as adaware, in past they had different advertisement on start tab

Edited by george2018 (see edit history)

Share this post


Link to post
Share on other sites

I just tried downloading Bitcomet setup  on a machine with Symantec av and it blocked the download.

Then i tried downloading another torrent client to see if its about a problem with torrent software. Other client didn't alert the av.

As you said, it's probably due to ads, or the way ad engine works.

I hope Bitcomet fixes that issue because it's impossible for people running av to understand if it's a false positive or a real infection. A known false positive exe can get infected too.

Edited by taseron (see edit history)

Share this post


Link to post
Share on other sites

The issue with 1.53 has already been reported to the devs

  • Like 1

Share this post


Link to post
Share on other sites

well KIS 2019 started deleting bitcomet.exe file even after adding it in threats and exclusions (using 1.51 version) , i think i switch to 1.45 version as well, there's no such problem, well it treats 1.46-1.53 versions as adaware and doesn't like fusion.dll file in those versions, i even cannot install those version when KIS 2019 is running, i think they changed this recently, because i was using 1.46-1.51 since they were released and never had any problems with them using KIS

yiJQLhQ.png

maybe it's something to do with the installer, i will try zipped version as well and report back

Edited by george2018 (see edit history)

Share this post


Link to post
Share on other sites

no it keeps deleting some files:

4e4cRjf.png

since 1.46 version it deletes even installation exe file, last version is 1.45 that installs fine without deleting anything, so KIS 2019 and maybe some other antiviruses changed something in their latest virus definitions that prevents using bitcomet 1.46-1.53 builds, even it is false positive and there's no actual virus or trojan 

Edited by george2018 (see edit history)

Share this post


Link to post
Share on other sites

The fault seems to be with Kaspersky. There is NO virus or trojan in the file. All you can do is to disable the A/V (or change to another program), download and install and then re-activate the A/V

This topic was discussed at some length here

Share this post


Link to post
Share on other sites

yes KIS 2019 treats bitcomet.exe as trojan and deletes it after some time even after adding it in threats and exclusions

7MCpcs0.png

i rather stay at 1.45 version, it's working fine and there's no false trojan warnings, i check again 1.51  version in KIS 2020 when they release final version, maybe they fixed it

Share this post


Link to post
Share on other sites
9 hours ago, Rhubarb said:

The fault seems to be with Kaspersky. There is NO virus or trojan in the file. All you can do is to disable the A/V (or change to another program), download and install and then re-activate the A/V

This topic was discussed at some length here

Kaspersky does not say it's a trojan or a virus. It says "adware"

I don't know what others think but I wouldn't disable/ or change my AV just because a torrent client does not comply with it's protection rules.

I trust Kaspersky and I'm sure many people trust them too That's why they install it on their system and let it control everything.

We like BitComet too and we trust it so we use it on our systems but if you ask me to make a choice I'd uninstall BC and keep Kaspersky.

I believe it's BitComet's job to build a proper exe file (like the old version) that does comply with Adware rules.

Thank god the old version works for now. I hope BC finds a solution.

Edited by taseron (see edit history)

Share this post


Link to post
Share on other sites

Change your A/V - Kaspersky is acting on a false positive. The problem is in the A/V itself - not in Bitcomet.

Read the thread I gave - it explains what the 'adware' is

Share this post


Link to post
Share on other sites
44 minutes ago, Rhubarb said:

Change your A/V - Kaspersky is acting on a false positive. The problem is in the A/V itself - not in Bitcomet.

Read the thread I gave - it explains what the 'adware' is

In other thread you say;

"That's why 99% of all software states "Close all running applications" and 'all' means ALL. "

 

Rhubarb, you don't need to close AV apps. They are designed to be running during installs. You can even install whole Adobe Creative Suite or some low leverl USB Dongle or system drivers without stopping Kaspersky or any AV.

Closing an AV for every installation defeats the whole purpose of having an AV on your system. Every experienced user knows that. If you ask BC developers, I'm sure they'll agree too.

Sorry dude, I've been using my AV for 8 years and I trust it.  I won't change my AV just because someone on a torrent forum told me to do so.

 

Edited by taseron (see edit history)

Share this post


Link to post
Share on other sites

No - they're NOT. The standing instructions on most apps is to close ALL running programs and that INCLUDES the A/V.

However, it's your choice - if there was a problem, it wouldn't have downloaded to begin with, but just as a FYI - I'm retired and I've been working with computers (professionally) since 8 bit days, but it's your choice to use an A/V program that is giving a false positive.

Share this post


Link to post
Share on other sites

Thanks Rhubarb. I'm also a long timer, my first PC was a ZX Spectrum so you can be sure that I know what I'm doing.  Thanks for your help. I'm sure each user will decide according to their own situation.

 

Edited by taseron (see edit history)

Share this post


Link to post
Share on other sites

All I can do is advise - and part of that advice is that Kaspersky is known to have issues with some apps. It's not just BC.

Additionaly, I'm part of the windows insider group (on skip ahead/fast track) and it's a known problem there for running A/V to really mess up an installation. Kespersky has also been known to cause problems with Firestorm Second Life viewer.

I actually started with a ZX81 (and the wobbly RAM pack) and I build my own computers now.

Share this post


Link to post
Share on other sites

well after fresh windows 10 1809 installation i installed 1.51 and then installed KIS 2019 with D patch, so far no more false trojan warnings, i don't use 1.53 version because it has some problem with private trackers, 1.52 has same problem https://www.cometforums.com/topic/12800244-152-torrents-corruption/ i think it's something to do with dht ipv6 network  url which introduced from 1.52 build

Edited by george2018 (see edit history)

Share this post


Link to post
Share on other sites

well no more false trojan warnings in new 1.54 build but 1.52 bug with private trackers remains, i don't know about other users but with ipv4 connection i cannot continue to download any private torrent task after i restart bitcomet client, i checked many torrent trackers and none is working with private flag, 1.51 version works fine as well as older ones, can you at least add option to remove dht ipv6 network  url from private trackers, otherwise it won't download anything and i'm stack with 1.51 build as well as many other users who still use ipv4 protocol and private trackers with bitcomet client

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×