Jump to content
Comet Forums
Jeffery

Why if listen ports get blocked would affect speed?

Recommended Posts

Posted (edited)

Quoted from the wiki of BitComet:

http://wiki.bitcomet.com/add_port_mapping_in_nat_router

Quote

 To get the best speeds, BitComet needs an open listening port, just as
 most other P2P applications do.


http://wiki.bitcomet.com/bitcomet_status_bar

Quote

 An yellow light means BitComet successfully requested the probe, but
 did not detect it at your listen port. This indicates that the port is
 blocked by one or more firewalls. Your client can therefore reach
 other clients but other clients can not initiate contact with your
 client.
 
 If your listen port is blocked you can still transfer files with
 BitComet, but your transfer speed probably won't be very high.

http://wiki.bitcomet.com/bitcomet_options

Quote

 No listening Mode: will greatly slow down your upload/download rate.
 Not recommended. (Exceptions are those who are situated behind routers
 or firewalls which they cannot access and configure. For them, this
 setting will provide the means to still be able to download even
 though at much lower speeds).

E.g. I can't not configure the outermost firewall, so the listening port used by BitComet is blocked, thus I can only be a client not a host. But how would it  greatly slow down the download speed? I can still connect to all the other peers who can be a host as a client. 

Is it merely because I would lose those client peer connections if I can be a host?

I am a programmer and interested in this problem. A technical explanation is ok and appreciated. Because now my ISP does not allow me to configure the outermost firewall, so if this affects the speed hugely, I would consider to choose another ISP who can give me a "real public ip"( I can configure the outermost firewall ).

Edited by Jeffery (see edit history)

Share this post


Link to post
Share on other sites

Did you set up port forwarding in the router? To do this successfully you will need to give the target computer a fixed intranet IP number(on the lines of 192.168.0.### if your routerhas a numberin that series). You will then have to add port forwarding (I use a block of ports) in the router itself and the port in bitcomet set to one of those.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hmmm. That's not what I asked. I just want to know, if my BitComet's listening port is blocked, in which I can't be a server. How badly my download/upload speed will decrease ? Because in the Wiki of BitComet, it mentions that it will hugely impact the download speed. I just want to know how and why in a technical perspective. But I' think I've found the answer somewhere else. So thank you for replying :).

Edited by Jeffery (see edit history)

Share this post


Link to post
Share on other sites

The simple answeris that if you block the app from hearing, it doesn't receive responses from trackers or any downloading so it simply doesn't know what speed the otherperson is receiving at, so it slows things down.

In a nutrshell, if a person is hearing impaired, you have to shout and even then you can't be sure if they actually heard and understood

Share this post


Link to post
Share on other sites

Without an open listening port you will not receive any peer initiated requests. The only way you can connect to a peer is if you initiate the connection and most peers in a swarm already have the connections they need.

As new peers enter the Swarm they will try to connect with others except they cannot reach you. You will not know they exist until you receive a Tracker update and by then they may have all the peers they need. If you cannot receive incoming connections your performance is going to be horrible on most torrents. I highly recommend you get a better internet connection and mobile broadband is never a good option when using peer-to-peer downloading.

Fiber optic is usually the best option

  • Like 2

Share this post


Link to post
Share on other sites

I am having the yellow light listen port blocked issue. I currently run WIndows 10pro and have norton security suite. I have created a new rule in Norton but I still cannot open the listen port. Any ideas? I am not a techie person so any help would be great. 

 

 

Share this post


Link to post
Share on other sites

check that port forwarding is set up from your router - it's best to use a fixed IP on the computer before allocating ports

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...