Jump to content
Comet Forums

VPN and Port blocked (yellow status)


Recommended Posts

Hello,

My Bitcomet has always worked very fine until now when I can use a VPN (Surfshark).

I have opened listening ports of Bitcomet and eMule in my router as well as I have the private IP of the device as fixed or static.

Without VPN connection all is OK and the port indicator is green (opened). The problem is that under VPN connection the port indicator is yellow (blocked).

I tried several things but I haven´t get a solution:

  • With Bitcomet I tried to change options in network.preferred_network_adapter_ipv4 (Options/Advanced); check/uncheck Enabling UPnP port mapping.
  • With the VPN I tried to change servers and protocols (IKEv2, OpenVPN TCP or OpenVPN UDP).

Does anybody know any possible configurations (in BitComet, router and or VPN) to get the port indicator green when the VPN is connected?

Thanks in advance

Link to post
Share on other sites

It's possible the VPN is using a different port from the ones you have set. Open the router control panel and add whatever port is being used for the VPN. You may also have to add it to the firewall.

Link to post
Share on other sites

I have the same issue untill last week no problem downloading but now it is marked on the right bottom site whispergate blocked? 

check your firewall and NAT router connections, I have no clue what that is.

Firewall is Norton and that I checked it is allowing Bit Comet, no problem there I think.

Link to post
Share on other sites
  • 3 weeks later...
  • 4 months later...
  • 1 month later...

If you're using a VPN and your Listen Port is blocked...

If you want to up or download - and still be protected by your VPN - Disconnect your VPN for a short amount of time.

In your BitComet app, right slick on "Listening Port Blocked" in the bottom right hand corner of the screen and chose "Check Again."  The Listen Port will open.

Now you can reconnect your VPN and the Port will remain opened.

Link to post
Share on other sites
On 1/12/2021 at 4:34 PM, AlexX15 said:

Opening ports won't help if you connect to a VPN. You need to open these on the VPN server. If surfshark doesn't support this your out of luck. 

ExpressVPN does not support the opening of ports inside its VPN:

"ExpressVPN does not offer port forwarding"

<link removed>

 

Examples of the best VPN with the port forwarding feature: PureVPN (the best for port forwarding options, free of 14 eyes), PrivateVPN, PrivateInternetAccess

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...