Jump to content
Comet Forums

Recommended Posts

I got a new win 10 computer and when I try to install bitcomet it say no internet or check fire wall. Is there a port i need to open? I loaded it on my older computer with no issue. or is there a windows setting that is causing this.

Link to post
Share on other sites

First, turn off the anti-virus during installation (it can cause problems) and turn it back on onceinstalled.

BC should set the firewall exception itself - if it prompts, allow it to have access

Ports - the best system is to set the computer to a fixed IP number and manually add ther gateway (your router IP address) and your ISPs DNS in Network Settings servers) Make sure that the router ports are set to allow TCP and UDP on the selected listening piorts (you can set those to any value you like provided it's not a reserved one - anything about 10,,, is fine usually). So long as the port setting on the router matches the ones in Bitcomet, it should be fine.

Link to post
Share on other sites
4 hours ago, Rhubarb said:

First, turn off the anti-virus during installation (it can cause problems) and turn it back on onceinstalled.

BC should set the firewall exception itself - if it prompts, allow it to have access

Ports - the best system is to set the computer to a fixed IP number and manually add ther gateway (your router IP address) and your ISPs DNS in Network Settings servers) Make sure that the router ports are set to allow TCP and UDP on the selected listening piorts (you can set those to any value you like provided it's not a reserved one - anything about 10,,, is fine usually). So long as the port setting on the router matches the ones in Bitcomet, it should be fine.

I got a spectum router and can't figure out where the listen ports are. I tried disable the firewall and antivirus. Tried setting exceptions for .exe and folder programs/  It installed fine and works on my older lenovo T410 so it would seem it is set ok. My new computer is a lenovo x1 carbon and it asked me a tlhousand q;uestions when setting up about commumication with ms etc. abittorrent loads fine and works fine. I miss bit comet but am at a loss as what is causing it . It would seem its a MS setting win 10 pro on both computers  thanks

Link to post
Share on other sites

Open a command prompt and type in (without quotes)  Look at your IP address there and your router will have the same first three numbers - take a not of those and open a browser and enter the address as (the first three numbers) followed by 1 (similar to 192.168.1.1)

That should connect to the router. To change settings you will need the password which, in most cases. will be on a label on the router. Enter that (and change it before closing)

Link to post
Share on other sites
2 hours ago, Rhubarb said:

Open a command prompt and type in (without quotes)  Look at your IP address there and your router will have the same first three numbers - take a not of those and open a browser and enter the address as (the first three numbers) followed by 1 (similar to 192.168.1.1)

That should connect to the router. To change settings you will need the password which, in most cases. will be on a label on the router. Enter that (and change it before closing)

I'm not having a problem getting into the router. Once in I can't find anything that says listen port. 

I got bitcomet 1.50 from Foss and it unzips the entire directory so I make a shortcut of the bitcomet app in that directory onto the desktop and it is working.

I have ver 1.6 on my old computer and it works fine but it also won't load ver 1.73 with same error as on the new x1 carbon.

version1.73 is not a zip file but a installer that wants to load into 😄 programs/bitcomet. Does 1.73 have known problems?

Link to post
Share on other sites

No problems that I'm aware of ( but people do seem to jhave problems that I can't replicate)

That being said, you have to go into the router in order to set ports. Unless they are opened and set to match the IP number and listening ports in the PC, you will get that error. It wonm't say 'listening port' or anything similar in the roputer - it should, however, say something on the lines of 'port forwarding'. This needs to be set to both TCP and UDP and the IP address of your computer

However, that doesn't cover the installation problem. The 'zip file' you mention seems to be a 'portable' version (able to run without actual installation). That can be problematic really but what may be happening (guesswork here as I can't actually look over your shoulder) is that User Account Control on Winddows is set too high and actively blocking the installlation. This can also happen with the anti-virus as a lot of A/V apps balk at the bundled software (which is optional and not necessary)

Link to post
Share on other sites
13 hours ago, Rhubarb said:

No problems that I'm aware of ( but people do seem to jhave problems that I can't replicate)

That being said, you have to go into the router in order to set ports. Unless they are opened and set to match the IP number and listening ports in the PC, you will get that error. It wonm't say 'listening port' or anything similar in the roputer - it should, however, say something on the lines of 'port forwarding'. This needs to be set to both TCP and UDP and the IP address of your computer

However, that doesn't cover the installation problem. The 'zip file' you mention seems to be a 'portable' version (able to run without actual installation). That can be problematic really but what may be happening (guesswork here as I can't actually look over your shoulder) is that User Account Control on Winddows is set too high and actively blocking the installlation. This can also happen with the anti-virus as a lot of A/V apps balk at the bundled software (which is optional and not necessary)

I lowered the uac to lowest and in port fwd i said port range is 3388:3390 and set the port to 3389 which is my win 10 listen port i found using regedit. I set to both udp and tcp. still no go same error

Link to post
Share on other sites

The problem seems to be with your router and/or W10 configuration. This is a sceen dump of my 'statistics' panel and you should see something similar. Check that all functions show working

At the bottom I have green lights on DHT Connected: 3833 and Port Opened: 21174

 

options.jpg

Link to post
Share on other sites
1 hour ago, Rhubarb said:

The problem seems to be with your router and/or W10 configuration. This is a sceen dump of my 'statistics' panel and you should see something similar. Check that all functions show working

At the bottom I have green lights on DHT Connected: 3833 and Port Opened: 21174

 

options.jpg

where is this statistics?  bit comet or win 10 or router. if in bitcomet where do i find it

Link to post
Share on other sites
4 hours ago, jpmcsale said:

I can't find that screen in my bitcomet ver 1.50;  are you using ver 1.73 for this? Are you running on windows 10?

I was able to load ver 1.73 on my wife's win 10 home edition and I notice it pops up a choice for adware install before installing bitcomet. So I added bitcomet to the pop up allow list and it installed fine. The error message is a far cry from being intuitive. Thank you for all your concern, it kept me thinking.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...