Jump to content
Comet Forums

"Auto start task when download rate less than specified rate" feature does not work


Recommended Posts

Hi,

Using latests version: 1.78, windows 10 with latests fixes.

I have enabled "Auto start task when download rate less than specified rate" and I have it at 150 KB/s for total download speed and 15 KB/s for slowest task. I have 22 active tasks (all downloading). My limit for concurrent tasks is 10. Unfortunately it does no pause any of those 10 active. Tool tip says 5 min but after 10 minutes (or even whole day) the same 10 tasks are downloading. All of those are stuck at 90+ because seeds are not available. Can you please fix that?

Do you need any more information from me?

Thanks and have a nice day.

 

Link to comment
Share on other sites

Those speeds are really very slow. I'd increase them to at least 256 KB/s for both min and max values. At a guess the p[rogram is downloading what it sees as the 'faster' files and with a download limit of 10, that's all you will get - 10 concurrent downloads, irrespective of the number in the queue.

You could try manually stopping any running downloads but that will just shift the problem to other files

Link to comment
Share on other sites

What do you mean by min and max? Those settings are:

image.png.c883496393c6eb8025f2f904499ebe43.png

In my condition I have 22 tasks that are all stuck at various % of completeness.  So download speed of all tasks is way below 150KB/s, mostly around 0 KB/s. I want to cycle through them because I would like to add tasks from time to time so they are picked up from the end of the queue, finished and then those stuck will get pick up again. I don't want to increase the maximum number of concurrent tasks because tasks that I am adding are often popular files that have a lot of peers and seeds and I don't want to use my whole bandwidth.

Link to comment
Share on other sites

Take the 'auto' setting off. You could also increase the number of concurrent downloads as you are restricted to 10 downloads at the same time irrespective of any other setting

Link to comment
Share on other sites

2 hours ago, Rhubarb said:

Take the 'auto' setting off. You could also increase the number of concurrent downloads as you are restricted to 10 downloads at the same time irrespective of any other setting

I don't want that setting off. I want it to work as it is described in the tooltop and on that page.

Link to comment
Share on other sites

It's working exactly as it's supposed to - you are restricted by your own settings from downloading any more than 10 torrents no matter how many you have queued for autostart.

It will not pause any of the files running  even if there is no movement from the seeder so long as they remain active

Link to comment
Share on other sites

You don't quite seem to understand. YOU altered default settings and you also have restricted downloads to a maximum of 10. That is down to you and NOT the program.

Link to comment
Share on other sites

All anyonwe can do is to advise you and the advice is to stop running at ridiculously low speeds

As you seem bent on totally ignoring that advice, there is no point in continuing

And as a fyi - what is happening is NOT a bug

Link to comment
Share on other sites

Can you please IGNORE speed settings? I can set them to whatever values because for that feature they don't matter. IT says in that tooltip that it will stop task if speed of that task is BELOW that speed. It does not stop that task. Ergo: that feature DOES NOT WORK. IT SAYS IT WILL PAUSE that task to make room for another. It says that in the tooltip.

image.png.09a058de03319be92c227cb38411386d.png

Link to comment
Share on other sites

It should work as follows: if i have it set to 150KB/s for first parameter (total speed) and 10kB/s for slowest task limit. I have 10 concurrent tasks allowed. I have 12 tasks started, 10 of them running:

Tasks:

  1. running at 10KB/S
  2. running at 10KB/S
  3. running at 10KB/S
  4. running at 10KB/S
  5. running at 10KB/S
  6. running at 10KB/S
  7. running at 10KB/S
  8. running at 10KB/S
  9. running at 10KB/S
  10. running at 0KB/S (because there are no full copies of the file or it is stuck in "connecting" state because there are no peers at all)
  11. not running, queued
  12. not running, queued
  13. not running, queued
  14. not running, queued

After 5 minutes it should stop task number 10 and start task number 11.

It says that in the tooltip.

Edited by Some User (see edit history)
Link to comment
Share on other sites

They are?

image.png.f1220ca1a5ac01d007b281e9f2d713eb.png

Or are you focusing on wrong setting.

image.png.997434609393d1135498fead063dfdbf.png

Please read my previous post carefully. Replace speeds that I wrote there with X, Y, W, Z ... AND FOCUS ON A FACT THAT DOWNLOAD ARE NOT PAUSED. PLEASE. You are focusing on wrong thing!!!!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...