Jump to content
Comet Forums

How to Set up Portforwarding & Static IP Reply thread.


Recommended Posts

i know how to open a port but there is something odd that just happened today i haven't opened the bicomet 4 about 2 weeks but 2day i was trying 2 use it and soothing unusual happened i got gray light and beside it there is detect failed its not the usual unknown beside the gray light it says detect failed so can any1 help me in how to deal with that??

i also would like to add i tried check again and restarting the program sevral times but it always ends up the same way (detect failed) please help!!!!!

thanks

Edited by fire_boy (see edit history)
Link to post
Share on other sites
  • Replies 506
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

You don't know what you're talking about. There is a ton of misinformation about that "limit" floating about the net. That limit of 10 incomplete outbound TCP/IP connections per second. It is not a l

i followed this guide and i finally got decent speeds -thanks- oh and about that patch... ...some people just need to be slapped!! and others just need to listen to people who kn

Posted Images

  • 4 weeks later...

Im having a problem setting up BitComet Version 1.6. The message Im getting on the bar at the bottom is a yellow icon with a message that says the listen port (which I have set for 60002) is blocked and to check firewall and NAT router configuration. At the statistics tab it says that both the UDP and TCP listen ports are bvlocked by a firewall or router.

My operating system is Win Vista.

Ive tried to follow the guides, but what Im seeing in the various dialogue boxes doesnt match the screen shots in the guides. Ive tried both setting the exceptions in Windows firewall and the Router static IP setup, coming as close as I could, but neither worked.

My internet connection is through a ZTE MF626 USB modem, but from what I have read in the guides it appears that the modem is recognized as a router. When I did the ipconfig it came up

Dirección IPv4. . . . . . . . . . . . . . : 10.9.94.8

Máscara de subred . . . . . . . . . . . . : 255.255.255.255

Puerta de enlace predeterminada . . . . . : 0.0.0.0

O yeah, the other thing is Im using a spanish version of Vista which doesnt make it any easer and the service provider is Claro Guatemala.

At any rate, the ip address and gateway (puerta de enlace predeterminada?) are different.

Any advice would be appreciated

Thanks

Link to post
Share on other sites

You are definitely behind a router, because your IP address begins with 10. The whole 10.xxx.xxx.xxx address block is reserved for private subnets and can't be legally used out on the internet proper.

The question is, whose router is it?

Your modem is not a router. It is a cellular-type modem. All cellular modems that I've encountered so far, and the vast majority of all wireless connections of any sort, are on private networks, behind routers and more importantly, behind firewalls.

This is a router/firewall that you do not control, and as a result, probably cannot get an open listen port set up on. (All port-forwarding instructions re intended for routers/firewalls that you control and can configure yourself.) Most large networks won't even discuss setting up a static IP and open port for you, and the cellular providers especially won't. It could too easily interfere with other customers, and fail to provide you service up to their promised standard.

That means you'll probably have to stay in no-listen mode, and just accept the lower speeds that means.

Link to post
Share on other sites

Hello i have a Linksys rouder i have opened the ports as i should which i have it on a random port which is 14885 and i'm trying to see what is wrong with it. so the thing i'm downloading has 4/74 and the Ip is blocked i have tried closing my router firewall which didnt work i have all ports opened on this computer which didnt work can you help me with my dilema?

Link to post
Share on other sites

@ Trelltan: Not unless you read and provide all the info from the "Read This Before Posting" announcement on top of this section, along with a detailed description of what steps you have followed trying to correct the problem.

Just "i have opened the ports as i should" doesn't cut it.

Link to post
Share on other sites

i have done all the steps i can take but i'm on Windows XP Black and i am still receiving a block signal on bitcomet i have registered network and that didnt show up i d/c my connection and did it through that way didnt work also i have added the Nat port mapping device through firewall etc.. and still nothing i do not know what i did wrong or why it is blocking. please help me :(

Link to post
Share on other sites

can anyone make a very fed up man reinterested in this crap that goes on .

I have two computers ,one with vista home ,the other with xp and i am an orange live box router broadband customer .The xp (in fact two xp machines ) are showing with port forward open and always have .

The vista machine i have never been able to get it working with the same port ................

I have been with this internet thing right from the start and i am no novice by any stretch of the imagination ( but am i ,i am starting to ask )

the way the net is going is the way real life is in our day ..........a one that keeps people in the dark ,and by that token things will always be kept one step ahead of you untill whatever it is they want is so ingrained that we truely believe we cannot do without it .............slowly taking the means to make desisions out of individual hands .its called the squeeze ,and well tried and tested ( but it doesnt stop us falling for it every time )

So why isnt the vista machine accepting the same port as the xp machines ..............because the new machine wants something from you ....it wants you to walk blindly into whatever it is they want ( while making you think you have walked that way to get something you wanted )

Yes and every angle is covered as if you revert back to an old system .....you are left with a load of componenets out of your hard earned cash spent that you have to break laws to stay with what you know how to use ( remembering who and whatever THEY are ,do not want you to know )

But we follow the rules just like fools ..............because we believe we are resisting .

forget it,ill probably have it uninstalled before i get an answere

Edited by Zelat0r (see edit history)
Link to post
Share on other sites

Apologies if this is not the right place for this post - I'm new.

A detail about the advice on opening the Listen Port that I didn't find in the Help areas is that you need to turn off SPI (Stateless Packet Inspection , I believe) in your router as well as turning off its firewall.

I have a Huawei EchoLife HG520b router and it has separate options for Firewall and SPI, on the same page. When I eventually disabled both of them the Listen Port was opened immediately. Previously I had enabled UPnP as your Help instructed. I found this idea on another forum.

Link to post
Share on other sites

@Zelat0r: It's virtually impossible to give you an straight answer based on the nearly inexistent information you gave about your setup and the steps you followed so far in order to fix that.

A few posts above I've indicated the minimum necessary info from which one may start to draw a conclusion.

A few pointers though, are these:

  1. you need a unique port number for every machine running a BitTorrent client on your LAN. And that port number must be forwarded towards that machine on the router;
  2. You also need a static IP set up for that machine; that IP you will use on the forwarding page of the router.

But if you really can't solve it you need to start providing all the info required.

@docdoob: Actually, most routers I've seen don't have a SPI (Stateful Packet Inspection) option, separated of the firewall. But it's good to know, anyway, for those using the same model as you.

Link to post
Share on other sites

docdoob, that's a pretty strange configuration, but whatever.

"My firewall is turned off. So I'm going to, what, just look these packets over but not do anything with them..." the purpose of this eludes me.

Sounds like it didn't work for them either, so Huwaei didn't implement it that way. They just left everyone confused about it.

I really dislike using UPnP for router configuration. It seems to have surprises like this in store when it does actually work.

Link to post
Share on other sites

Your message makes my head hurt. I started picking it apart, beginning with "What's XP Black?", and going on to tell you about the invention of punctuation and the paragraph, when my system crashed. Probably just as well.

Why not ask your question again, making liberal use of those two innovations and providing lots and lots of information, like whether you have a router of some sort, and what sort that might be? Things like that, you know?

Link to post
Share on other sites

never mind i have given up on Bitcomet lol

It doesn't matter you give up BitComet. BitComet is a free software. But I think you will give up next according to your attitude towards problems.

All BT clients act the same, if you do not setup properly, it can not get the optimal performance. If you just want to igonore the problem and switch to another whenever you have any questions, you will never be able to get best download speed with any BT client.

Link to post
Share on other sites

Sophia, as a Spanish proverb says (even if kluelos, thinks that they're all very weird :lol:)...

"You could have said it louder, but not any clearer."

:)

Link to post
Share on other sites
  • 2 weeks later...

Since the past five six months; I'm struggling to get the green light. Sometimes it gets green; mostly it shows orange; with serious lowering in the download rate.

The thing I want to know is, if this is triggered by the ISP, will forwarding the port do any good. The thing is my ISP sucks in the tech division; I've asked for my DNS address several times; but they are not providing it (God knows the reason). So if port forwarding is useful even if the ISP has blocked bit comet's IP ranges; I'm planning to go to the higher authority to get the DNS (I didn't find that in my MODEM's status section; so ISP is my hope now.

How I was happy with the performance of BitComet till all this mess came along !

Link to post
Share on other sites

Still the same issue; logged into the comet passport in 1 second; but status shows 'Detect failed' and is gray.

Checked again, to get 'IP BLOCKED'

Tested the same with U & Bit torrents; which went to green in under 3 seconds. I guess my ISP is responsible; is there any hope for me via port forwarding ?

Configuration:

CPUs : Intel P 4 HT 3 & AMD Athelon 2.4

OSs : XP SP3 & XP SP2; both 32 bit

Connection : 2Mbps broadband

Modem : Nokia Siemens C2110

Bit Comet Versions checked : 1.15 - 20100111 (beta); same issue in all versions.

:(

Link to post
Share on other sites

You do seem to want to blame your ISP. They're probably not an issue. It's more likely to be your understanding.

For example, you say, "I've asked for my DNS address several times". At once the question indicates that you aren't clear on what you're asking about. I have to guess at what you mean.

Do you seek the IP address of the DNS server? Or do you seek your own IP address?

The former isn't going to be any kind of secret, and they will answer immediately, but you do need to ask the question properly so that they understand what you want, viz, "what are the IP addresses of your DNS servers, please?" Or you can simply plug in the addresses of the free servers from OpenDNS (google em), or the free DNS servers from Google at 8.8.8.8 and 8.8.4.4

If it's your own IP address you want, then you do not need the ISP's help and you don't need to take up their support time, to find this out. Just browse to whatsmyip.com to find your own IP address. If you are connecting via a router (this is critically important information), this will basically be the router's IP address. Your computer will have a different one which the IPCONFIG utility will tell you. Your ISP can't help you with that, it's your subnet and not theirs.

The most common case, and yours appears to be one such, is that you have one or more firewalls blocking your listen port. Commonly this is not because of your provider, it's because of your own system settings.

Your best bet there is to start reading this thread over from the beginning. You will find all of the information you need here, and several examples. You'll need to work through this to the point where you understand exactly what it is you're trying to do.

Link to post
Share on other sites

I don't want to sound rude; but have you ever heard of dynamic IP ? (192.168.1.2/255.255.255.0/192.168.1.1 - for about a billion users)Mine is such a connection; where both IP & DNS are assigned automatically by ISP server.

I didn't know IPCONFIG will provide IP & DNS in a dynamic connection :lol: . Also, most of the public DNS from OpenDNS failed to have a fix on the link (mine is an 'always connected' connection), so I relied on ISP, once again. And on the tech issue; where I'm from; the techs do not know how to differentiate a pink elephant from a router. I'm having a faulty line since a week; with about 2-3 written complaints to the L-1 tech; I'm still waiting for something to happen. On asking about DNS; they simply are saying they do not know much about that; contact the higher authority ! World is a funny place sir, if you think everywhere you have the same standard; I'm sorry to say you are terribly WRONG. (P.S. I'm from India; that kind of gives you the picture of the 'techs' who are employed in public firms)

Link to post
Share on other sites

I'm sorry to break it to you but you are in error and you don't even know it.

You seem to be at that particular point where you got some networking notions but not all the notions which allow you to get a complete and correct perspective of a network setup.

Let's take it, one step at a time.

First of all you fail to read and understand well, even the posts made in reply to your questions. I say that because kluelos has specifically told you in his previous post that you must first take into account if you use a router or not. As you mentioned in your other topic you have a modem/router device Nokia Siemens C2110.

We can't guess if it's working in bridge mode (thus giving your PC a public IP) or in NAT router mode (thus assigning a private IP to your PC).

But since you mention the 192.168.1.x IP range I have to assume that your PC has a private IP assigned to it, by your router.

For your information, the ipconfig command always provides you with the IP assigned to your computer. And with a DNS address. It just so happens that if you use a NAT router these will be local private IPs, not your public IP.

The public IP (which can also be dynamically or statically assigned by your ISP) will be held by the WAN interface of your router in that case. Many times that can be found on the Web interface of your router.

As kluelos also told you (but you failed to understand), in that case your public IP address can be easily found by navigating to a site such as whatismyip.com which will always tell you your public IP, no matter how many NAT routers sit between you and the Internet.

OTOH if you only have a simple modem or your modem/router is in bridge mode then an ipconfig command will show you your public IP and DNS, irrespective if they are dynamically assigned by your ISP or not.

I hope that by now you managed to understand that whether your IP is dynamically assigned to your PC or not has no bearing whatsoever on the results of this command. If you get returned by it either your public or some private addresses, it depends only on your local network setup (using a router or not).

Furthermore, the screenshot you provided is related to Reverse-DNS which is an entirely different thing than DNS. You really need to make an effort to read, inform yourself and understand a notion before using it as an argument in a debate.

Last but not least, I've already answered you in your other topic, that the behavior of your BC client seems particular to a UPnP mapping which doesn't succeed all the times. And I recommended you to disable UPnP and perform a manual port forwarding as a means to get a constant green light.

Your reply was and I quote "I tried the port forwarding; but it secures the same traffic rates; so I switched back to UPnP & dynamic/random port scheme". So you dismissed my advice and returned to your previous setup.

But the real question was: Did that fix your yellow light for you or not? And why did you return to your previous setup if it didn't show better rates?

Besides in this very topic you seem to contradict your previous statement and say: "Sometimes it gets green; mostly it shows orange; with serious lowering in the download rate".

So which is what?

And if you dismiss our advice and have it your own way, what exactly is it you would want us to do?

You need to either acknowledge that your networking knowledge is not sufficiently advanced and take to heart and learn what others tell you on that matter or if you believe you know enough, try to solve your problem on your own.

Because if one moment you ask questions and the next moment you think you know better, then you're only waisting our time. And yours.

Link to post
Share on other sites

You do appear to have some holes in your understanding. Reading this thread, from the beginning, will correct most of those. It was written exactly for people whose understanding of networking is insufficient, and especially for those who've learned just enough to confuse themselves.

All of your questions are answered, but you do have to read it for yourself.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...