Jump to content
Comet Forums

How to Set up Portforwarding & Static IP Reply thread.


Recommended Posts

That's correct. It sends a probe to your listen port and sees a service there, so your port is definitely open. But we're not at your house, or sitting in front of your computer, we don't know anything about your software, your connection or what upgrades you've done.

Link to post
Share on other sites
  • 1 month later...
  • Replies 506
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

You don't know what you're talking about. There is a ton of misinformation about that "limit" floating about the net. That limit of 10 incomplete outbound TCP/IP connections per second. It is not a l

i followed this guide and i finally got decent speeds -thanks- oh and about that patch... ...some people just need to be slapped!! and others just need to listen to people who kn

Posted Images

Port forwarding offers the convenience of allowing remote computers access to specific ports within a local area network.First go Control Panel, Network Connections, find the network connection that represents your connection to the internet. Most often it's labeled simply Local Area Connection. Right click on that and select Properties. Now click on the Internet Protocol.Click on Use the following IP address: and enter the IP address, subnet mask, and default gateway information that your ISP should have given you.

Link to post
Share on other sites

and enter the IP address, subnet mask, and default gateway information that your ISP should have given you.

The great majority of ISP's throughout the world, will not have given you an IP address, subnet mask or default gateway address, and if you ask them to, they will tell you, "$orrry, $ir, you don't have that $ort of account. I would be happy to $ell you one!"

Then she will mention the cost of a static IP address account and you will say, "Um, gee, no thanks." That's fine, because you absolutely do not need one.

Disregard this awful advice. Don't listen to it. If this is your setup, then YOU DO NOT NEED TO FORWARD A PORT because you have no external firmware firewall to forward it through.

You only need to forward a port if you have a router (or something similar) which contains a built-in firmware firewall which you don't want to turn off. (That's good, firmware firewalls are better and more secure.)

If you don't have a router, which most people don't (it's an electronic device, about the size of a paperback book, that you plug into your broadband modem and can then plug multiple computers into) then you don't need to forward a port and will just become confused if you try.

What you DO need to do in this situation is to open a listen port in your software firewall. If you just use the one that is built-in to windows (and it's all you need, all you should use), then BitComet can configure it automatically for you. See our settings guide for how to do this. BitComet will open and close the port as needed without you having to touch it.

If you use a third-party software firewall, which you should not, then you must follow the manufacturer's directions about how to open your chosen BitComet listen port in that firewall. Or you can and should uninstall that firewall and just use Windows'.

Link to post
Share on other sites
  • 3 weeks later...

Hello everyone.

Just been trying unblock the listening port like everyone else in this thread. I've done it before when I was using XP but since I've changed over to Windows 7, I am finding it very difficult. I've pretty much spent about 6 hours solid trying to get it open.

The things I've tried:

-Set BitComet Listen Port to 57753 and tried with/without UPnP Mapping

-Port forward as usual with the port 57753 and assigned a static ip on my computer.

-Set port exceptions on Windows Firewall for 57753 on UDP/TCP in Public, Domain and Private.

-Tried setting Port Triggers as well (dont know if I was correct).

-Even went as far as turning the SPI Firewall off on my Router.

All these things didn't work for me at all and its starting to annoy me a lot. What annoys me more is when I check at http://www.canyouseeme.org/

it says:

Success: I can see your service on xxx.xxx.xx.xxx on port (57753)

Your ISP is not blocking port 57753

Now, unless I am imagining things, this should be telling me that my port is opened and that BitComet listening port should be unblocked.

Im currently running:

Windows 7 Professional 64-bit

NOD32 Anti-virus (doesnt come up on boot and doesnt start unless I open it)

BitComet v1.10 (Dont think version would matter)

Windows Firewall (No Third party firewalls)

TP-Link TD-W8960N Modem Router

Network setup:

MyComputer -> Switch -> Modem/Router

Any help to where I am going wrong is greatly appreciated. If more infomation is required, just say. Cheers.

Link to post
Share on other sites

The yellow light indicator is an indirect measure and it can be wrong. The test at canyouseeme.org is definitive, as is the presence of REMOTE peers. They mean that no matter what any other indicators say, it is possible to get through your firewall(s) -- that your listen port is open.

In earlier days there was no yellow light, no such indicator, and we relied on external tests because they were accurate. We talk about this at length earlier in this thread, but that's the bottom line. Either of those tests is definitive, so ignore the indicator.

Link to post
Share on other sites

Yes I could see Remote peers but even though, I was downloading at a very slow rate.

But none the least, I've upgraded to the latest version of Bitcomet and my listening port has sorted itself out, green all the way.

I didnt think the older version I had would matter for this problem but I'm very happy when Kluelos told me it can lie.

Thanks for the help Support Team :D

Link to post
Share on other sites

Hi, I seem to be going round in circles regarding static ip address and port forwarding. I am running XP Pro SP3, I use AVG Free antivirus and I use Windows Firewall. ADSL up to 8meg (usually more like two if I'm lucky) My router is a HUAWEI EchoLife HG520b. Also I use BitComet 1.21. I have attached a screenshot of the result from the CMD window. It doesn't seem right as it doesn't give all the details. I have done everything as advised by Portforward.com but port 18833 is still showing as blocked. Over to you!post-57593-12755600877675.jpg

Link to post
Share on other sites

You have two ethernet adapters, one you're not using. That isn't a problem: so do I.

You're using your wireless Ethernet adapter to connect to the internet, so that's the one you need to pay attention to.

Look at the details of its setting. There's a line that reads,

DHCP Enabled ........... Yes

This means you have not told your computer to use a static IP address for this adapter. DHCP means Dynamic Host Control Protocol, and that's what devices use to request and be temporarily assigned, an IP address from the host device (the router in this case)'s available pool of addresses.

It means, in short, that you're using a Dynamic IP address, not a static one.

You need to consult and follow the wiki guide that Wiz linked to.

When you've done it properly, that line will say NO instead of YES.

Link to post
Share on other sites
  • 2 weeks later...

ok, I need some major help here

in my BitCommet Statistics

my listen port of TCP and of UDP both say, (Blocked by Firewall/Router)

yet my widows firewall says, Added [TCP opened UDP opened]

and my UPnP NAT port mapping says, Failed [uPNP device not found!]

I went to help -> BitCommet Help -> Frequently Asked Questions -> I have a yellow status light and my downloads speed are slow. What should I do? -> Add Port Mapping in NAT Router Guide

I then scrolled down for Windows Vista step by step instructions

On the first step the portforward link was no good because all instructions have been removed from the site and replaced with an ad page to buy their software for $29.95 but I was still able to find step by step instructions for what to do by searching "westell port forwarding" in google.

in step 5 it says (and the same for eMule if it's enabled) but I have no idea what eMule is or how to input this so I skipped this and just did the TCP and UDP

I then closed BitCommet and re-opened BitCommet with no results

I then went on to read Manually Configure Port Mapping at Router setup page

here for the second part of step 2 I had to get my primary and secondary DNS address from my router by typing my ip address in my browser, only in these instructions it shows the secondary left blank and the primary is the same as the gateway, so I tried doing both and neither worked.

Still Blocked !!!

I made sure it wasn't my Firewall a long time ago, and double check it and it's good. I even disabled my firewall several times during these steps and still my listen port is being blocked.

I've been back tracking my steps over and over and over... nothing works

What am I doing wrong? What did I miss?

My router does have a UPnP option, why won't it work?

I tried setting up a static IP, why didn't that work?

Do I have to reset my computer? I haven't tried resetting my computer yet?

Link to post
Share on other sites

I just tried https://grc.com/x/ne.dll?bh0bkyd2 and got

Ping Reply: RECEIVED (FAILED)

22594

Stealth

Unknown Protocol for this port

Unknown Application for this port

--------------------------------------------

I just tried canyouseeme.org and got

Error: I could not see your service on xx.xx.xx.xx on port (22594)

Reason: Connection refused

???

I still can't figure this out...

Link to post
Share on other sites

If canyouseeme, or any other port checker says your port is open, then it is open, more so, it is in use by an app in your computer (in the case of canyouseeme). Shutdown bitcomet and test it with the port checker tool from portforward.com, to see if there's no conflict with another app. If that too says it's open then maybe the problem resides in a security solution you recently installed or misconfigured so that it blocks incoming connections for the BitComet client.

A screenshot would be helpful.

LE: I think I was a bit slow with this post, d*** cigarettes,,, <_<

Link to post
Share on other sites

First, the ad page at portforward.com pops up occasionally and can be skipped towards the page with the actual info, you don't have to buy anything.

Second, you can find info on the eMule plugin inside the very same BitComet Help Wiki site.

Third, the DNS addresses are not at issue at all here; if there are any mentioned in the ipconfig output, then you can use them in the configuration, if not you can just leave blanks there, it will still work. It is just the IP address of the NIC interface you need to worry about.

Next, even though you gave detailed descriptions on the steps you took, we know nothing about your client version, listen port number, your static IP address or what steps you took or missed on the router configuration.

Therefore we'll have a really hard time telling what doesn't work.

Link to post
Share on other sites

Sorry for the long reply...

Just going over this as much as I can on my own before making posts.

I went to portforward.com and read the info pages they had. I also downloaded the port checker, and after disabling the firewall on my router and on my desktop, and exiting out of BitCommet, the TCP says Could Not Connect and the UDP says Your port is NOT OPEN or not reachable

However, after disabling the fire wall on my router and doing canyouseeme.org again, I noticed the reason changed from Connection refused to Connection timed out

---------------------

Router is a Westell

Model Number A90-327W60-06

Software Version VER:4.04.01.04

Software Model 4 Port Gateway

Description WireSpeed Data Gateway

----------------------

3 computers are linked to the router, but all computers are directly linked to this router so there is no interference from the other computers.

here is a screen shot of my port forwarding I did on my router

16tafl.jpg

Is this set up right?

Edited by selective (see edit history)
Link to post
Share on other sites

it was the older version that was causing it!

No, it was not. No version of BitComet can cause your port to be blocked. You simply got lucky and the newer version of bitcomet was able to automatically open the port on your Network router. The cause of the previous problem was your network, NOT bitcomet.

Link to post
Share on other sites

After looking at it again. I found out exactly why it wasn't working on the old version.

Every time I tried a random generated port number, it would give me a number starting with 2 and for some reason they never worked. When I installed the new version it gave me a number starting with a 1 and I tried a few other random generated port numbers with it and they all started with a 1 and they all worked. So I tried using 22594 on the new version and it disabled it again, then went back to my new port number 18920 and now it works great again.

Yeah, I did get lucky. I wasn't aware it could give me bad port numbers.

Link to post
Share on other sites

There is no such thing as "bad port numbers".

There is a possibility that an application/setting on your system (for some reason) or your ISP blocks incoming connections on a certain range of ports.

Anyway, for the best results one should always use ports from the ephemeral range (49152 - 65535). That's because no application will register for a port in this range and they are more likely to be free than any other number.

Link to post
Share on other sites

Wow, I wonder if this is how urban myths get started. Bad port numbers.... is it the number that's supposed to be bad? Or is it the port itself, that just happens to have that name ...err, number?

Could you train it?

"Bad port! Bad, bad port! Sit! Staaaaaayyyy! Now, open wide! Good boy!"

Link to post
Share on other sites
  • 2 weeks later...

Hi there!!

HELP!!! I've followed all the steps on how to set up port forwarding and static IP but it still isn't working. Please help. I'm using windows vista. I tried it in XP, won't work either. It must be really my router. It's Linksys wrt54G. Please help! Thanks!!! :D

Link to post
Share on other sites
  • 2 weeks later...

Help... all i want is to be apart of the community..

Well, in that case you'll have to do a way better job on communicating, because I have almost no idea what you're talking about.

There is a Read This link in the header of this page. Try reading it and fill in the blanks.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...