Jump to content
Comet Forums
Sign in to follow this  
sancrage

Problem with LAN IP

Recommended Posts

Hi, I have a problem with Bitcomet where it listed my LAN IP as 127.0.0.1 which is a localhost loopback.

Default tracker optimization rules file loaded.

IP rules file: ipfilter.dat loaded, 0 entries.

Start Listening at TCP Port:16140

Start Listening at UDP Port:16140

Windows XP ICF Status: Firewall TCP port is opened.[Local Area Connection 3]

Windows XP ICF Status: Firewall UDP port is opened.[Local Area Connection 3]

Update Local IP: 127.0.0.1

Windows XP ICF Status: Firewall TCP port is opened.[1394 Connection 5]

Windows XP ICF Status: Firewall UDP port is opened.[1394 Connection 5]

Windows XP ICF Status: Firewall TCP port is opened.[1394 Connection 4]

Windows XP ICF Status: Firewall UDP port is opened.[1394 Connection 4]

Windows XP ICS Status: WAN IP: 76.**.**.**

Windows XP ICS Status: TCP PortMapping Successfully Added.

Windows XP ICF Status: Firewall TCP port is opened.[1394 Connection]

Windows XP ICF Status: Firewall UDP port is opened.[1394 Connection]

Windows XP ICS Status: UDP PortMapping Successfully Added.

UDP tracker report: WAN IP = 76.**.**.**

Connected to UDP helper tracker on 2006-10-08 22:18

And on my Dlink DI-524 router it automatically listed:

AllowBitComet (127.0.0.1:16140) 1614WAN,*LAN,TCP,16140

AllowBitComet (127.0.0.1:16140) 1614WAN,*LAN,UDP,16140

So the question is how to change it to my correct LAN address?

Any help/suggestions would be greatly appreciated

Share this post


Link to post
Share on other sites

For normal operations, most people and most computers, your IP should be dynamically assigned by the router. That means enabling DHCP in your network connection under TCP/IP properties. This will usually be either the class B subnet reservation (10.10.xxx.xxx) or the class C reservation (192.168.2.xxx)

Change your network properties to use DHCP, try it again, and observe this to assure it's working correctly. Your IP should now be in one of those ranges This is the way it should have been set up all along.

This also means that if you connect the computer to another network which supports DHCP, it will probably work. (Suppose it's a laptop, and you take it to school, or work, or a coffee shop with WiFi. It'll work on those networks without having to reconfigure network properties, and it'll work when you bring it back home and plug it in.)

-------------------------

Routers usually have built-in firewalls. They will block unsolicited traffic on all ports unless told otherwise. Bittorrent clients require at least one listen port for unsolicited connections, which is how other swarm members initiate contact with you.

For that to work, your firewall(s) must be opened to traffic on that listen port.

Most routers will not open a port generically, but only to specific IP addresses. This is a security measure. In order to open a listen port on the router firewall, you must specify an IP address, and your computer had better be at that address.

Dynamic IP's are dynamic: they can change. If yours changes, you are no longer at the IP address where the port is open, so for you the port is blocked by the router firewall. For this reason, use a static, unchanging IP.

If the router is using the class C range, as most of them do, then it behooves you to choose a static IP in that routable range. There are 265 addresses in that range, and the router will need one of those for itself. The others are, by default, dynamically assignable to whatever happens to connect to the router.

What you want to to is keep enough assignable addresses for your own needs (2 or 3 perhaps) while the rest are static. Then choose one of those static addresses, set your TCP/IP properties to NOT use DHCP and use the chosen address instead, with (optionally) the router's IP as the default gateway and DNS server. So:

Router IP: 192.168.2.1 (Skipping 0 because it confuses people)

Dynamic addresses Start: 192.168.2.2 Dynamic Addresses End: 192.168.2.4 OR

Dynamic start address: 192.168.2.2 Dynamic address Range: 3

Computer IP: 192.168.2.7 (Why 7? Why not? It could be 27, or 77, or 42, it doesn't matter. Just not 2.3 or 4)

Then open the listen port on the router firewall for that IP.

Share this post


Link to post
Share on other sites

I am in the same case (Update Local IP: 127.0.0.1), my local ip is:10.10.xxx.xxx and my public ip: 81.xxx.xxx.xxx but, I don't have any acccess to my router config. since I am NATted by my ISP.

So it's normal to have this ip in BitComet instead my real local ip ?

Sorry if the answer has been said before because I am not good in english. :mellow:

PS: Sometimes my real local ip is listed instead "127.0.0.1" in BitComet and I have this in log:

-----

Update Local IP: 127.0.0.1

Update Local IP: 10.10.xxx.xxx

-----

Share this post


Link to post
Share on other sites

on my PC Bitcomet (0.70) shows 0.0.0.0 for my WAN IP and my online IP is shown as my LAN IP :blink: (my PC is connected directly to my DSL Modem, no Router in use)

Share this post


Link to post
Share on other sites

What software firewall / antivirus are you using?

I don't have firewall, I have only the ICF of Window$ XP SP1 and my Antivirus is Kaspersky 6.0.

Share this post


Link to post
Share on other sites

Well both of you have Kaspersky so Im gonna guess that is the reason Bitcomet thinks your LAN ip is 127.0.0.1

Kaspersky must have some worm control or anti-hacker feature that is causing this.

Are you still able to download OK???

-if so then you can probably ignore this

Share this post


Link to post
Share on other sites

CSX, it's not a good idea to jump into the middle of a thread with a separate problem.

Your system's behaviour is normal and correct. If you don't have a router, you don't actually have a WAN IP, it's one and the same thing as your LAN ip. Not just "the same as", but "the same thing"

Share this post


Link to post
Share on other sites

Well for me, I guess it was Kaspersky that caused it because when I turn it off and started Bitcomet the log showed the correct LAN IP. But is their a way to prevent this when using both or is their settings in kaspersky that would fix this.

Share this post


Link to post
Share on other sites

Well for me, I guess it was Kaspersky that caused it because when I turn it off and started Bitcomet the log showed the correct LAN IP.

I confirm it !

But is their a way to prevent this when using both or is their settings in kaspersky that would fix this ?

Share this post


Link to post
Share on other sites

Hi again,

You knew that Kaspersky had a "P2P/File Sharing Protection" capabilitie which is verry rare in Anti-virus softwares (BitDefender has it).

Maybe that it is the cause, maybe it slows down the DL/UP rates also ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...