Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Bitcomet slows internet browsing speed, please Help!

Recommended Posts

Using Bitcomet v1.13

Wireless Broadband Internet, using HUAWEI Mobile Connect 3G USB Flash Modem (advertised to provide upto 3.1Mbps)

Port Forwarding Yes, both DHT and WAN are green and port(s) open.

Windows XP SP3, with built-in Windows Firewall configured to allow Bitcomet.

Antivirus is Avira AntiVir Personal v9.0

Speed Results from Speedtest.net:

Download - 0.35Mb/s

Upload - 0.02Mb/s

Ping - 313ms

Bitcomet Settings:

Enabled NAT/Firewall config in ICS/ICF

Enabled UPnP port mapping

Global Max D/L and U/L rates at 1500kB/s each

Max concurrent D/L tasks 10

Enabled DHT network; Enable Anti-Leech at Auto

Max. and Min. U/L rate unlimited

Long-time seeding enabled

Advanced Options:

network.max_connecting_connections 300 (max. simultaneous half-open TCP connections)

network.max_connections 150 (global max. connections)


I have been using Bitcomet for downloading torrent files for 3 yrs now and it had never before caused this problem but now whenever I start a file download on the client, everything else using internet becomes dead: browser, messenger, all other Windows programs using internet.

The problem has started since I switched to this Wireless internet connection (described above). Before that I was using a university broadband internet from LAN cable, and even though at that time my ports were not open (DHT light was grey and NAT light was yellow) and I used to get crappy speeds of max. 1-2 kBps, the browsing would still work fine alongwith torrent downloads.

Now since switching to this wireless internet, when a download starts on bitcomet, internet activity on IE/Firefox/Messenger/all programs svirtually comes to a halt. D/L speeds I get now on Bitcomet, range between 0-50 kBps, although I'm not entirely satisfied with that either.

I have tried the following: changing bittorrent client; switching off my firewall; changing listen port; disabling NAT/Firewall config and DHT; changing Advanced options of bitcomet as well as other options....but nothing seems to work, internet is just dead when bitcomet's active. Contacting ISP was of no help either, they had no clue of what I was talking about.

Please, Help will be very much appreciated; My download speed is already not too fast and having to stop downloading everytime I need to browse for something is annoying and causes them to take days to complete.


Link to comment
Share on other sites

Your Global Max Upload speed is way through the roof ! :blink:

This should always be set to 80% of your tested upload capacity, which for you is: 20kB/s*0.8 = 16kB/s.

All TCP connections use overhead traffic (connection control messages) which will get chocked up if you leave all your upload capacity available to the BitTorrent client. This will translate both in very slow download speeds and inability to use other applications connected to the Internet. And your BitTorrent client can have hundreds of simultaneously open TCP connections !

Besides, all the other applications will need some upload bandwidth too, for the same reason; protocols overhead (i.e. TCP/IP overhead, your browser's HTTP requests etc.). If they have no available bandwidth to use, it's only natural they'll stall forever. Hence the 80% necessary capping.

You should set your Max concurrent D/L tasks to 1 or maximum 2. The thumb rule is: no less than 8kB/s upload bandwidth per task but you'll want 10kB/s or higher to get better peers and consequently better download speeds.

Your network.max_connecting_connections setting is bound by the value set on the TCP/IP Limit, options page. But unless you're a very experienced network geek and you have a very specific reason, you shouldn't touch that default value which is 10. So, your network.max_connecting_connections should be set to something a little lower than the value on the TCP/IP Limit page (i.e. 8 or 7).

There are a lot of "tutorials" on the net, teaching you to patch your TCP/IP limit in order to "unleash" the hidden speed in your BitTorrent client. In fact they're all based on a terrible misunderstanding. This setting, both on the TCP/IP Limit page (which affects this setting, system wide) and in the network.max_connecting_connections (which affects specifically BitComet's share of the former), refers to the number of connection attempts per second ! Having this set to 300, puts a lot of stress both on your system and your router. For more detailed info read this guide, and also this one from the old forum.

So, as I said, you might want to set network.max_connecting_connections to something a little lower than the value set on the TCP/IP Limit (which you should leave on default) in order to grant the rest of the applications a shot at some instantaneous connection attempts, too.

For a complete guide regarding BitComet settings read this one from the Guides section of this forum.

Link to comment
Share on other sites

thanks a lot greywizard...

I've set the global max upload speed to 10, decreased the sumultaneous downloads to 2, changed the listen port to a large 60000+ value, changed the half-open tcp/ip limit to 10 and reset the advanced options to their default value...

am getting a consistently 45+ kBps download speed, as well as the rest of the internet seems to be working fine now as well...

just one more query: how should I change those other settings of BitComet, like NAT/Firewall config, UPnP port mapping, Long-time seeding, and those BT task settings. Currently the NAT/Firewall config is enabled, UPnP port mapping is disabled, and Long-time seeding is also enabled...will they affect performance as well??

thanks again Gandalf...

Link to comment
Share on other sites

... decreased the sumultaneous downloads to 2...

Keep in mind that in order to get best download speeds, the number of uploading tasks shouldn't be higher than 2 (for your speed). That is, you have to count both still downloading tasks and finished tasks which are seeding. So, if you have several tasks queued, you might want to temporarily pause some of those which are already finished in order to keep the number of running tasks at maximum 2. Of course you should continue seeding after finishing downloading, till you reach at least 1.0 share ratio.

am getting a consistently 45+ kBps download speed, as well as the rest of the internet seems to be working fine now as well...

Well, it seems that now you're downloading at the max capacity of your connection (350kb/s = aprox. 43kB/s). ;)
Currently the NAT/Firewall config is enabled
It should stay enabled if you are using Windows Firewall since it automatically configures it to open BitComet's port.
UPnP port mapping is disabled
Leave it disabled if you forwarded your ports manually. You don't need it. It is meant to automatically forward your ports through UPnP (activated both in Windows and router) but for some routers it works while for others it doesn't.
Long-time seeding is also enabled...
You can leave it enabled because it could get you additional seeds (LT seeds). Set it to Auto (if available), if not set it to 10% of your upload speed. When not used it will dynamically release that bandwidth for normal upload.
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...