Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Listen port blocked

Recommended Posts

1) What version of BitComet are you using?


2) What type of Internet connection do you have (ADSL, etc.)?


3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port?

Modem is a Westell mstatea and my router is a D-Link DGL-4500. Yes I have forwarded my port.

5) What version of Windows, Firewall and Antivirus do you use?

Windows Vista. No software firewall and Eset Nod32 Antivirus V4.

Ok I have been going through everything I can think of to fix this issue. I turned off the routers firewall and even put my PC on a DMZ using my router. I also removed the router and connected my PC directly to the modem. I have looked through my PC and am positive there is no software firewall installed and windows firewall is turned off. Eset Nod32 does not have a firewall. I am about to rip the hair out of my head. I am positive I have forwarded the port however as previously stated I took the router out of the picture with no luck. This is starting to piss me off as I have configured Cisco ASA's and PIX's but can't figure out how to get Bitcomet to work... any help is appreciated.

Link to comment
Share on other sites

OK I have a green light!

I swear I tried this a few times but it's working now so whatever... Basically I had to setup my modem to hand my router a public IP. Bam it works now.... I do think my modem has some issues. It disconnects somewhat often and it seems when I make config changes it doesn't always accept them. I used to have a Motorola modem that was awesome but it fried and I got this POS for a replacement...

I am curious though why it didn't work when I connected my PC directly to the modem. The PC was assigned which should allow all traffic however I just tested by giving my PC a public addy and that did work... dunno... don't care.

Edited by weedaholic (see edit history)
Link to comment
Share on other sites

That's because your modem is also a rudimentary router. It can be set to perform NAT and give you a private IP address. In which case you should have set port forwarding on both devices.

In your case it gave your router a private IP when it expected a public one.

But in these cases it's a better idea to just disable/bypass one of the NATs as you found out by yourself.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...