Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Computer using ICS has slow upload speeds on any torrent

Recommended Posts

Hello all and thanks for helping me out. First of all, I have researched intensively on this topic and I am not a newbie, but I have clearly run out of ideas on how to make this work properly. As you know from the topic my problem is I am having terrible upload speeds. Here's the overall situation of how the network is configured here at home:

- 2 PCs using Windows XP Professional.

- PC #1 has 2 network cards and receives direct internet connection from card #1, card #2 is used to share internet to PC #2 by connecting to a hub and then connecting to PC #2 (I know I could've use a crossover but I already had the hub and the cables, so...).

- Both PCs have been configured manually with their IP addresses. ( for PC#1 and for PC#2, PC#2 is also using as the gateway and ISPs DNS numbers).

- The gateway is configured to forward ports my BitComet is using (1720) for both TCP and UDP.

- The firewall is OFF on both computers.

My upstream is 600K, if I connect PC#2 normally without receiving internet through PC#1 I get upload speeds of 60-70k/s but using it I cannot get speeds other than 1 to 5k/s. It's driving me crazy! I've run out of ideas. Help anyone ?

Link to comment
Share on other sites

Hello friends! Thank you for those who have read and tried to help, I have finally found the responsible for this problem. It has nothing to do with configuration whatsoever, the problem was my onboard network card, which for some reason is malfunctioning.

It was not evident as the download speeds reached 400k/s without a problem, but after I left the computer pinging the other machine in the network all night long (only 4 pings wouldn't normally show packet loss) I found out there was a 16% loss. I first tried replacing the cables in my network, but no go. I then tried a Network card I had laying around and disabled my onboard lan and it works perfectly now. Same configuration as the old card.

Well, now it is documented. I love these forums for this reason, someone with similar problem might google it and come into this thread and fix their problem too. Who knows, some user might not know he has to do port forwarding for ICS or may even have forgotten sometimes it can be a hardware problem.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...