Jump to content
Comet Forums
Donde

MPCStar keeps quitting.

Recommended Posts

But its like im too attached to MPCStar @_@.

VirtualDub isn't an alternative viewer, it's a digital video tool. I'm not saying you should try a different viewer, I'm saying you should try to repair the file.

Share this post


Link to post
Share on other sites

Well, I've downloaded your file. Here's what I found out:

1.Your file is encoded with the latest version of WMV9 Advanced Profile, that is, the so called "VC-1" codec. I'm not sure, but it seems to me that even though MPCStar comes bundled with WMV 9 Series codecs, it doesn't include the WMV Advanced Profile codecs or at least it doesn't install the latest "VC-1" version. At least, on my machine, having MPCStar already installed, with all the codecs it came with, your file still didn't play neither in MPCStar nor in BsPlayer.

2.When I tried to open the file in WMP it automatically started to search for a codec and downloaded the "VC-1" codec. After installing that, your file did play in all my video players with no problems. (Hence, my assumption that VC-1 is not included in the WMV9 bundle of the MPCStar).

So, the file has nothing corrupt/bad in it, therefore I don't believe the problem you encounter is caused by the file itself. It must be a codecs (audio/video) related problem, I guess, which just arises when the filters needed for playing this file are loaded.

Please, open the ffdshow's video codecs interface (from MPCStar menu) and on the Codecs page check that at the VC-1 entry "disabled" is selected - not "libavcodec" or "WMV9" - for testing's sake and report back.

That is, whenever you feel like it or have the time. B)

Share this post


Link to post
Share on other sites

I concur. The file isn't damaged, so remaking it won't help. It is a codec issue.

Try opening it in Media Player Classic, to get detailed information from the error message, if you want or need to know all that.

If you have WMP 11 installed, then just open the file one time in it, and it should download and install the right filter automatically. (Far be it from Microsoft to simply make the filter itself available for direct download and installation. Is it that this would be too simple, or is it that it deprives MS of another opportunity to usurp your video file associations?)

This is a really graceless way of handling a missing filter, I have to say.

Share this post


Link to post
Share on other sites

Cant seem to figure out in what menu of MPCStar is the ffdshow at @_@.

Edit: wait found it, so u want the VC-1 codec enabled then, cus its already disabled ._.?

Edit O.o again: Alright well instead of leaving it disabled I enabled it to "libavcodec". So the videos I was trying to play , play now. But im gonna make sure im out of the woods, so Ima try playing any type of video file I have to check in case enabling the vc-1 codec doesnt interfere in some way that should make some other videos unplayable.

But enabling VC-1 codec shouldnt mess up any other kind of video play right? @_@

Edited by Donde (see edit history)

Share this post


Link to post
Share on other sites

Actually, leaving libavcodec enabled for VC-1 decoding, was the last solution I was gonna suggest. I meant first to check if you can make your other VC-1 filter (the one WMP uses) either work for all players or unregister it (checking that libavcodec is disabled was just a part of it). But if you find it solves your problem and doesn't interfere with the other one that was already installed you can cut it short and just leave it to that.

Technically, leaving libavcodec enabled for VC-1 shouldn't mess up playing any files encoded with another codec. As for VC-1 encoded files you'll have to check that up yourself, in every player you have installed on your system. But since you care most for playing your files in MPCStar, that, probably, won't be that much of a nuisance.

On that note, if you do find that this causes problems you can just unregister the other filter in order to avoid conflict.

Share this post


Link to post
Share on other sites

Well it seems everything is a-ok. Problem solved, pat on everyones back all around :lol: . Thanx to everyone who bothered to reply in this thread ;D.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...