Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Probleme cu Btcomet

Recommended Posts


Am o problemă apărută de curând.

Orice torent descarc, dacă închid calculatorul se șterge din lista de torente (rămân în calculator),

dar nu mai pot să fac seed.

Este vre-o setare din meniu?


I have recently encountered a problem.

All the torrents I download vanish from my task list after reboot (the downloaded files remain)

but I cannot seed them.

Is there any setting that fixes this?

Edited by Vasy
translated (see edit history)
Link to comment
Share on other sites


In primul rand, ce sistem de operare ai? Ce versiune de Bitcomet folosesti? Citeste aici.

Primul lucru pe care poti sa-l faci este sa inti in meniul File si sa selectezi "Import and Export", de acolo poti crea si incarca fisiere de siguranta cu lista de sarcini si setatile tale.

Problema e ca, dintr-un anume motiv, BitComet nu poate accesa fisierul "Downloads.xml" din folderul de instalare BitComet (ex. C:\Program Files\BitComet), sau acesta este defect. Mergi in acel folder si sterge fisierul "Downloads.xml" si restarteaza BitComet apoi, mergi in acel folder din nou si da click dreapta pe noul fisier "Downloads.xml", alege "Proprieties" si asigura-te ca nu e setat pe "read only" sau (vista) mergi in tabul security si seteaza contul tau ca proprietar al fisierului, si seteaza pe acces deplin. Porneste cateva sarcini in bitcomet, opreste-le, inchide bitcomet si apoi da restart la calculator sa vezi daca tot dispar.

Pe viitor, tine minte sa inchizi programul bitcomet normal inainte de a inchide calculatorul.


First in hand, what operating system are you using? What version of bitcomet? Read here.

The first thing you can do is to go to the File menu and select "Import and Export", from there you ca make and load backups of your tasklist and settings.

The problem is that BitComet cannot access the "Downloads.xml" file from BitComet's installation folder (ex. C:\Program Files\BitComet), for whatever reason, or it is corrupt. Go to that folder, delete the "Downloads.xml" file, restart bitcomet, go to the same folder again and right-click the new "Downloads.xml" file, then select "Proprieties" and make sure that the "Read Only" option is not ticked or (Vista) go to the "Security" tab amd make your account the owner of that file and grant full access to it. Start some tasks, stop them, then exit BitComet and reboot your computer to see if they vanish again.

To avoid future problems, exit BitComet properly before shutting down your PC.

Link to comment
Share on other sites

Salut Vasy,

Scuze că nu am citit suportul tehnic înainte!

Am SO WIN 7 64 bit, și BitComet 1.15.

A funcționat bine până acum trei săptămâni, după care, când închid calculatorul, dispar torentele descărcate.

Fisierul "Downloads.xml" nu este pe read only.

Am încercat și varianta cu închidere manuală a BitComet-ului și este tot așa.

Hi Vasy,

I'm sorry I haven't read the rules for technical support before!

I have the Windows 7 64bit OS and BitComet V1.15.

It worked well until 3 weeks ago, now, every time I shut down my pc the tasks disappear.

The "Downloads.xml" file is not read only.

I tried closing Bitcomet manually and it's the same.

Edited by Vasy (see edit history)
Link to comment
Share on other sites

O cauza a acestei probleme poate fi UAC, (User Account Control) o noua tehnica de securitate aparuta odata cu vista; inutila si enervanta (din punctul meu de vedere) Pentru a dezactiva UAC intra in meniul start, scrie UAC in casuta de cautare si alege "Change User Account Control Settings"


apoi trage bara pana la ultima optiune, de jos.


Apasa OK si restarteaza pc-ul.

Apoi porneste o sarcina si restarteaza din nou sistemul sa vezi daca problema s-a rezolvat.

A source for this problem, may be UAC (User Account Control) , a new technology of security, first implemented in Vista; useless and annoying (in my opinion )

To disable it, type UAC in the start menu's search box and choose "Change User Account Control Settings"

Then drag the slider all the way down to the bottom, click OK and restart your PC.

Start a new task in bitcomet and reboot again to see if it worked.

Link to comment
Share on other sites

The problem is quite likely with what MS calls "virtual storage".

BitComet has always stored its various settings and tasks in .xml files contained in the program directory, which is in the Program Files tree. That's very common, but it's also a very bad thing to do.

Windows is finally waking up to the idea, after twenty-five years, that it's a bad idea for applications to be messing around in the execution environment, so has taken steps to hide it from you.

What LOOKS like "C:\Program Files\..." is not. Instead, it's off in your individual username folder in the "Documents and Settings" tree. You may want to read up on this.

Wherever those .xml files are actually located, if BitComet cannot write to them when it shuts down, then it obviously can't read what it didn't write when BC restarts. The reason we most often see for this inability to write the file is a permission problem with either the file or the directory it's in.

Problema e cel mai probabil in legatura cu ce Microsoft numeste spatiu de "stocare virtuala" .

Bitcomet si-a salvat de fiecare data setarile si sarcinile in fisiere .xml aflate in folderul de instalare, care se afla in sectiunea Program Files. E un lucru des intalnit dar si rau.

Windows s-a trezit insfarsit cu idea, dupa douazeci si cinci de ani, ca e un lucru rau ca aplicatiile sa se joace prin mediul de executie, asa ca l-a ascuns de tine.

Ce ARATA ca "C:\Program Files\..." nu e. Se afla in sectiunea pentru contul tau din folderul "Documents and Settings". Poate mai cauti si tu informatii despre subiect.

Oriunde ar fi acele fisiere .xml, daca BitComet nu poate sa scrie pe ele atunci cand se inchide atunci evident ca nu va putea citi ce nu a scris cand pornste din nou. Motivul cel mai intalnit pentru care nu se poate modifica fisierul este o poblema cu permisia de a modifica fisierul sau folderul in care se afla.

Link to comment
Share on other sites

@Kluelos So if he installs Bitcomet on a different folder (maybe a different partition too) will BitComet be able to write to it?

Deci, daca el instaleaza Bitcomet intr-un alt folder (poate si alta partitie) bitcomet va putea modifica acel fisier?

Link to comment
Share on other sites

This won't solve the issue, alas. The biggest reason is not being able to control where BC stores its data. It's going to try to use OS calls to write to its own program directory and do this in whatever location that ends up pointing to. Now apparently, this sometimes results in writing to the actual program files tree, and sometimes results in writing to virtual storage. Or so it appears to me.

Whichever it is in this case, isn't as important as working with the actual location. I do wish BC would throw an error message when this happens, rather than letting it take you by surprise and then having to figure it out.

I would look at both locations. If only one has the .xml files, that's the one to fix. If they both do, I'd fix both.

Din pacate acest lucru nu va rezolva problema. Cel mai probabil motiv nu este abilitatea de a avea controla unde unde isi salveaza bitcomet datele. Va incerca sa scrie in propriul folder de instalare folosind apeluri la sistemul de operare oriunde s-ar afla acel folder. Aparent se intampla sa scrie in adevaratul folder Program Files sau in cel virtual. Sau asa mi se pare.

Oricare ar fi cazul, nu e la fel de important ca lucrul cu adevarata locatie. As dori ca BitComet sa arate un mesaj de eroare cand se intampla, decat sa te lase sa te ia prin surprindere si apoi sa-ti dai seama.

Eu m-as uita in amandoua folderele. Daca doar unul are fisiere .xml, atunci acela e cel cu pricina. Daca amandoua le au atunci le-as repara pe amandoua.

Edited by Vasy (see edit history)
Link to comment
Share on other sites

But at least it will make things easier as he won't have to figure out witch folder is the right one. If he installs bitcomet to let's say "d:\XYZ\BitComet" there is no other virtual XYZ folder, or is it? :blink: or he can try a zipped version.

Dar cel putin va simplifica situatia, pentru ca nu va trebui sa-si dea seama care folder e cel cu pricina. Daca el instaleaza BitComet la, sa zicem, "d:\XYZ\BitComet" nu mai exista alt folder virtual XYZ, nu? sau poate incerca o versiune arhivata.

Link to comment
Share on other sites

Yes, that's certainly so, but it assumes he has more computer sophistication than most users possess, and certainly more than his question indicated he has.

I thought of writing instructions for using a zipped version on the wiki, but I realized that if you're doing this, you don't need instructions or you need far more than a few paragraphs on a web site can give you.

Da, asa e, dar aceasta presupune mai multe cunostinte decat stiu majoritatea utilizatorilor, si in mod sigur mai multe decat a indicat intrebarea lui.

M-am gandit sa scriu un ghid pe wiki pentru utilizarea versiunilor arhivate, dar mi-am dat seama ca daca o folosesti nu ai nevoie de un ghid sau ai nevoie de mult mai mult decat cateva fraze pe o pagina de web.

Edited by Vasy (see edit history)
Link to comment
Share on other sites

Salut din nou,

Nu stiu cum și de ce dar a început să funcționeze corect.

Oricum mulțumesc de ajutor.

Sper să nu se mai întâmple, dar o să mai intru pe forum.


Hi again,

I don't know how or why but it started working properly.

Thanks for the help anyway.

I hope it doesn't happen again, I'll be back if it does.

Edited by Vasy (see edit history)
Link to comment
Share on other sites


Ma bucur ca cel putin aparent s-a rezolvat.

Pe viitor poti instala bitcomet pe o alta partitie si sa mergi la proprietatile fisierului, apoi pe tabul "security", dai click pe butonul "Edit" ca sa editezi permisiunile la acel fisier, asigura-te ca ai bifat "full access" si aplici noile setari. Ai inteles ce ai de facut?



I'm glad that at least it appears to be fixed.

Next time this happens install bitcomet into another partition and go the file's proprieties, then select the "Security" tab, click the "Edit" button to edit the permissions to that file, make sure to check "full access" and then apply the new settings. Understood?


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...