Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

lost new downloads


Recommended Posts

Ever since downloading newest version 1.15, whenever computer shuts down and restarts, all downloads both active and newly finished disappear. Unfinished files still show up in files on cpu but no active downloads appear in BitComet. All previous downloads, prior to update, still appear as active (either uploading, or downloading). This is really frustrating. By the way, I've clicked on "all downloads" tab at left of BitComet and none of the new ones appear.

Any ideas on a) where they went or B) how to reactive/reconnect or locate the new unfinished downloads?

Thanks in advance.

Link to comment
Share on other sites

Sorry about lack of info. Didn't and still don't think any of them pertain to this query. But here they are:

BitComet 1.15

Windows Vista x64

DSL no speed issues

Windows firewall (everything has been getting through until this version was installed)

avast! virus protection

Sorry if i've missed anything. I followed the directions in your link. Nothing changed after .xml.bak file was changed to .xml. Same files as before came up (already completed files). No files that had been recently selected to download were recovered.

Also, recently (a day or two ago) I deleted a torrent on the BitComet main page as it had been there two weeks and no download progress. I'm not blaming the program or software, no seeds I presume. But when I originally restarted the computer, and found this problem, I noticed that the file/torrent I deleted (delete task and downloaded files) previously was back up on the screen. This is the first time I've had issue(s) with this program. Up to this point I loved it. It's just frustrating to have to try and retrace my steps to find all files I was attempting to download.

Thanks again

Link to comment
Share on other sites

Sorry if i've missed anything. I followed the directions in your link. Nothing changed after .xml.bak file was changed to .xml. Same files as before came up (already completed files). No files that had been recently selected to download were recovered.

The reason why I've sent you to the wiki pages, was that I wanted you to understand the usual reasons why this is happening most of the times, which is BitComet's inability to write to the downloads.xml file. Obviously, you haven't understood, otherwise you would have realized that is was the second solution (under paragraph numbered as 2) which applied to you. The first solution is only for people who lost their entire tasklist (as you can read in the very title of that topic), which is a slightly different matter, and is not your case.

Also, recently (a day or two ago) I deleted a torrent on the BitComet main page ... But when I originally restarted the computer, and found this problem, I noticed that the file/torrent I deleted (delete task and downloaded files) previously was back up on the screen.

This thing (reappearance of the deleted task) has the exact same reason, which is: BitComet, for some external reason, can't write on the downloads.xml file. If it can't write it means that neither the newly added tasks nor the ones deleted, which are both changes to the said file, won't be saved. So the next time you load BitComet you'll find the old tasklist in place. So you'll need to check what is impeding BitComet from writing to that file.

Sorry about lack of info. Didn't and still don't think any of them pertain to this query.
Well, you don't think, but then again you'll have to leave most of your opinions at the door as they can be harmful (if they were good they would have lead you to finding a solution).B) As a matter of fact at least one of the pieces of info required is of crucial importance, which is the OS type. WinXP and Vista have quite different approaches regarding a lot of things related to system folders and file permissions.

Besides, for almost 90% of the users which require help on this forum we always end up asking for more details which they never provided in the first place, so, that's the reason that topic was put at the top of the page; it's the minimum required. You should also have specified for this case, what version of Vista are you using (Home, etc.) and especially if you are running an Administrator account or a LUA account.

So, as a bottom line: this file resides normally in the Program Files\BitComet directory. But Vista gets smart and doesn't let your applications perform write operations in the Program Files directory; instead it sends them to some virtual copy of that folder residing somewhere else under Your User profile folder or under All Users profile (thanks be given to Microsoft for repairing mistakes of the past by screwing up things the traditional way). So theoretically, it doesn't allow applications, by default, to write to Program Files but instead redirects their writing and, hopefully, reading operations to that Virtual Store folder. But if you have a copy of a config file (i.e. downloads.xml) in both locations it will, theoretically, always load the one in the virtual store first. You see now, that besides not being able to update the tasks file another reason for your problem could be that the OS supplies the wrong file to BitComet.

So, welcome to the Vista, Program Files folder troubleshooting nightmare.

First check that the file is not read-only. After that do this:

  1. check that your account has writing permission on the BitComet folder, under the Security tab (I'm assuming that you are running an administrator account, aren't you?). Here's the tricky part: normally Vista presents first the file from the virtual store (if there is one) to an application trying to read from the file. You really need to determine in which of these two folders %systemroot%\Program Folder\BitComet or %systemroot%\Users\%userprofile%\AppData\Local\VirtualStore\Program Files\BitComet does the old file (the one with the tasks from before upgrade) reside. After that you'll know what you deal with. So if the old file is in the virtual store just try and give it full permissions for the current or Everybody account. If it's in the real Program Folder you can try either of these: a)give it full permissions (and the whole BitComet folder), under the current account (or Everybody if you wish) and delete the other copy from the virtual store or B) move it from the real folder to the virtual store and make sure it has full permissions under the current (or Everybody) account;
  2. if that doesn't fix it then right-click on the BitComet icon on your desktop and check the Run as Administrator check-box;
  3. if it still doesn't work, turn off User Account Control or alternatively
  4. reinstall BitComet to a different folder outside the Program Files folder, preferably on another partition than the root drive. Then before running it, copy the old downloads.xml file (you'll have to find out in which of the two locations it resides) to the new program folder.

Try these and get back to us.

Link to comment
Share on other sites

I've tried all the mentioned tips. To no avail. I'm not sure if, when this originally happened, if I've done something before posting here to undermine your attempts to help me unintentionally. I'm going to go back and delete any unfinished downloads that had started and reattempt to download. I've performed numbers 1 and 2. Not sure by what you mean in number 3 (I'm a dumbass I know). I'll have to try and figure out which downloads hadn't yet started and are therefore completely lost.

I fully appreciate your patience and time. I now understand why you wanted/needed all that information.

There currently are no downloads in the archive or active. I'm going to start a new download, restart cpu and see if it comes back up.

I'll be back with the results.

Note: I'm not trying to ignore your advice, as I realize that there are two more steps, but I just want to see if this is something that I personally screwed up trying to repair this problem before coming you.

I may even decide to put all the required info into a signature for future inquiries.

Thanks again.

I'll be back.

Link to comment
Share on other sites

How to disable User Account Control: http://www.howtogeek...-windows-vista/.

Google is your friend.

I've just noticed (it slipped me) that you use the Vista 64 version. If at any point you begin to understand the steps I've explained to you you should know that when I pointed out to Program Folder\BitComet, it should have been Program Folder x86\Bitcomet.

There are other methods to try of course, but they are a little bit more complicated and I get the impression you didn't really understand very well even what I've told you so far.

I'm sorry but you seem to need a far greater level of hand-holding. But keep experimenting, you're bound to get somewhere in the end.;)

If at any time, you feel like picking up the discussion from where it was left, you should provide detailed explications with the results you got from following every of the solutions indicated.

Link to comment
Share on other sites

You don't need to reboot: you only need to stop and start BitComet, but with an awareness of what you are trying to do.

As Wiz pointed out, you don't seen to have that awareness. Let's try this.

BitComet keeps track of its tasks by writing them to a certain .xml file.

When you add a new task, which we'll label "task Alpha", to BC, it adds that task to its internal list and tries to re-write that list, to that file.

Therefore, you can add task Alpha to BC, then immediately shut BC down, and then start BC back up again. If the list got written to the file, and if you told BC to resume tasks at startup, then BC should try to read that file for its old task list and come up showing task Alpha in the list, in the same status (running, stopped, paused) that it had when you shut down.

If this doesn't happen, then it is because

  • The file never got written for some reason
  • The file can't be read for some reason, including that it was never written in the first place.
  • You don't have BC set to resume tasks at startup, so it didn't try to read the file.

It takes only the time to add the task, terminate BC, and start it up again, in order to see if something went wrong. It's not arduous or difficult to do this. You especially don't need to wait for Vista to ponderously reboot.

If the task list comes up blank, then first check again that BC is set to resume new tasks at startup. I know you just checked it, check it again. If it is now NOT set to do that even though you just did, then BC is having the same problems with its preference file, that it is having with its tasklist -- unable to write to, or unable to read from, the file.

If the task list comes up blank and BC is set to resume tasks, then BC couldn't read its task list. Use Windows Explorer to go and see if the downloads.xml file is there. If it isn't, that's the problem. If it is, open the file in notepad and look at it. You don't need to make sense of it, just confirm that it's not completely blank and you somewhat recognize the tasks it lists.

If old tasks keep coming back while new tasks disappear, then BC is likely not able to write to the file. When you restart BC, it reads an older version of the file containing those old tasks and NOT containing the new tasks -- because BC was unable to overwrite that old file for some reason -- probably either a permission problem or a location problem.

You will need to figure out which one it is, and to fix it.

Use Windows Explorer to navigate to the location where the file is supposed to be. Is it there? If so, can you delete it? If you can't, this is likely a big part of your problem, so fix that. If it isn't there, then can you create a file with that name using notepad? If you can't, ditto, ditto. If you don't see any xml files there at all, are you sure you're looking in the right place? You are almost certainly not, and need to triple-check.

Link to comment
Share on other sites

OK, lets start this over.

I just started two new tasks, shut down and restarted BC.

I had a few finished downloads, they are no longer on the screen.

I had two active/just started downloads, they are no longer there.

All files appear in the archive.

When going into archive, clicking on started files that are now not downloading, a message appears "The task you want to view has been removed. Do you want to open the torrent file and create a new task?".

Obviously, yes I do and so I did.

After clicking yes or OK or whatever, I then have to reselect the file(s) I wish to download. So I do.

New message appears: "The path you want to save already exists. It's likely to contain some uncompleted files you downloaded before ....

Yes to hash ..... No to change save path....."

I'm fairly used to this program. I obviously do not have your level of knowledge and hence, that's why I'm here.

I stopped going about it your way earlier Grey, not to offend you or question your knowledge. I did it to get a fresh start, fuller knowledge of what it or I was actually doing.

If we were all as knowledgeable of this subject as you, you'd be as dumb as the rest of us.

Link to comment
Share on other sites

Look, you still don't get it.

The reason why your 2 tasks were gone after restart, was explained to you in the posts above. BitComet still can't write into the downloads.xml file. Until, in some way, you eliminate or overcame that, things will stay this way. It's not up to BitComet at this point to fix your writing permissions on the file but to you. Yes, indeed, it is a good method to re-add your tasks from the Torrent Archive list but only after you have solved the first issue at hand. Restoring the tasks will do you no good at this point yet, except for testing purposes.

I was not being malicious when I said you don't seem to understand all the instructions I gave you; almost anybody can always find, someone who knows more than him in any area you can think of. Anybody can learn more from that person. That goes for me too; this is not a contest.;)

I was merely making an observation: it will be hard for us to help you troubleshoot this if you don't fully understand everything others explain to you and can't figure out how to put it in practice or why. Beneath some level there are some users which simply need to learn more, or so to say, to become more "computer literate" in order to understand some notions considered basic. This is needed as grounds for understanding more complex stuff. And we happen to encounter a lot of them.

If you feel confident that you don't belong to that category you can go ahead and try putting in practice the solutions we gave you above, and feel welcome to ask for clarifications if you're not sure about some particular points, along the way. On the other hand, if you don't trust us to come up with a working, viable solution for you, you can always, simply, stop asking.

But either way, good luck man! ;)

Link to comment
Share on other sites

Fair enough. I wasn't really trying to be malicious either. Just meant in jest, really.

I will retry your previous suggestions. I trust and know your knowledge on this subject is superior to mine. I've used this program for quite some time, without problems, and never bothered to learn the ins and outs of it. As long as the files were there, I was happy.

I apologize if I came off as an idiot (in any sense).

Your help truly is greatly appreciated.

Link to comment
Share on other sites

This part confuses me somewhat:

* How to manually backup tasklist:

Main Menus-> File-> Import and Export, Export .bc_bak files (these are backed-up files) . If your tasklist has disappeared when you restart your BitComet, do the following: Main Menus-> File-> Import and Export, import the .bc_bak files you exported previously.

-- not sure what to put in the export box

Link to comment
Share on other sites

If you click on the button with the 3 dots on the right, it will open a window where you can choose the location where the backup file will be saved and also provide a name for it. When you hit OK it will fill in the path automatically in the box you asked.

Basically, the box is there so if you already know the full path for the file, you can just type it inside directly, instead.

But you should keep in mind that this is wasn't meant as a solution for your type of problem, meaning that you'll probably get fed up pretty quickly to export and import the tasklist every time you open or exit BitComet.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...