Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Failed to Save Task List

Recommended Posts

Hi all

I just had to reinstall windows but managed to save all my unfinished torrents. The problem is whenever I try and resume them I get

"Failed to Save Task List

c:\Program Files\Bit Comet\Downloads.xml"

I have tried using the import unfinished download option and tell Bitcomet where the incomplete folder is (c:\Downloads) it usually manages to find the right torrent automatically (c:\Program Files\Bit Comet\archive)... but still it won't resume.

I backed up the Program files/Bitcomet folder before I reinstalled windows and may have messed things up by copying it into program files on my fresh installed windows! Then I downloaded and reinstalled Bitcomet.

The files are definitely still there, I just need a way of getting Bitcomet to resume them without complaining. Any help would be appreciated!

Link to comment
Share on other sites

This is a lot better than before -- BitComet would just fail and not tell you. Grr!

My sympathies about the reinstall. I went through that not long ago, and it's always a monstrous pain.

What you've almost certainly got, though, is a permissions problem -- BitComet not being able to write its task list. That can be a directory where the account it runs under doesn't have write permssion, or it can be an existing file that BC doesn't have permission to alter.

So, first go into the options and look at the Advanced tab. Check down near the bottom for a parameter, "system.use_app_data". If this is set to "True", then files like downloads.xml will be stored in your %appdata% directory. If it's set to "False", then they'll be stored in the application directory under Program Files.

The latter was the default for a long time, but also a really bad idea. WIndows finally got serious about trying to protect its operating environment -- a real "doh!" moment twenty-five years late -- and starting with Vista, gives you a hard time about writing stuff into the Program Files tree. This switch is the result of that.

So if this switch is set to "False", you might want to just set it to "True", where it really should be, then try again and see if the problem's now solved.

If it's not then recheck the %appdata% permissions -- often you need to check all the permissions for the entire tree and every node in it. The account you usually run BitComet under - normally your own - should own the directory and files, and have full control of both.

Link to comment
Share on other sites

You can also check this FAQ topic which deals with exactly this type of situations.

Since you gave no info whatsoever on your previous and current Windows version or the one of your client, you may find more specific info in here: Tasks have disappeared/deleted tasks reappeared in my tasklist after a BitComet restart. How can I fix this?.

Link to comment
Share on other sites

Hmm. Since we now have this error message, we need to add it to the FAQ, so that people searching for it can find the topic.

I'm not authorized to log in to this new FAQ so I can't.

Link to comment
Share on other sites

@Klulos: I've added this to FAQ in wiki here, I just copy and paste your answer to the FAQ, please let me know if I got anything wrong. Thank you.

By the way I'll ask the team leader to retrieve your account so you'll be able to login to the new wiki. :)

Link to comment
Share on other sites

  • 4 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...