Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

TCP/IP Properties Help

Recommended Posts

I followed all the steps, as in the tutorial "HOW TO SET UP PORTFORWARDING & STATIC IP", by Soraiya. However, when I changed from automatic IP address, to use the IP address, and clicked ok, I received this "Warning the default gateway is not on the same network segment (subnet) that is defined by the IP address and subnet mask. Do you want to save this configuration?" I clicked ok, and lost internet connection. I went back, and tried it again, and I got the same warning, so I changed it back to automatic IP. I am happy with my download speed (most of the time), but my upload speed stays around 1 or 2 (even when I set my max upload rate to 100 it only got up to around 10). Most of my uploads don't even get off 0. How can I fix this problem.

My info:

ISP Bellsouth

Bitcomet v1.24

Windows 7

Broadcom 440x 10/100 Intergrated Controller


AVG Firewall

Speed Test Results (server distance 100 miles):

Ping 1196 ms

DL speed 216.3 kB/s

Upload speed 15.3 kB/s

Thank you all for your time, and your help!

Link to comment
Share on other sites

That message appears when you're trying to manually set an IP address which is not part of the same subnet as the IP used by default gateway (which in your case is the LAN interface of your router). The two addresses need to be on the same subnet (obviously) in order for your PC to be able to communicate with the router and subsequently to gain from it, access to the Internet.

If you followed exactly the steps from the guide, normally, you shouldn't have run into this. Therefore you'll need to give us the exact IP addresses you're trying to work with, in order to figure this one out.

That is, post (text or screenshot) the results of an ipconfig command (when your connection is on default setting and working). Then also post the IP address, subnet mask and default gateway IP that you're trying to use when setting up a static IP so that we can verify that they're from the same subnet, because this looks at first glance as a misconfiguration from your part.

Don't be worried about posting your PC or router's LAN IPs on a public forum (many users inadvertently make this mistake) since these are ALWAYS private IPs (therefore, non-routable on the Internet) and hence of no consequence to your system's security.

As far as your speeds go, I'd recommend you to follow first the BitComet settings guide. Once you've done that, you can start troubleshooting your speed issues.

By the way, the ping response time seems awfully long. You should try to use several servers for testing at different times of the day, to see if you get similar results, or this was just a single case.

Link to comment
Share on other sites

Ok! I don't know what I did wrong this morning (other than my brain was too tired), but I finally got it right. Now, I am confused about the step that I'm supposed to take, where I "enter the static IP I want to forward to" (which in the tutorial states that it is 192.168.2.[ ], and in the space, enter the last digit of my IP address). I didn't see this step in the portforwarding steps. There steps were, as follows: I changed the UPnP (in BitComet Advanced Settings), set my "Listen Port" #, I entered my Internal IP address (Default IP) in the address bar (as their steps stated), clicked on firewall button, clicked firewall settings, (my PC name was already entered in the "select computer" box), clicked "Add new user-defined application", in "Application name" box I entered "BitComet", entered the port range # that I had selected to be my "Listen port" in BitComet "Options", clicked "Add definition", clicked "back" button, selected BitComet in the "Applications" list, clicked "Add" (to add BitComet to the "Hosted Applications" box), and then I clicked "Done". I then downloaded, installed, and ran PFPortChecker, I entered the port # to check & selected TCP, clicked "Check me", and it wasn't open. Therefore, I shut down all firewall protection Windows Firewall & AVG Firewall), tried it again, and (SUCCESS) it was open! Now, I need to know if I missed something somewhere, where was I supposed to enter the 192.168.2.[ ]? Also, I have selected BitComet as an exception for Windows Firewall, and I haven't figured out how to make an exception on AVG Firewall. I have the free version, if that makes a difference. As long as AVG is off, the port is open. In my AVG, I don't understand how to add BitComet & PFPortChecker. It keeps stating that the file doesn't exist. How do I resolve this issue (I can't be surfing the web without protection)?

My additional info (just to show that I am not as childish as Deeder):

IP address:


Default Gateway IP:

BitComet Settings: Global max dl-unlimited

Global max upload- 32

By the way, I love how you genuis, free-giving people put him in his place! You guys are GREAT, and I thank you for your time & patience! Sorry, if this post is too explanatory, I just wanted to show what I did in detail. Many thanks, again!

Edited by angel61968 (see edit history)
Link to comment
Share on other sites

No you didn't miss anything. Actually, the port-forwarding guide on the forum, while accurate is a little bit outdated therefore some info on the new-comers in the routers scene is missing.

You seem to have an NetBIOS-aware router and for those ones you don't need to set a static IP in order to forward your port.

There is a more extensive and frequently updated port-forwarding guide on the BitComet Wiki, under the topic Add Port Mapping in NAT Router, which includes instructions both for automatic UPnP-based port-forwarding and for manual port forwarding (the one you did).

The section for Manual Port Forwarding in that guide, actually covers NetBIOS-aware routers, so if you're interested in more info, you should peruse that. If you have any more questions after that, we'll be happy to answer.

Link to comment
Share on other sites

Multiple firewalls do not make you more secure. (If I can get through one firewall, I can get through two.).

Everything you do to configure one firewall, you must also do to all of the others as well. Multiple firewalls DO give you more pain.

The built-in Windows firewall has everything that most people need, and does not have a lot of things that most people do not need or know what to do with. That last bit can't be said of most 3rd-party firewalls including AVG's.

A firewall that is built into your router can't fail to start, can't crash, can't run out of memory, can't be interfered with or subverted by other software, doesn't take computer resources and just generally provides the constant protection you need without hassle. These are all goodness.

An external firewall must be configured. That's easy, but it's technical.

The windows firewall can be controlled by BitComet: it will open its listen port when that's needed, and close it when it doesn't. No other software firewall can be configured in this way.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...