Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Listen Port of TCP: Blocked by Firewall/Router

Recommended Posts

Client: Bitcomet v1.33

Internet: ATT DSL

Modem: Westell ProLine F90-610025-06

Router: Netgear WNR2000

OS: Windows 7 x64

Firewall: Windows Firewall

Antivirus: AVG Free

TCP Connections: Established: 31 [MAX:200] / Half-Open: 69 [MAX:100]


Listen Port of TCP: 25167 (Blocked by Firewall/Router)

Listen Port of UDP: 25167 (Opened in Firewall/Router)

Windows Firewall: Added [TCP added, UDP added]

UPnP NAT port mapping: Added

I have followed all of the guides precisely and cannot get the TCP port open.

Here's what I have tried (after each settings change, I restarted bitcomet):

I have set a static address for my laptop which is running through my router. I have then set up port forwarding for the aforementioned port. I then set up exceptions in windows firewall to allow the connections. No luck.

I enabled UPnP on both the router and BitComet. Bitcomet showed the port map added, but still no luck on the TCP.

I connected my laptop to the modem directly with an ethernet cord thinking the router was causing the trouble. Blocked. I then turned off my antivirus while still connected through ethernet. Still nothing. I then disabled my laptop firewall. Still blocked. So with everything disabled, it was still blocked.

https://grc.com/x/ne.dll?bh0bkyd2 gives the port a pass, but http://www.canyouseeme.org says Error: I could not see your service

When downloading, my speeds are hitting close to the max (up to 600KB/s), which is 750KB/s. This isn't causing any problem downloading, but now it has me perplexed and I am looking for an answer. I haven't found anything on Google or the forums here that have worked.

Is it possible my ISP is blocking the port?

Edited by thrice_eye (see edit history)
Link to comment
Share on other sites

As far as I can see you have two routers not just one, since other reports on the Internet seems to confirm that the Westell modem is also a router.

Therefore you should follow the section of the Wiki guide about cascaded routers.

However, if you're one of the unfortunate AT&T users which have received a stripped software version with the device that may not be possible.

You should then look in the web interface for a way to put it in bridge mode.

Link to comment
Share on other sites

AT&T never blocks ports on their wired connections, so you don't have to worry about that.

TO start, you should connect your PC directly to the Westell, and get your listen port open there. You don't need to open all the ports or anything like that, just the one listen port.

If you are using WIndows firewall, configure BitComet to automatically manage it. Now you need to make absolutely certain that you don't have another software firewall running. This isn't easy. They don't announce themselves. A lot of software comes with firewalls, so you'll need to examine every running process in Task Manager, to make sure it isn't a firewall. You have to get this bit sorted before moving on to the Netgear.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...