Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Strange port forward problem


Recommended Posts

I dual boot Win XP MCE/ Win7

4 MB ram and at least 2TB of free disk space

Latest version of BC

Lately I have noticed that Bitcomet has a problem accepting my listening port, It is forwarded etc. but will show blocked for ages until it finally finds a remote connection ( this can take hours) then it will fly.

Thing is I don't think that this is a Bitcomet problem since I can never get a response from canuseeme. either. Is it something with my system or perhaps my ISP.

This happens wether I am using XP or Win7

Any help or advice would be appreciated

Link to comment
Share on other sites

Without more info there isn't much we can do to help you. You mentioned that you forwarded your port but didn't mention what device it was forwarded through. My guess is this unnamed device is where the problem is.

Link to comment
Share on other sites

ps. info missing from your post

2) What type of Internet connection do you have (ADSL, etc.)?

3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port?

4) If you have more than one router, be sure to mention the make and model of both devices, how are they connected (i.e. in which connector of both devices is the network cable plugged) and which one of the devices is connected to or is the modem.

Also, if you have more than one computer make sure to mention in this case, to which router is every one of them connected.

5) What version of Windows, Firewall and Antivirus do you use?

Link to comment
Share on other sites

So Sorry, I was in too much of a rush and omitted the very basics, Also sorry for the late reply, things are a little hectic here ( am about to become a grandpa)

Routr is a tplink WR 1042ND and the modem is a Cisco EPC 3925 that is set into Bridge mode( i.e its internal router and wireless are disabled) ip address is static.

I can dual boot win xp/win7 but get the same problem

I use Mcafee antivirus and firewall

Connection is cable via UPC 30M up 3M down. All interconnections are cat6 for my pc, there are up to 6 other connections to the router but they are all wireless and do not use bitcomet

I have been running this system for quite a while now with no problems until recently.

What it seem is that Bit comet has a problem seeing the port initially (this can take hours and hours) and then suddenly it finds a remote connection, the green light comes on and and more connections fly in. The other strange thing is that Canuseeme.org will always give me a fail (time out)

Will try your suggestion of connecting direct to the modem in the morning (It is in another room and impracticable tonight)

Edited by gasman (see edit history)
Link to comment
Share on other sites

I think the best way to pinpoint the problem is to remove the router/s from the connection and if that fixes the problem you'll know the solution is in your router settings. If the port is still blocked, then it would most likely be a firewall on your PC.

Link to comment
Share on other sites

Fixed it at last.

You were right of course it was Mcafee causing the problem.

For years I was using Mcafee security center but for reasons that escape me I moved to Total Protection.

Although I had made sure that BC was given full permissions in the firewall it was still blocking BC and canyouseeme. Then after trawling through the awful Mcafee interface I spotted it.. a secondary firewall within the main one !! This thing is called netguard and it remains active even if the firewall is turned off. It requires manually setting up for individual programs.

Still have to figure out haow to get it to allow canyouseeme yet but I am over the main hurdle.

Many thanks for your help

Link to comment
Share on other sites

Oh No I didn't fix it.

After a restart the whole problem returned. Seems that bitcomet has a special talent for circumnavigating network problems if you leave it enough time to do it.

So this is what I did

1. tried (very naughty and hope Kluelos is not reading) dissing my Mcafee firewall. Result.. open port

2. Suspecting now it is a Mcafee firewall issue I enabled Windows Firewall. Result.. open port

3. Having PAID for Mcafee, I contacted customer support via webchat..... 1 hour later the guy just gave up and offered to put me on to a tier 2 support which of course I accepted. The tier 2 guy was like "in my room" almost scary and I could watch him controlling my pc, diving into Bitcomet etc. Even though it was 2hrs 23 mins before he got it sorted, but bless him , sorted it is and I am thankful.

I now get an almost instantaneous green light when I open bitcomet. All is what it was before.

Thanks for your help TUUS

Link to comment
Share on other sites


I would love to know the answer to that question myself but to be honest once you allow someone so obviously acquainted with their own product to access your machine it is impossible to remember all the steps he took.

All I know is that it wasn't easy, the fist tech gave up and passed it on to a "Tier2" tech who then spent the best part of 2 hours tweaking the system (including several re-installs and system reboots) before he cracked it.

I suppose the advice is simply to use the Mcafee online chat support, its free 24/7 and obviously works.

Bitcomet still running like a dream

Link to comment
Share on other sites

  • 2 weeks later...

Ok, if you have followed this thread, you will know that I dual boot xp and win7.

I used mcafee help to resolve the problems (and it was extremely successful) but I was booted into XP at the time. Trying to follow up on TUUS's request I have been trying to review what changes were made by Mcafee such that I can also get bitcomet fully working in Win7 which is presently presenting the same problems that I had in XP.

The problem is that I find the Mcafee interface extremely confusing and unhelpful, Yes I could go back to Mcafee help and get it sorted but surely I should be able to somehow look at the settings in my Mcafee/XP set up and duplicate them in the Mcafee/Win7 scenario such that I can post a helpfile here?

Bear in mind that it took a tier2 Mcafee tech 2hrs to fix the XP installation including several reinstalls and rebbots.

In short Bitcomet flys in XP but crawls in win 7 because of slow recognition of my listening port(it will eventually get it) I also cannot get a response from canyouseemee.org in win7 without first disabling Mcafee but XP works fine following the 2 hr Tech intervention.

Anyone out there that is familiar with Mcafee Total Protection?

Edited by gasman (see edit history)
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...