Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Running Bitcomet shuts down my internet connection

Recommended Posts

I actually started to get this problem about 3 weeks ago with uTorrent installed. We started losing connections, and I finally realized it was uTorrent causing the issue. I uninstalled it and installed BitComet, and for several days it all worked fine, and then suddenly I started getting the internet shutdown again. It happens within a few moments of starting Bitcomet, and usually resolves within a minute of it being shut off. It affects all the machines in the house, not just the machine with Bitcomet on it. I've tried adjusting a number of settings, but nothing has relieved the problem...the best I have gotten is for it to take slightly longer to kill the internet once BitComet is started.

1) What version of BitComet are you using?

BitComet (64-bit) 1.36 Stable Release

2) What type of Internet connection do you have (ADSL, etc.)?

Comcast Cable Modem

3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port?

I have a Comcast supplied modem, which was just replaced last month (a Ubee D 3.0), running through a Belkin N750DB. I encounter this problem with the port forwarded, and without it.

4) If you have more than one router, be sure to mention the make and model of both devices, how are they connected (i.e. in which connector of both devices is the network cable plugged) and which one of the devices is connected to or is the modem.

Also, if you have more than one computer make sure to mention in this case, to which router is every one of them connected.

Just the one router, which all the devices work from.

5) What version of Windows, Firewall and Antivirus do you use? Is your Windows 32 bit or 64 bit?

Windows 7, 64-bit, Windows Firewall (it has an exception for Bitcomet), and Avast antivirus.

7) For speed-related issues, please run various speed tests at a site such as speedtest.net (make sure that no other computer is using your Internet connection and that all other programs - including BitComet - are closed, during the tests). Include the results, along with the settings that you are presently using, in your post, so that we may review and offer suggestions to improve its performance.

35.47 Mbps download, and .79 Mbps upload.

I've tried fiddling with a bunch of the settings based off suggestions all over the internet...here is where I am now. With these settings, when I start a torrent I'll get a download rate of about 200 kB/s for a minute or two, then the internet cuts out for everything else, and the download rate slowly dwindles to nothing over about a minute:

Global Max Dowload Rate: 200 kB/s

Global Max Upload Rate: 50 kB/s

Long Term Seeding is off

network.max_connections 100

network.max_udp_pky_per_sec 40

When I am running Bitcomet, the status bar tells me DHT is connected, but that my port is blocked (this is true whether I have port forwarding and a static IP setup or not)

If I look at the security logs on the router, I see a group of errors that seem to coincide with the shutdown. Here are some examples (they usually come in batches of 3-5). :

Warn: The origin for route XXX.XXX.XXX.XXX changed from to

Warn: The origin for route XXX.XXX.XXX.XXX changed from to is the router address, and is the Bitcomet machine. I have no idea what this warning implies is happening, or if it is relevant at all.

I'm feeling like I am just hitting a wall, and any insight would be great.



Link to comment
Share on other sites

This is a problem with your router, a common problem when the unit is unable to handle the numbers of connections required to run p2p. You've confirmed that it's not a problem with either uTorrent or Bitcomet because you have the same problem with both but for whatever reasons it took longer for it to surface with bitcomet. I think the first place to look is the manufacturer's support website/forum, it's very possible a firmware update has been issued to fix this if it's a common problem.

It also looks like DD-WRT is working on adapting their firmware to work in this model so you may have an alternative to use in the future.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...