Jump to content
Comet Forums

So confused about ports


Milke6623
 Share

Recommended Posts

BitComet says that my listening port is blocked. It is showing my PUBLIC IP. I am seeding (trying to) seed torrents to keep a ratio and I need to NOT use a proxy. Port forwarding is enabled on my router, but not sure what port to use? The router is Netgear R600. What do use? How do I enter my public IP instead of my internal 192.68. etc ? I am NOT connectable. I have turned off the firewall, same. How can I seed!!!?

Link to comment
Share on other sites

It's really not that complicated. First of all you can seed without an open port, but no peers can connect to you unless you initiate the connection, so the problem is they can't reach you when then need you to upload, then later when you get around to offering them a connection they may no longer need your help. This is why an open port is a good idea.

When they try to connect to you they have only your WAN IP and port number but you've moved your computer away from your WAN IP and it's hiding on your LAN (local area network). This is where the port number comes in handy. You instruct your router to send all traffic using that port number to go to computer A, which is done through port forwarding. You'll need to know the local IP of that computer which you can get by running the "ip config" command from a command prompt. Usually it's something like 192.168.xxx.xxx or in some cases it could be 10.10.xxx.xxx. Your listening port can be selected in your bitcomet options, the higher numbers are less likely to conflict so using any random port from 50,000 to 60,000 would be ideal.

Note, when changing your port it could take upto an hour for all peers to receive your new port number.

When the router is properly setup the connection coming from the internet reaches your router, it recognises the rule for the port number and forwards it to your computer where bitcomet is registered to use that port and the connection is made. If there are any firewalls in the way they too need to be open.

It's also important to note that you need full access to the internet, if a user connects using a cellular type connection, mobile broadband, 3G/4G, etc, you are most likely firewalled and have only a one directional connection. Most Cable, FIOS, fiber optic, dsl, etc are full bi-directional connections and work fine with p2p.

If you are having trouble setting up your router you can check the articles published on wiki.bitcomet.com for upnp port mapping, specifically the section on "manual port forwarding". There are also some good guides on portforward.com, just don't be distracted by their attempts to sell you software to do it for you. The software is usually more difficult to setup than doing it yourself which is really as simple as turning on a switch.

Link to comment
Share on other sites

Not complicated?? Really? haha ok, thanks for that. WEl, for a noob it can be

So, where doI find my pot number? When I ipcong /al do nt see ports

Forward the port wit which IP I my router? 192 is there by default. Do I entermy pubic IP? I disagree, this IS sort of complicated

. Do I eneter the port on the router? DO I need to port fowars my 192 address? Make up a port? Very confused. I just want to seed

Edited by Milke6623 (see edit history)
Link to comment
Share on other sites

If you'd like my help then I will ask that you use proper spelling and grammar. This is an international forum and some members browse using a translator and your post is incomprehensible.

Your port number is found in your bitcomet settings, just like I told you.

ps. the only reason you feel this is complicated is because of your choice to use your computer on a private network. If you remove the router and plug your computer directly into the modem you won't have to learn to be a network administrator, which you now are.

Link to comment
Share on other sites

It's possible you have some malware on that PC, I could (pretty much) understand what you were saying, but anyone trying to read it with a translator would be completely lost.

My previous message has enough info that should help you to get this resolved. Your port number is found in bitcomet settings. I can't be more exact than that because you didn't tell us which version of bitcomet you are using, but that doesn't really matter because with the smallest amount of effort you can find it.

Now if you think about the direction the incoming connections are taking, they come into your house just like a phone call, go to your router which is located at your WAN IP (96.11.xxx.xxx). You don't forward "to" this address because this is where your connection is before it gets forwarded. You need to redirect it to the proper computer, to find it's address you run the "ipconfig" command. You didn't tell us what windows version you are using so it's hard to be specific, but it will either list it as your "IP address" or "IPv4 address" and as I mentioned in most cases it will start with "192.168.xxx.xxx" or "10.10.xxx.xxx".

Hopefully you understand that the use of "xxx"s here are for the parts of this address that I don't know or have masked to protect your personal info. You have to enter these numbers correctly, you can't just "wing it", or take a guess, just as you can't call someone if you get their phone number "close", it has to all be correct.

In the end it's really as simple of telling your computer to send traffic on port number "54321" to IP "123.456.789.0". Of course these are just random numbers used to demonstrate. I'm also sorry I can't tell you step by step how to enter your numbers into your router since every router is different, but the principle is the same on all of them.

Here is the page I told you to read in the previous message...

http://wiki.bitcomet.com/add_port_mapping_in_nat_router

Although you should read the entire article, special attention should be paid to the section on manual setup.

http://wiki.bitcomet.com/add_port_mapping_in_nat_router#manually_configure_port_mapping_at_router_setup_page

Also make sure you don't have multiple routers. If your cable or fiber optic plugs into a device that provides your telephone or TV first, this may also be a router. If your routers WAN address is not similar to the one I posted above then you may have "cascading routers" which is also covered in that article.

I also suggested you could find help on portforward.com. I looked for a guide for your netgear R600 router but Google kept trying to correct that to model N600 so I'm not sure if you provided the right number. They have guides for most routers and often if they don't have you exact model, a similar number will use the same setup procedure.

Again, be careful not to get distracted by their attempts to sell you software to open your ports. It's usually a lot easier to open your port than to install software that will open it for you and if you want to solve this by throwing money at the problem you should contact one of your local universities or technical colleges and ask a professor in the I.T. dept to recommend a hungry student who would probably be thrilled to earn $50 by stopping by and either setting this up, or walking you through the process.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...