Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Listen Port of TCP: Blocked by Firewall/Router

Recommended Posts

Client: Bitcomet v1.33

Modem Router: Dlink DSL-2640B

OS: Windows XP, SP2

Firewall: Windows Firewall

Antivirus: AVG Free

TCP Connections: Established: 6 [MAX:Unlimited] / Half-Open: 8 [MAX:10]


Listen Port of TCP: 50123 (Blocked by Firewall/Router)

Listen Port of UDP: 50123 (Opened in Firewall/Router)

Windows Firewall: Added [TCP added, UDP added]

UPnP NAT port mapping: Added

I have followed all of the several guides in this forum and cannot get the TCP port open.

Here's what I have tried (after each settings change, I restarted bitcomet):

I did follow the instruction to disable the uPnP on Bit Comet option and try the manual port forwarding guide, set a static address for my desktop which is directly connect to modem router. I have then set up port forwarding for the aforementioned port. I then set up exceptions in windows firewall to allow manual the connections. No luck.

Then I've enabled UPnP on both the router and BitComet. Bitcomet showed the port map added, but still no luck on the TCP.

https://grc.com/x/ne.dll?bh0bkyd2 gives the port a result stealth.

I'm actually running Bit Comet for more than a year without any problem until recently I really tried various way but still not successful turn the yellow light to green.

Is it possible my ISP is blocking the port? Or my modem router is having problem? Because I brought my PC to try it at my friend house, without doing anything the light is automatically Green.

Link to comment
Share on other sites

I brought my PC to try it at my friend house, without doing anything the light is automatically Green.

This tells me that the hardware you brought with you to the friends house is working fine as well as all your software, so wither your router, modem or ISP is blocking incoming connections.

You didn't mention what type of internet connection you're using, if it's mobile wireless/cellular type of broadband you'll probably never have an open port, if it's cable, fios or (x)dsl you should be ok, so I'd try bypassing the router first, then look at your modem or anything else installed in the line which may also be a router. Your public IP is 175.144.126.xxx and your local IP is 192.168.1.xxx (xxx=0 to 255). If your router shows a different WAN address, it could be an address assigned by a modem/router combination, a Voip phone system, or internet tv system. That's most of the common causes.

Link to comment
Share on other sites

I'm actually tried both with cable and wireless in my house but it doesn't work well. when I brought the wireless laptop to friend house it working fine.

I'm only using a phone line splitter before the modem, and the direct connect to desktop with LAN cable. To diagnostic the the problem I believe by using wireless laptop will be easy way as it never have an open port as you mentioned.

My router setting showed the default gateway is 10.82.127.xxx but in the command prompt when I type ipconfig /all the default gateway is 192.168.1.x can I say I have a different matching of modem/router with local ip? Should I assign the static gateway in the internet connection? Or change the router default gateway to 192.168.1.x?

Link to comment
Share on other sites

Sounds like you have two routers, perhaps your isp or landlord has one in their control, but unless you can get a specific port assigned to you, your peers won't be able to initiate connections to you. Your internet IP is 175.144.126.xxx, then you have some device creating a local area network using 10.82.127.xxx, then your router creates another LAN at 192.168.1.xxx.

If you get your internet direct from the isp I would call them, if you get it from the building owner, you'd need to contact them.

Link to comment
Share on other sites

  • 4 weeks later...

I have used BC for a long time and suddenly my listen port is blocked. nothing was changed on the pc and I have gone through all the steps to open the port to no avail. I am using cisco 2325 router and have just reinstalled BC and the version says 20150629

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...