Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Can't listen to ports

Recommended Posts

1. BC 1.39 [20150629]

2. (I Think) Optical Fiber. 10Mbps

3. Modem/Router: TP-Link TD-W8960N, connected to Bridge TP-LINK TL-WA801N

3-1 Using Router-Bridge-Laptop (Wifi)

5- Kaspersky IS 2015 (I think the problem started when I installed the Techincal Preview of KTS 2016 and then uninstalled)

6- No filter o protection

Using Windows 8.1 x64. Thanks for the help

I must say I don't really know how to port forward with this new TP-LINK. But I think it's done like this:

Sorry for being noob.

It is weird because it hard worked before in my pc for about a year, and this just happened a few days ago.

The program is not blocked in KIS in any way.

Also tried installing BitComet 1.38 with no luck.

It just stays in "Connecting to server". Nothing else works.

"Add firewall exception", and "Enable UPnP Port Mapping" are checked




Link to comment
Share on other sites

A quick look at your screenshot suggests that you're unable to connect to any of the bitcomet operated servers, none of which are required to download torrents but they are required to log you into cometID, test your listening port, display comments, snapshots and the start page.

This may not be a port issue because you don't need an open listening port for any of this to work. The most common cause of this condition is improper use of a program like PeerBlock, PeerGuardian, or Protowall with block list manager. If your listening port was blocked the grey light in the lower right corner would be yellow instead of grey.

You may also have a complete inability for BitComet to connect to the internet since your task is still trying to download the .torrent using the magnet link. A problem with Kaspersky could have caused this and since you report this problem starting when you tried an evaluation copy I think that is the most likely culprit, but naturally I'm assuming the port test remained blocked and the magnet download never completed and since the screenshot only shows one instance in time I can't confirm that by looking, but even if you did have something blocking bitcomets servers that wouldn't stop the magnet connections from downloading which is why I feel it's the kaspersky or another firewall type app blocking you. Kaspersky's support team may be able to help you or you can try removing it completely and see if the problem clears itself, then reinstall a version that is considered stable. Sometimes it's a good idea to run a registry cleaner after removing a problematic software program and make sure you delete all traces of kaspersky, some options will remove the app but not remove all user settings as they are often retained to be used in the next installation, but if the settings files are corrupted that could be a problem. It's possible that the evaluation copy you installed had a conflict with your current settings.

There is also an issue with BitComet which shouldn't matter but I'll mention it just in case you talk to kaspersky support so they are aware. Version 1.39 appears to be released as a stable version but identifies as a "beta" program, so it's possible that kaspersky doesn't consider it the same program. I really don't know why this was done and no one from development has cleared this up, if 139 was intended to be a beta or if they forgot to rename it as a stable version when they released it. It also might be worth looking to see if you have two bitcomets listed in your apps permissions before you contact support or start removing apps.

Good luck and thanks for reading the rules and posting the min required info, you would not believe how rare that is.

  • Like 1
Link to comment
Share on other sites

Thank you very much for your comment and time helping me. I already checked that I'm not using any port blocker or any weird software. I really think that it's an issue that remained due to the kaspersky settings, and even though I uninstalled Kaspersky completely, it didn't work for me.

I also checked that the entire BitComet software doesn't have internet. It doesn't even work trying to download any file coming from a normal URL.

Then I remembered that installed a software called System Mechanics Pro (symilar to AVG Tuneup Utilities) which had a firewall even though I chose not to install it, so I tried installing it again and checf if it was blocking it still somehow, with no luck.

Also, I tried removing ALL KIS files using a software directly from their website: http://support.kaspersky.com/common/service.aspx?el=1464#block1

Also, I ran CCleaner as suggested, with also no luck.

Even with antivirus and a disabled Firewall, I can't seem to make it work. It's really weird. But I really appreciate the help. I'm soon going to change to Windows 10 wiping all data, and I hope it would work from there.

Link to comment
Share on other sites

Some apps that contain firewalls will block any connections they don't understand and apps that send out a lot of half open connection attempts and receive unsolicited incoming connections are often flagged as malware. A well written app will recognise a bittorrent client and not block it, but some just haven't invested the time to make their apps smart enough to do this. Years ago nVidia gave away a free firewall that was a nightmare for anyone using any p2p software and this could be something similar. I'd try uninstalling the app because it seems obvious you have some type of firewall blocking bitcomet.

Good Luck

Link to comment
Share on other sites

Upgraded to (didn't clean install) WIndows 10 and now it shows up that the port is blocked but it can connect now. I have no antivirus installed and the firewall is off, but it wont work yet. I think I would do a clean install just for BitComet

CanYouSeeMe can't see the port:

Error: I could not see your service on XXXXXXX on port (49153)

Reason: Connection timed out


Edited by haraop (see edit history)
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...