Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

BitComet suddenly won't load past Task Bar icon

Recommended Posts


I do hope that I'm in the correct place for asking for help. If not, I apologize!

I've read through the FAQ, the Wiki and I've searched through numerous threads trying to find a similar problem but I have had no luck so far.

The problem: when I attempt to open the program by double-clicking or right-clicking, select: run as admin, the BitComet icon appears in the task bar but the program does not load. I can right click the icon in the task bar and select "Suspend... Resume... Exit..." and it appears that "tasks" have been affected in the way I intended (but I'm not sure because when I hover over the task bar icon it doesn't give me any information about which tasks have been resumed, for example).

I can do certain things: I can download a magnet link and obtain the file, choosing where it will be saved. However, only that dialogue box pops up, not the full listing of all my previous torrents. So I can't restart a particular download and I can't actually see any progress on any download. So, every time I shut down I'm gambling that I'll be able to resume. I hope that makes sense.

I have tried un-installing the previous version (1.37x64) several times over the last few weeks thinking that I could repair it but that did nothing. This might be the very definition of insanity :unsure:

I've read through some forums (off site) that suggested that the program might be already running in the background but I can find no evidence of that (I purposefully did not select Start BitComet at start-up when I reinstalled) and I checked the task manager for whether the program was running and it was not.

Here's some info about my situation:

1) BitComet version: was using BitComet 1.37 x64, it worked great for a long time - until the Windows update a couple of weeks ago. I uninstalled it and then installed BitComet 1.40 x64 to see if that would fix the problem but the same thing is happening.

2) Internet connection: ISP: Telus Communications High-Speed (ADSL I think? Sorry, its hard to get a straight answer from them.) (3-15 Mbps download speed)

3) 1 Modem: Actiontec V1000H; no port forwarding, VoIP or telephone devices connected. Modem is connected to desktop computer using an ethernet cable, provides wireless access to a Samsung Tablet, 2 iphones and a Roku3 which is connected directly to my smart TV.

5) Using Windows 10 Home (64 bit), Windows Defender and Firewall, Avast Free Antivirus, Malwarebytes Anti-Malware

6) Not using any IP filtering or protection software, do not have any questions about specific torrents or speed problems

Well, thank you for your time. I appreciate any help you can provide. :)



Link to comment
Share on other sites

I assume you've restarted the computer?

perhaps one or more settings are corrupt, find "bitcomet.xml" file and delete or rename it, a new one with default settings will be created. Most likely located in %appdata% folder

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...