Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

File locking problem

Recommended Posts

I am downloading a rather big torrent (8.34 GB). I keep getting this "locking violation occured while accessing ..." on different files. Every time I run a hash-check it takes about 7-8 minutes and in the end sends me back to 80% done. What troubles me is that this happens only to files that are 1GB and bigger. The torrent has already been downloaded about 150 times and there are still 50-60 seeders, so it's not the ".torrent" file's fault. My ISP is not to be blamed too, my DL speed is 3 MBps so DLing the files is not the problem, but it is driving me crazy because what I'm DLing is something I'd really love to get! Can anyone help me? Please? :'(

Link to comment
Share on other sites

Hi Pavlin87,

This error is actually not caused by the BitComet client itself, rather it's a conflicting error made by all versions of Windows.

Basically, Windows 2003, XP, and NT has this function whereby it can reduce networked traffic in a single LAN, whenever a database is accessed by only 1 user. But because of this, when a second user attempts to access that database (i.e. in your case it could be the same registry/directory that BitComet or your Internet settingsa are using) Then the 1st user's settings will be overwritten automatically by the 2nd user.

Here's the solution:

I assume that you're using Windows XP or 2000.

Use "REGEDIT" to Expand the HKEY_LOCAL_MACHINE tree,

Next --> System --> CurrentControlSet -->Services --> MRXSmb and Parameters. With the Parameters key highlighted in your top left hand pane ---> select New/DWord value from the Edit menu and enter


Press Enter -->select Modify from the Edit menu, enter "1" for the Value data, and click on "OK." Verify that the entry you just made has a data value of 0x00000001.

For further reading, this is how Microsoft diagnosed this issue:


Restart once you've applied the change.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...