Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Bitcomet corrupts my DNS cache


Recommended Posts

Soon after I have started Bitcomet my browsing in IE becomes impossible. Downloads in Bitcomet are still working so the Internet connection is still working.

My first fix was to reboot my ADSL modem. This is a slow fix since it will take ten minutes to renew my ip-address and all seeds in Bitcomet have to be retraced.

I spent weeks trying to figure out the problem. What I found was that I had a problem with my DNS.

You can prove this by typing in the ip address for google into the address bar: instead of the DNS like "www.google.com"

To fix it I simply flush my DNS with the "ipconfig /flushdns" command in the Command Prompt.

Unfortunately my DNS cache gets corrupted almost every twenty minutes so its quite irritating.

Is there anything that can be done to avoid Bitomet corrupting my DNS cache?

Link to comment
Share on other sites

It seems like the problem lies within the modem's router.

Bitcomets disturbs the router in some way.

My modem is XAVI X8222r

The modem is also a router if Gateway address and Ip-address are different. These addresses can be found trough your Command prompt by writing "ipconfig /all"

Problem is solved by bridging your modem

Logg into

Set modem in bridge

Go to Start > Control Panel > Network Connections > Create New Connection


Connect to the Internet (alt 1)

Set up my connection manually (alt2)

Give your connection a name

Write the login info from your ISP


Link to comment
Share on other sites

  • 3 weeks later...

Dessbee, could you give me the same trik how to get bridge mode and get internet after on SpeedStream 5660?

My OS is Win2003SrvStndrd, not XP/Win2000Pro!

Cause SpeedStream 5660 looses connections after 4-5 hours if they reach level around 250.

My ISP is PPPoA, not PPPoE, but into the page of the modem I must write name and password.

My DNS settings are manual and Full duplex/Network Addressed on 10/100 Network Adapter Properties sheet as well.

Thanks in advance.

Link to comment
Share on other sites

  • 3 weeks later...

Hi, i have the same problem here. When i start a download in BitComet, my internet connection is like "blocked", can't use IE, online games.. only bitcomet is still working.

I don't understand the bridge thing, and i can't "bridge" my router like you said on

Can you explain step by step or post any screenshot please?

This is really annoying, can't download with BT :(

plz help, thnx.

PS: I use a modem/router of my ISP which is Wanadoo in France, it's called Livebox.

Link to comment
Share on other sites

  • 2 weeks later...

Same problem.

1) Install BitComet 0.70.

2) Download/Upload appears to be working well.

3) IE returns DNS errors.

4) E-mail clients (both MS Outlook/Outlook Express were unable to connect to my pop servers.

5) HP Multi Function Printer on HP TCPIP port no longer connected.

6) Warm boot sometimes fixes the probelms.

7) Have encountered problem connecting to router on intranet.


ADSL modem provided by service provider - ARESCOM NetDSL 800.

Wireless Broadband Router - Buffalo AirStation G54

Have tried Cold boot the whole network - this will usually fix the IE browsing POP connections but the HP TCPIP port is still down.

Any other suggestions please or shall I change the torrent client?

Link to comment
Share on other sites

Any other suggestions please or shall I change the torrent client?
WinXP/Win2k's DNS cache has (I assume its been fixed now but can't say for certain as M$ may not class it as a bug) a bug where it would also cache failed DNS lookups.

This would mean if you momentarily had a problem viewing a page like a server was down for a few seconds then reloading the page would always return with a DNS problem because WinXP had cached the failed DNS lookup just before.

If you check Speedguide.net for WinXP_DNSCache.zip which would fix this bug so that any failed DNS lookups, WinXP/Win2k DNS cache would not cache it.

The above may help, or alternatively, set the DNS Cache service to 'Manual' and DNS caching will not be performed by OS, instead it will be done as normal via your ISP. The DNS Cache service is NOT needed on most home computer setups - infact I have mine set to 'manual' and it therefore doesn't start the service at all but I can still browse and use BitComet, etc as normal.

I can honestly say I don't have any problems with BitComet 0.70. I have avoided using the current latest 0.71 due to the bugs reported by other forum members.

Link to comment
Share on other sites

May not be of help--But i had a similar IE problem-got rid of it by Shutting down (not resetting) my computer and turning it back on --had it 5-7 times --been 6 months since last time--(just for info (my Modem is ADSL Brdbnd Router-SSABR-B in operation 23 mos and No Changes by me---im no expert but i really dont think it was caused by BitComet--some other Malicious /intentional outside source in my humble opinion(you know the more you surf the more Garbage you run into and in the most innocent of places even!!!!!!!!! :(

Link to comment
Share on other sites

here is my fix. use utorrent instead because it has "Global Max connections."

the reason, our router/modem are not good enough to handle unlimited connections so we need that setting. I was so happy to see such thing in v0.71 but I found it doesn't take actions at all. so I went back to utorrent again. try utrorrent and set it up as 120 and it should fix your problem. if not, try to make it lower.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...