Jump to content
Comet Forums

BitComet kills my Internet dead, 2nd !!


julakian
 Share

Recommended Posts

Hello to all good and bad people who know something about bitcomet,

A.) My System:

1) What version of BitComet are you using? - BitComet 1.15

2) What type of Internet connection do you have (ADSL, etc.)? - DSL by cable

3) Do you have a modem? Do you use a router? What model? Have you forwarded your port? - Modem: DSL Easybox 601A Wlan, Port forwarded, all green lights.

4) What version of Windows, Firewall and Antivirus do you use? - Windows Vista 32, Windows Firewall, Kaspersky 2009

B. What's my problem?

Basically, I have eMule and BitComet. 4-5 weeks ago, bitcomet (I think since I upgraded to 1.15, but I'm not sure) starts out fine for 30 secs., then kills my internet speed to 0. This is not a seeder/leecher issue, since my Mozilla Firefox Browser is suddenly dead too, as is eMule. The only thing that helps is restarting my pc.

C. What MIGHT be the problem?

As I said before, the problem surface only about a month ago and I was happily using Emule, Firefox and Bitcomet at the same time for 5+ years.

Problem might be (or rather, pc-changes over the last 4-5 weeks):

-BitComet v1.15 - I have yet to try to downgrade bitcomet

-Hamachi - I have installed the Hamachi local network simulation program, launch it at weekends where I play with a friend

-Starforce Driver - I had installed a Starforce protected game, and ever since its uninstallation, I get the "starforce driver error, driver disabled"

-Unstalling BitComet - solves the problem, everything works again as always.

D. HEEELP!!

UPDATE:

E. Oh ok...hmmm Bitcomet v1.01 seems to work ok. The problem seems to be with bitcomet v1.15

Edited by julakian (see edit history)
Link to comment
Share on other sites

Have you tried just restarting the router? (Full power-off, wait 20 seconds, power on, wait till lights normalize)? And the modem, ditto? And both? What results?

Try also setting the network to inactive, wait for a slow count of 10, then reactivate it and try again.

Have you tried installing another BT client, such as Āµtorrent? Do you get different results with it?

Link to comment
Share on other sites

First of all, Thanx for the fast reply.

I actually have never every tried any other BT client (1000% BitComet fan :P). I HAVE tried restarting the router, including the waiting time, to no avail. Plz note that while my Internet speed was killed, my modem was still having the usual DSL lights on and blinking (as normal, when I'm online).

I have also tried deactivating the network connection, and reconnected after 1 minute. Well, connection says all ok (like before), but internet is still dead.

Ok, I hope this helps. Plz note, that my problem has been solved (by using an older bitcomet version, as noted at 1st post, last point), but that this problem might be part of BitComet v1.15 (or earlier versions, since I'm not the first with this problem).

I will be looking at this post until 25.10.2009, and will reply to any further questions if it will lead to an improvement to bitcomet.

thx and regards

Julian

Edited by cassie (see edit history)
Link to comment
Share on other sites

Unfortunately, kluelos, I believe the modem and the router are integrated in one device.

Another few things to check:

  1. can you ping (get a response) any site. Try your ISP first or a fast server like Google or whatever. If yes, can you telnet to them, too? (Try these, also, after point 2).
  2. does exiting BitComet solve your problem or once your Internet has gone dead it stays like that?
  3. delete the downloads.xml file (back it up first) then on the advanced option page set the network.max_connections to 150 (this is to check if your router doesn't go haywire because of too many connections open). Also disable DHT on the BT task options page (for the same reason).

Link to comment
Share on other sites

Yes, the modem and router ARE integrated in the same device.

1. I couldn't get a ping on ANY site, no Google, no Yahoo,etc.

I'm sorry, but I don't know what "telnet" is... -_-'

2. Like I said, the only thing that solved the problem, was to restart the system. Simply exiting BitComet couldn't revive my internet-speed (which is to say, the connection seems alright but it isn't, there is no 'disconnected' icon).

3. My max_connections were usually at 100, and I had times were I downloaded like 90 files simultaneously on bitcomet AND had emule running.

By the way, I tried clearing the download list on bitcomet and also deleted all torrent-files in the bitcomet/archive folder, restarted the system and after 30 secs, the internet-speed died again.

I also tried restarting the system with ONLY bitcomet running (no emule) and didn't open mozilla firefox, and the internet-speed died nonetheless.

Lastly, I tried tweaking the torrent-share option on/off, but it was useless.

Ok, time to go to sleep ;)

Edited by cassie (see edit history)
Link to comment
Share on other sites

I'm not able to tell for certain. The product, and all of its support, are German. My high-school German from long ago isn't up to the task. But some of the messages strongly suggest it's not an all-in-one. One blog message from Jet Rat seems to be explicit that they hook the 610A to an Alice modem.

I do appear to see multiple reports of similar problems, though not with bittorrent. It looks (bear in mind that this is all google-translated sites, and those can be really terrible) like a lot of people are complaining of similar sudden and inexplicable disconnections with the Easybox. Nobody seems to have any answers, and even the Arcor forum was no real help.

I do gather that there's a lot of activity with the firmware, so constantly making sure you have the latest version installed, is one good thing to try. Probably won't solve the problem, but will clear away one issue.

One suggestion that I did see is changing the wireless channel you're using. That can't hurt to try, but will really surprise me if it helps.

Link to comment
Share on other sites

Yeah, by the way how are you connected to the router (wireless or patch-cord)? If it's wireless you could try the wired way and even disable the wireless module if you have the possibility to see what happens.

However given all the things said until now, it seems to be a software conflict of some sort. It's an odd ball though.

I'm not sure if it's between BitComet and Vista, BitComet and Kaspersky (is it the Kaspersky Internet suite or just the AV?) or between all three of them combined. Or whatever other piece of software on your machine.

It might be worth a try to disable both Kaspersky and Windows Firewall (you can do, for the sake of testing only with the firewall in the router) and see if there's any change (by the way do you have any of the SPs for Vista installed?). Further more you should definitely clean the remnants of the other uninstalled application. Try using a system cleaner application like CCleaner or Comodo System Cleaner for that task. It might be worth uninstalling even the other network application for a test, that is, if it has any permanently resident modules or drivers loaded.

Link to comment
Share on other sites

Good morning :)

now, to the suggestions. I am connected by cable to the router and wireless is disconnected (as having wire-connection and wireless both enabled sometimes creates problems).

I have tried disabling windows firewall, but not disabling Kaspersky 2009, which is the Internet Security version (full Kaspersky package).

My System is Windows Vista, with Service packs 1+2 installed and regularly updated.

Which all leads to the possibility, as kluelos noted, that it might be a compatibility problem between the Easybox and BitComet (or rather the firmware of Easybox). Hmmm......

It might also be worth trying bitcomet v1.15 on Windows 7 using Easybox (which won't be possible for me, because in 3 days, my internet provider will change and they don't use the Easybox)...

Windows Vista DID produce loads of c*** on my computer and is even now barely faster than my old pc with Windows Xp on it, so it just might be Vista.

Please use the "Fast Reply" option, unless there is a specific reason for quoting the post directlly prior to your own.

Edited by cassie (see edit history)
Link to comment
Share on other sites

If you have the full Kasperky Internet suite it means it has a running firewall too. It is a bad idea to run 2 firewalls simultaneously. You should disable either one of them.

But for the sake of testing, if you wish to pursue this further, you should disable both the Kaspersky suite (entirely: firewall, antivirus, IDS and whatever other modules it has running) and the Windows firewall, just to see if there's any change. You still have the hardware firewall in your router protecting you so, no worries.

Link to comment
Share on other sites

Ok, I've been checking around. It seems, the internet-killing is NOT related to the bitcomet version. I believe it to be the cause of certain torrents (torrentshare?).

Anyways, disabling both the Kaspersky Suite and the Windows firewall does not solve the problem.

I have (for some reason I can't discern again) been killed out of the internet again, even with my bitcomet v1.01. As before, deleting all torrents from the bitcomet list and directory does NOT help, so it may be that some torrent is tweaking some port-configuration in the background (because only complete reinstallation helps). My guess is, that ports are being constantly opened in the background, until the internet connection is completely dead.

My Kaspersky 2009, fully updated did NOT find any virus, trojan, etc., only the common weaknesses in firefox.exe, adobe acrobat, microsoft office, etc.

But this is still weird, since I never had this problem before, and because I can't seem to find out which torrents might actually be responsible (or how). It's NOT related to certain sites (as I have tested). By the way, I have tried linking bitcomet to a limited port (light is yellow, not green), but no help either. Again, closing, not starting and running emule is NO help either.

Sadly, I'm not competent enough to check if and how any ports are opened... :(

Please use the "Fast Reply" option, unless there is a specific reason for quoting the post directlly prior to your own.

Edited by cassie (see edit history)
Link to comment
Share on other sites

Have you tried removing/disabling the other networking software you have installed (as I told you) and running again (with both firewalls disabled, too)?

This is obviously related to something that changed lately on your machine, since you haven't encountered this before and it's not limited to only one version.

You seem pretty convinced that this problem is caused by some particular torrents but you're wrong. There is no such information in the torrent file which configures anything related to your network connection. You can pursue this matter as long as you can in that direction, I'm pretty confident that you'll get nowhere. Besides, even if all ports were opened in your router and software firewall, that doesn't do anything else but put your PC in danger of being rapidly infected from the Internet (kind of like, opening all the doors and windows of the house and leaving to Tahiti). It doesn't however affect how your applications behave on your machine.

Is your Global Max Upload Rate capped to 80% of your tested upload speed (not the advertised one)?

What is the value on the TCP/IP Limit page in Options-->Advanced?

What is the value for network.max_connecting_connections on the Advanced page?

Have you removed the remnants of the other networking(gaming) application?

Link to comment
Share on other sites

Hello again,

so, it DOES seem my global max upload rate is capped at 80%.

The TCP/IP Limit page cannot be set, because my "TCP.Sys" is an incompatible version

Half-open TCP/IP Connections is set: auto

If my other networking application you mean "hamachi", then yes, I did, but it didn't change anything.

Right now, bitcomet is removed again, but emule is working fine with 30+ downloads.

What bothers me the most is, that bitcomet is not "not-working", but rather stops working after 5-10 minutes (and kills the entire internet-connection). This is actually where I am at a loss of what to do.

I repeat:

-After 5-10 min, the internet speed drops dead and NO internet application/browser has connection.

-Disabling Firewalls and Kasperspy 2009 does NOT help, neither does closing/restarting the bitcomet application.

-Uninstalling "hamachi"-networkgaming-application does NOT help, neither does NOT starting emule.

-I use Windows Vista SP2, and parallel with bitcomet, emule and windows live msn. My internet browser is mozilla firefox 3.0.1.

-Kaspersky 2009 could NOT find any virus.

-I use "tuneup 2008" to defragment my cpu and remove any other errors.

-Bitcomet has the internet-killer problem, unrelated to its version. Versions that have been tried out are Bitcomet v1.15 and v1.01.

Unsolved Issue on my cpu generally is an error report concerning a starforce-protection-driver (which I can't get rid of, re-installing then uninstalling the game didn't work).

Edited by cassie (see edit history)
Link to comment
Share on other sites

Use a system cleaner like CCleaner or Comodo System cleaner; they will find and remove orphan files on your system but most important they will find and clean registry entries related to uninstalled applications which left a lot of crap behind, in the registry. In fact I recommend running them both (if they are Vista-compatible, which you'll have to check) since one of them sometimes finds things which the other didn't.

Namely, among other things, they should remove from the registry, the entry which loads the network driver for the application you said you have uninstalled. So, this is a good thing to do, anyway.

But make sure that you get an application which is Vista compatible, since the registry access in Vista is different from XP and if you use an application which is not designed for Vista it won't do you much good, as it will probably be fooled by the registry virtualization feature of Vista.

As I said, this is not an usual situation and since you said that you were running BitComet without problems before, it's obvious that something changed in your system's software configuration, which triggers that behavior, right now. The tricky part is finding out what.

Another thing to do, is to check out the Event logs in Windows for the exact time when this error occurs (internet connection freeze) to see if there are any records of this.

Link to comment
Share on other sites

Ok, here I am again.

I have installed and tried out both CCleaner and Comodo System Cleaner. CCleaner was really reliable, since it did find some registries, that tuneup 2008 didn't. Comodo Cleaner however completely messed up my system, well lucky for me, that I had a restoration point set-up :P.

Anyways, they didn't remove the problem. However, re-installing bitcomet somehow did the trick again (bitcomet works fine again... -__-"

Now I'm not even sure how to re-create the internet-killing, but it will show up again for sure.

I need a short explanation, how to check out the Event logs in windows (I have no idea....) so I can do that, when the internet-killer shows up again.

Edited by cassie (see edit history)
Link to comment
Share on other sites

Please, do not quote messages when they are previous to yours and especially don't quote the entire message.

The Event Viewer snap-in can be reached through Administrative Tools menu. Or alternatively just type in the "Run" box or at a command prompt the following:

eventvwr.msc

.

Link to comment
Share on other sites

  • 2 weeks later...

Ok, I got the Internet-Killer going again. The windows-viewer is attached (well...German).

But what we do know, it's "error-message 3004", and the problem-file location seems to be in the internet explorer-folder. The General Content of the message is: "Windows Defender has detected a change". As is seen on the snapshot, the internet-connection symbol seems to be ok, and trying to deactivate the connection results in nothing happening except that it doesn't happen and the operating window is dead (no action, cannot be closed). Also, shutting down or restarting the computer is impossible, since the "deactivating" of the internet connection is still being attempted.

Any ideas? Anyone?

P.S.: Oh, and sorry for the wrong quoting, won't happen again.

Edited by julakian (see edit history)
Link to comment
Share on other sites

Just disable the daaamn thing (Windows Defender) and see if your problem goes away. You don't need it anyway if you're still running KIS.

If that does not solve it, uninstall KIS and check if there is any change. We have seen quite a few users who seem to have problems with the KIS + torrent client (not only BC) combination. (You'll still be firewalled by your router so you're OK.)

Let us know how this pans out.

Link to comment
Share on other sites

Hello, our team member said this may be caused by software contradiction. Please try to disable long-time seeding UDP.

Options->Advanced: Set "bittorrent.connection.ltseed_protocol_selection" value to 0(support TCP protocol only)(read more about this at wiki). And check if that works.

If that doesn't work, disable long-time seeding in Options->Task->Long-time seeding: untick the box of "Enable long-time seeding".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...