Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Hash Checking

Recommended Posts

This problem has been driving me crazy...

I am using 1.28, and BitComet always re-hash-check every torrent when it completes downloading even though:

- my Long-Term Seeding is disabled;

- my eMule Plugin is NOT installed;

- my Options->Advanced->bittorrent.hash_check_on_finish is FALSE

Please, can someone help? I'd really, really like to turn this "feature" off.

Thanks and regards.

Link to comment
Share on other sites

If the advance option to hash check on finished is disabled, then bitcomet shouldn't do the hash check. Also, the hash check process is pretty well hidden behind the gui, meaning it doesn't announce what it is doing, so how exactly are you sure it's doing this?

Also this is one of the best options in bitcomet and it will assure your download is 100% intact and hasn't been damaged by disc read/write errors during the process of upload/download. Are you sure you want it disabled?

Link to comment
Share on other sites

Actually the text in the Wiki leaves a little room for interpretation, so I'm kind of puzzled myself. This was added by the team so I'm not sure as to its original meaning.

When it says that BC will perform a hash-check in order to "prepare" the task for LT-Seeding or eMule upload that could mean 2 different things:

1. It prepares itself to actually upload through any of these 2 protocols (in which case it would mandatorily require that those options are enabled in BC);

2. It checks the files once again in order to make sure that it can calculate the correct file hashes and upload them towards the LTS server or respectively into the DHT network.

If the case is the latter I'm wondering if it would make any difference whether you actually disable LT-Seeding and eMule connectivity (i.e. if the file-hashes are still calculated and uploaded into the network even if you disabled those options).

@panickety: Can you confirm for any of your tasks that are public and on which you have seen this happening, whether now when looking into the Files tab you can see anything different than "No support" under the LT-Seeding and eMule columns (i.e. a number under the LTS column even if its 0 or an ed2k link in the next column)?

(The condition would be of course that the task HAD "no support" in the column(s) where you see now a number (of seeds) or an ed2k link when you started it and while it was downloading. I.e. you were downloading a task which had no LTS or eMule support but once BC finished downloading, it calculated and uploaded hashes for the task into the network and hence the content under those column changed.)

I don't currently have any downloading tasks and these 2 options have been since always enabled on my client, so I can't check this right now.

Link to comment
Share on other sites

To Usual Suspect: it shouldn't, but it does. I know it's hash checking because the status column says "finished hash checking" (top half, right), and the bottom half suddenly switches to the summary tab with the completion progress bar. Yes, I'm sure I want it disabled - I'm on a VPS with a high bandwidth, but small RAM and slow, shared HDD. Hash checking a 700 MB torrent can take 2 hours on low priority, and 15 mins on normal priority. So yeah.

greywizard: this happens on pretty much every single torrent I run. I've tried turning LT-Seed on and off just to see if it makes any difference (it doesn't), and I've never installed the eMule plugin (can't find one for 1.28).

In the files tab, under "LT Seeds" and "ED2K Link", both show "Global Disabled" (while downloading as well as during hash checking).

Thanks for looking into this :)


Link to comment
Share on other sites

I've never installed the eMule plugin (can't find one for 1.28).

Just to quickly settle this issue.

The latest emule plugin is 1.24 and will work with bitcomet version 1.11-1.28 and beyond

No new plugins will be issued unless there is something specifically updated in the plugin itself, which I believe is a good thing, so use v1.24 plugin if you want to install emule support.

@Wiz, please alert Ariel if you're unable to find the cause of this condition.

Link to comment
Share on other sites

@TUUS: Well, as to the cause I can only guess one of two at this point:

1. Even if you disable LTS and eMule upload, BitComet still calculates and uploads into the network the respective file-hashes, in order to benefit the other peers who might want to use LTS and eMule.

In order to do that, it's logical that it would perform a hash-check first to double-check that the files are in order (there would be no point in uploading hashes for any corrupt file). If that's the case, I think that the hash-check triggered by these conditions should be run in the background and with lower priority, so that it doesn't hinder the normal usage of the client.

2. There is a bug in the hash-checking routine of BitComet.

Whether it's the first or the latter only the team can tell us, as I can't think of too many tests which would help clear this.

So, Ariel is welcome to present this question to the team, at any point.

Link to comment
Share on other sites

Of all the Shakespeare I remember in The Tempest, several lines from Ariel stuck in my mind:

"Full fathom five thy father lies"

"Under a cowslip's bell I lie"

but the line that I remember most is:

"I go, I go, see how I go,

Straight like an arrow from a tartar's bow"

So Ariel, live up to you nick <grin>!

Link to comment
Share on other sites

Strangely enough, when I tried to use the 1.24 eMule plugin with BitComet 1.28, BitComet complains that the plugin is "out-of-date" and refuses to recognise it...

I just installed emule plugin 1.24 on bitcomet 1.28 and got no such message. Can you try again and provide a screenshot if you get the message?


Link to comment
Share on other sites

Okay, this is embarassing... you're right, of course. The error message I described earlier was for plugin 1.19.

When I go to BitComet's Options->eMule and hit the "Download eMule Plugin" button, I got 1.19

To get 1.24, I have to go to the BitComet site and download it manually.

Sorry about this.


Link to comment
Share on other sites

When I hit the "download emule plugin" button, it opens the download archives at bitcomet.com (same link as in my signature).

Edit: When I click the blue link seen above, it opens the web page, when I click the button, it attempts to download the plugin from an http source that doesn't exist. I'll get that looked at. Thanks for reporting it.

From there you can select any current or past version of bitcomet and/or plugins. I don't know why it would have directly downloaded an older version for you, but I'm glad you got it to work.

Link to comment
Share on other sites

Hi panickety

I have reported the hash check issue to the development team, and still waiting for their answer.

As for the emule download, the grey button will lead you to v 1.19, but the link in our website is v 1.24.

v 1.24 is compatible with our latest version.

The development team said this would be fixed in the next version.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...