Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Not all the bandwidth used is employed in the task


Recommended Posts

I noticed that my torrent downloads lately havent been reaching their full speed (They almost always do since my speed is only 105 kb/second). But my bandwidth is still 100% used. So, I used a program that shows the consumption of bandwidth by each individual program running, and BitComet WAS taking all 100% of my bandwidth, yet only 75%-80% of that consumption goes towards downloading the actual task( sometimes its 90%) This has never happened before, issue only appeared recently. What could have gone wrong?!

P.S Upload speeds are at normal rates

Bitcomet version: 1.27 stable

Internet connection: ADSL 1mbps

Router Dlink (Port is forwarded, tested and open)

Windows: XP Firewall:Sygate

Edited by Birosso (see edit history)
Link to comment
Share on other sites

Actually, you have to manually limit the upload bandwidth of BitComet at 80% of the tested upload speed of your connection in order to keep your client from hogging all the upload pipe.

There will always be a certain amount of bandwidth used for protocol overhead (BT, DHT, LTS), both directions (upload and download). That's unavoidable.

So, it's not at all abnormal to not reach the "theoretical" maximum.

You're not being very clear where from where you came up with the 105KB/s.

Furthermore, if your client is downloading through eMule, part of the task, that bandwidth isn't added to what's being displayed into the main window.

Link to comment
Share on other sites

1mb/s equals 1000kbs, or about 125kBs. If you don't use the proper units, it will confuse those trying to understand what your trying to say.

With a slow connection, try disabling all the services, this will reduce overhead. You might want to disable ltseed too. It's job is to get you faster download, but if it negotiates to get you 1000kB/s and you can onnly use 100kB/s, you only wasted a lot of overhead and you very well could have maxed out your connection without it.

I'd also disable dht on tasks that don't need it.

This should help on most popular tasks.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...