Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

BitComet is having trouble detecting the Complete file to download media online

Recommended Posts

I have a firefox 15.0.1, I'm using bitcomet 1.34 I use wireless internet, Windows 7 (64 bit) upgraded from vista,

Now after upgrading to firefox 15 the other day I had everything working fine. Except that I got a bluescreen bug. A bug I had already handled and gotten rid of before.

Except that on account that bitcomet wasn't working properly after solving the issue. I decided to use the windows system restore to the date of where it was working about 3 weeks ago.

Bitcomet was working again. But unfortuatly the bluescreen bug reappered also.

So I had no other choose but to use windows system restore to change the cordinate to how the computer was when it no longer had the bug. Selecting a more current restore date.

I'm back to the same problem I had before. A clean computer but with a bitcomet that isn't working correctly.

Now if you haven't read my previous post. I use bitcomet mainly for downloading online media files.

I've included my list of plug-ins, (if it helps) The only extension I have in the add-on is the bitcomet video downloader 1.34


The issue is that bitcomet is only able to show files that are under 2.5 MB in size now or nothing at all.

I go to youtube, right-click and the files that show up for a 42 min video are all under 2.5mb like just 1.5 or 2.3 Even if I download them all I see is a black screen with no sound or anything.

I don't know if this might of caused anything yet before I cleaned out the bug when bitcomet was working properly. I closed bitcomet. An I selected exist from the bottom right taskbar. But when I went to Window's task menu>service I sow that bitcomet disk boot service was still working so I right clicked it to stop service. After that this problem not finding the full file came up. I restarted but still the same. After that the problems been the same. Being as to why the only say I sow a solution was to use system restore to the date before I did that on task menu. Even if it was after I had cleaned out my computer. (Unfortuatly I don't remember how I fixed it. An I had Avast and it still didn't detect it I went around doing things here and there.


Uninstalling both firefox and bitcomet, even deleting their preferances or other relating files, before re-installing to see if that would fix the problem but didn't.

I've also tried to go the bitcomet >options>Intregration>Install firefox extention for bitcomet I thought I could of gotten something to confirm its statues but all I get is an error. I'm the only user and I've opened it under administrator but the error message still comes up. "Please restart bitcomet as non-elevated to preform this operation"





Edited by itsabouttime5 (see edit history)
Link to comment
Share on other sites

That has been around for quite a while... it seems to be Youtube's new protection system against flash downloaders. They seem to split the video files in many small segments as a workaround against most downloaders.

It doesn't have anything to do with BitComet's current state.

You may want to post a feature request in the appropriate area of the forum, for a feature that would join the segments back.

Link to comment
Share on other sites

The Youtube is still able to be easily downloaded by keepvid.com

If they were spliting the video on youtube. Don't you think it would work after downloaded with just the small section that was downloaded? But 2.3 mb doesn't show up anything. An as you can see in the picture with all the files offered it still doesn't come up the size the file should be (over 100MB)

bitcomet was working fine before downloading media and youtube till something happened. Because I've noticed that it isn't only with youtube. So I'm willing to even downgrade to a previous verizon if that does the trick. Like I said when I used system restore I can go get it to work as I want but I get a bluescreen.

I know your trying to help me out to fix this problem but I still don't know what your suggesting me to do to fix the problem

Edited by itsabouttime5 (see edit history)
Link to comment
Share on other sites

To be frank, I've observed this behavior for quite a long time (at least a couple of months).

Since I don't really use this feature almost at all, I didn't loose any sleep on its account and thought the behavior was related to the youtube site.

This may be a bug on BitComet's side if you say you can make it work again when you restore your profile.

I'm curious if other users encounter this too or not.

  • I'm not sure if BC will display ALL the flash files on a page or it has a certain limit perhaps (100 MB would yield at least 40 segments at that size), so that's not an irrefutable evidence to support the bug assumption.
  • The fact that youtube videos may be still downloaded by other apps, also isn't proof, since other apps may have updated their code to counter this new trick (it isn't that hard to join adjacent video segments)
  • The fact that you can't play the segment, still isn't evidence of that since if you segment a video with an application such as HJSplit you'll see that the segments are unusable as video files (until rejoined) as this application splits the file at a binary level and doesn't recreate the container structure for each segment (.avi, .mkv or whatever and ANY player I know needs at least a container header in front of the video data, in order to play it), as a dedicated application such as VirtualDub would do for instance.
  • However the fact that you can make it work by a restore, may be proof that this is related to a bug in BitComet's plugin and not to a new youtube protection.

I can't suggest you any fix at this point because I didn't even bother to look for a solution of that by the development team (as I don't use the feature) and at this point they have a in-mass 1 week vacation, so we couldn't reach them very easily even if we wanted.

Link to comment
Share on other sites

no offense, but the way you express it Sounds like you don't really care to fix the problem, nor would the rest. Sad. When emailing bitcomet I just heard the same youtube excuse.

Well for the sake of others. I have Found the problem and was able to Fix it. So here is what they can do.

This was a problem with the drivers in my computer. I have wondershare video converter. I then selected to get a driver check. All the necessary drivers were downloaded. A list of 5 is included for you to see. And now as shown it is working properly on youtube and the other websites that were affected.

Don't give up so easily. :)

Hope this helps others.




Edited by itsabouttime5 (see edit history)
Link to comment
Share on other sites

Yep, you're right.

I couldn't have cared to fix an issue in BitComet which I wasn't aware of, until now. I told you I thought it was site-related.

Besides, I'm not part of the developing team, so short of forwarding a bug report, there isn't much I could have done in that respect.

You can do that yourself at any time, it doesn't have to pass through us the forum staff, since the Bug Reports section is open for all forum members.

Glad you fixed your issue.

Link to comment
Share on other sites

Please keep in mind that this is a community support forum, it's staffed by bitcomet users. We can expedite bug reports that we can verify by gathering all the details and submitting a report to development who has always taken them seriously, however we do get a lot of (so called) bug reports that contain no useful information which are promptly ignored, not because we all don't want bugs fixed, but you cannot fix something unless it's properly described and most important, reproduceable.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...