Jump to content
Comet Forums
twOlegYch

UDP Tracker no response

Recommended Posts

Hello all

I'm trying out bitcomet and have an issue with some torrents.

e.g. a torrent from tpb discovers zero peers, the same torrent at the same time in utorrent discovers plenty of peers and downloads ok

i've attached screenshots from bitcomet and utorrent

the issue seems to be related to udp trackers

i'm using bitcomet 1.36 on windows 8 with firewall disabled and no antivirus, docsis connection with static ip over wifi, both utrorrent and bitcomet are unable to listen to a port

Thanks, Aleh

post-129534-0-63014200-1378444012.png

post-129534-0-84235400-1378444018.png

Share this post


Link to post
Share on other sites

I enabled port forwarding in router and now bitcomet says "Your listen port is open you can get the best download speed", but i still get no peers and UDP Tracke no response.

Share this post


Link to post
Share on other sites

Looks like something is blocking bitcomet from connecting to trackers, have you tried any torrents with http trackers?

I'd try bypassing your router too if possible. I would help to know if the problem is in the router or with your computer.

Share this post


Link to post
Share on other sites

Yeah http trackers work fine.

I don't think the problem is in computer or router since utorrent on the same computer at the same time with the same torrent has no problems with those trackers and discovers tons of peers.

What's even more strange is that i now get response from some trackers, but some still have the same error:

61e5b59149b41bb1469b3fa9ec7ddeec.png

Edited by twOlegYch (see edit history)

Share this post


Link to post
Share on other sites

If you can send me a link to the torrent or magnet uri I'll try the torrent and see if it works for me, if it doesn't we can send it to development and let them look at it.

Share this post


Link to post
Share on other sites

Please post a sshot of the Summary tab... let's see if your UDP port is open.

Tracker servers could be simply overloaded at certain moments (and that could account for the fact that they don't always reply in time), especially since there are lots of people who add whole lists of free trackers when they create their torrents even though the respective torrent isn't tracked by that specific server; which fact adds to the pointless burden the trackers sometimes have to shoulder.

Of course, I'm not entirely sure if that's your issue and in the first case (when all of them were not responding) it seems rather improbable, but this can very well account for the second sshot you posted.

It's also possible that other trackers have only a list of preferred clients to which they reply and ban the rest.

Moreover, 2 of the tracker URLs in the last sshot are not present in the first ones (so there is no evidence they worked even then) and the 3rd one seems to be in "updating" mode even on the uTorrent sshot so it's status is also unclear.

Seeing that usually the lists of peers you get from multiple trackers are identical mostly you shouldn't worry too much.

As long as you get at least one tracker to respond or even a DHT batch of peers, then the PEX kicks in and the connected peers exchange peer lists directly between them, so the tracker may even go down completely and the torrent could very well continue to live and download fine for quite long (proof are the TPB torrents which don't use a tracker any more, since quite long).

Share this post


Link to post
Share on other sites

Thanks, for your help guys.

I think it was a temporary fluke, most udp trackers work fine now.

And i noticed that those trackers sometimes timeout in utorrent as well.

Share this post


Link to post
Share on other sites

Unfortunately the problem still exists.

With this list of trackers:

udp://tracker.openbittorrent.com:80

udp://tracker.publicbt.com:80

udp://tracker.istole.it:80/announce

udp://tracker.ccc.de:80

udp://open.demonii.com:1337

i still get No response for all of them, for a couple of hours now

tried restarting bitcomet, readding the torrent - nothing works

but the moment i add it in utorrent - i immediately get lots of peers and full speed download

yes, i have udp port open in both utorrent and bitcomet

Share this post


Link to post
Share on other sites

You never responded to my post, if I can confirm a bug I'll pass it on to development but bitcomet works fine for me and you've yet to provide a task that works in other clients but not in bitcomet for us to test.

Share this post


Link to post
Share on other sites

how about this one

magnet:?xt=urn:btih:FAC6135C32DA51F8FD237F7F470A6E5A1417B35D&dn=King%20Of%20The%20Hill&tr=%2ahttp%3a%2f%2ftracker.thepiratebay.org%2fannounce&tr=%2audp%3a%2f%2ftracker.thepiratebay.org%3a80%2fannounce&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80%2fannounce&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80%2fannounce&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80&tr=udp%3a%2f%2ftracker.publicbt.com%3a80&tr=udp%3a%2f%2ftracker.istole.it%3a80%2fannounce&tr=udp%3a%2f%2ftracker.ccc.de%3a80&tr=udp%3a%2f%2fopen.demonii.com%3a1337

Share this post


Link to post
Share on other sites

I was able to load that torrent, I only selected the first of the videos because I didn't want to download them all. Most of the trackers returned a large number of peers and the first video downloaded in a matter of seconds. Of the working trackers some were http and some were udp.

Share this post


Link to post
Share on other sites

Thanks for looking into this!

indeed this seems to work now

damn, i have no idea what has changed...

will try to provide better reproducible case if that happens again...

Share this post


Link to post
Share on other sites

One thing I've suspected that some trackers have been doing is blocking some IP addresses that hammer their tracker. Unfortunately many people who distribute torrents have been copying random tracker url's into torrents without properly registering the torrent with said tracker, this results in everyone running the torrent trying to use their tracker and naturally this won't work. I've long suspected some trackers will block an IP after several unwanted attempts. This is a "long shot" (guess) but it's conceivable that if you're running any tasks that are hammering certain trackers, your IP could be temp blocked by them. The only way to tell for sure would be to find a torrent that doesn't work, then stop all your torrents for a day (or alternately change your IP if possible), then try again and if it works, you may have found the cause.

If that's not the cause it will be difficult to track down the problem, but I'm pretty sure this isn't a problem with BitComet, it's job is to send protocol compliant data to the tracker, if you get no response, it's usually a problem with the tracker, your connection, or the torrent itself. If this was a bug with bitcomet I think we would be seeing thousands of members reporting it.

I'll keep an open mind and try to reproduce anything you report and if we do suspect bitcomet has a bug I'm sure the developers will look at our data, but so far I have nothing tangible to send them.

Share this post


Link to post
Share on other sites

The UnUsual Suspect's theory (about temp IP blocks) seems to be correct.

I was having the same issue and a router restart resulted in instant response from 3 of the 5 UDP trackers, as well as the DHT network (was not responding before as well.

Share this post


Link to post
Share on other sites

that happened again

magnet:?xt=urn:btih:SWEL2D526SDAMEKPY4UPEAAWTBLUNOUR&dn=s03e10&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=udp%3A%2F%2Ftracker.istole.it%3A6969&tr=udp%3A%2F%2Ftracker.ccc.de%3A80&tr=udp%3A%2F%2Fopen.demonii.com%3A1337&xl=1849172912

http://prntscr.com/2mkqcj

Share this post


Link to post
Share on other sites

that happened again

magnet:?xt=urn:btih:SWEL2D526SDAMEKPY4UPEAAWTBLUNOUR&dn=s03e10&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=udp%3A%2F%2Ftracker.istole.it%3A6969&tr=udp%3A%2F%2Ftracker.ccc.de%3A80&tr=udp%3A%2F%2Fopen.demonii.com%3A1337&xl=1849172912

http://prntscr.com/2mkqcj

I tested the task you reported and all the trackers work for me except the ccc.de which probably no longer exists.

The rest of the trackers connected instantly and if they are working with one client but not with another, your problem is probably with a firewall or router that's blocking the connection.

Share this post


Link to post
Share on other sites

i don't know what to tell you guys

i tested on another network today and still get UDP tracker no response while utorrent is working fine

i get some peers via DHT but the speed is nowhere near to utorrent (if i manage to get any peers at all)

i repeat, i don't have any firewalls and the router is the same for bitcomet and utorrent

Share this post


Link to post
Share on other sites

Post another magnet link, I'll test it and see if it works for me. If we can reproduce a problem, it will get sent to development for them to look at.

Share this post


Link to post
Share on other sites

well it has nothing to do with this or that magnet link

basically every torrent from piratebay has only udp trackers and bitcomet is not able to get peers from them while utorrent works fine at the same time on the same computer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...