Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

can't find files with Vista RC1


Recommended Posts

Kind of a double-whammy here, but using Vista RC1 and BitComet Beta 20060908 I can not find the files I have downloaded. They are not in Program Files(x86)\BitComet\Downloads which is default, I set default to Desktop and still nothing. Odd thing is, using built-in preview I can play the files, but browsing and searching have not located them! Only clue I have is viewing properties of c:\Users (new location of Desktop...) shows a large size, tho the files themselves are still hiding.

I know, beta app on beta OS but still, thought you should know. Have not yet tried switching to non-beta BC.

Thanks, and any clues on finding them would be appreciated.

Link to comment
Share on other sites

This is an issue with windows vista and your permissions settings.

It has been reported that the vista beta2 release will allow you to view the files if you save them to "my documents" or "desktop", but I'm not sure about your version.

I suggest you look into your windows vista forums for how to allow users to view files in ALL areas.

I think Microsoft went in the wrong direction when they started hiding file extensions by default (I guess they think users don't need to know what kind of files they have), and now it is much worse when you can't even browse some sections of the hard drive.

Concerning the Bit comet beta version, I'm reasonably certain this is a vista issue, NOT a bit comet issue.


ps. you might want to log in as admin (if your not already) and see if files can be viewed

Link to comment
Share on other sites

Still not able to find what I already DLd, no big thing, just testing for now...

@Dark_Shroud: Yeah, tried that, Vista just won't show them wherever they are now, they are in C:\Users\Me (not feeling creative when I set this up.....) but I am unable to see or search for them....

@The UnUsual Suspect: Could be, but not RC1. And good idea about Admin, didn't think of that, but one problem - there is no Admin, or at least you can't access it in the same old XP way. CTRL-ALT-DEL twice at login screen did not work.

I did find a workaround, just made a new dir in root and set that as dl dir, just a pain that I can only use internal preview to see what I got...

Oh-well, hope this helps get ready for Vista in some way


Link to comment
Share on other sites

  • 3 weeks later...

Ah, here's the problem: BitComet writes to \Program Files\ by default. That's a bit NO NO! BitComet should default to <homedir>\Downloads. No program should ever hide user data in the program aread. That area should be read-only.

In Vista, MS have protected \Program Files\ and there is a VirtualStore made to allow writing. We just need to know about this new feature on Vista as the files don't appear where we think. RC1 is working correctly now and DOES allow BitComet to write. Previous versions just failed.

Thus, an app that requires write access into program files sees c:\program files\MyApp\UserData, but it's really in c:\users\<username>\AppData\VirtualStore\Program Files\MyApp\UserData


1. change your download folder to c:\Users\<username>\Downloads

2. BitComet gets an upgrade that properly does this when installed


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...