Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

1.16 Task list disappears


Recommended Posts

After installing 1.16, all the torrent tasks are missing, be it completed or in progress torrents. The torrent file is still there in the torrent archive, but nothing appears in the "All downloads" section at all. Reverting back to 1.15 and I get back my list. Is this a bug, or is 1.16 using a different method altogether for its list? I do not want to having to add back each 100+ torrents just to seed them.

Running BC on Win7 x64.

Link to comment
Share on other sites

It certainly should not behave that way. The task list mechanism hasn't changed as far as I can tell. I am hearing odder and odder reports about Win7 from a wide variety of sources, though.

I'd like you to save your downloads.xml file to another location after running 1.15 -- in other words, with the correct list. (Probably good to also back up the .torrents subfolder for paranoia's sake). Then install 1.16, and look at your task list again. If it's still empty, then shut it down and copy the downloads.xml file back to its original location, overwriting what's there, then try again. I'm curious to find out if this works as it should.

Link to comment
Share on other sites

Just to add to what kluelos was saying; under normal circumstances the downloads.xml (the file where BC saves its tasklist) is found in the Users\%userprofile%\AppData\Local\VirtualStore\Program Files\BitComet or in your case in Users\%userprofile%\AppData\Local\VirtualStore\Program Files (x86)\BitComet.

If you say that by reverting to v.1.15 you get back your tasklist it's obvious that the downloads.xml doesn't get overwritten in v.1.16 but instead the application reads it from another file (although it shouldn't).

To be sure, you should make a backup copy of that file (in v.1.15) and store it somewhere else, as kluelos said (you can make sure that you're looking at the right .xml file by opening it and looking inside; among all the gibberish you should see the names of your tasks).

Now, before trying to overwrite it as he instructed you, please add a task in the blank tasklist and exit BitComet. The new tasklist should be saved, now. Then restart BC to check if indeed it saved the tasklist. If it did then go and find that downloads.xml file (this could be a bit tricky, because it probably resides somewhere else than the original one from v.1.15 - check the real C:\Program Folder for it too). But even if it doesn't save the tasklist and you get again a blank list when restarting BC you should, still, be able to find the file (it will have just a few xml tags but no record of any of your tasks).

I'm asking you to add a task to the list, just to make it easier to verify that you're looking at the right file (and to check if the v.1.16 still can save its tasklist but does it in a different place or maybe it can't do that at all).

Moreover you should make sure that User Account Control is not disabled during these operations and that you are not running BC with elevated privileges (i.e. started with Run as administrator command).

So, basically, we would want to know where do you find the downloads.xml for v.1.15 and the one for v.1.16, because they're obviously different files in your case.

Why am I asking you to do all this?

Because lately we've been seeing tons of posts like yours, from people who in a way or another have lost their tasklist under Vista or Win 7. And no matter how hard I've tried I couldn't manage to reproduce that behavior. None of us could, for that matter.

So, obviously, we'd like to understand what is different in your setup that is causing this kind of error.

I'll give here a short clarification for all this folder madness, in Vista and Win 7. If you're familiar with all that you can just ignore the following lines.

In Vista and Win 7, even when you log in with an administrator account you get assigned for current use a standard user access token (derived from the standard Limited User Account). That goes even for the instance of Explorer that you see on screen after Windows started. Whenever any application needs to perform any task requiring administrative rights it asks Windows for elevation and you get that annoying pop-up from UAC asking your permission. Once given permission Windows assigns the app the admin rights token. But under normal circumstances most of your applications will run under LUA access token. This has some consequences.

Starting with Vista, applications can no longer write into the system protected areas of file system and registry (among other things Program Files is one of them) unless they are running with elevated rights (under administrator token). This is part of the UAC (User Account Control) mechanism introduced with Vista and in order that the existent (non-Vista compatible) applications to cope with that another mechanism was introduced: data virtualization.

What data virtualization does, is intercept all the write and subsequent read operations to system protected areas (Program Files included) of the applications running under LUA access token and redirects them to a per user location located under the virtual store folder: Users\%userprofile%\AppData\Local\VirtualStore\Program Files. It does that without the application's assistance, so, the process is transparent for the application which believes that it did write or read from the real Program Files directory, in our case.

However, there are several cases when data virtualization gets disabled (when the application is run under admin token, when UAC is turned off, when the application has a embedded manifest requesting for elevation and is run under admin account etc.) which in turn will, sometimes, lead to problems much like yours.

Link to comment
Share on other sites

  • 1 month later...

Sorry for the very late reply, didn't get around to doing what you asked until upgrading to 1.17. Anyway, here's where versions prior to 1.16 stored the files that were supposed to be in the Users\%userprofile%\AppData\Local\VirtualStore\Program Files (x86)\BitComet folder:

C:\Program Files (x86)\BitComet

So actually the older versions didn't go through all the LUA-UAC headache and managed to write itself there. Overwriting all the required folders from the installation directory into the folder with userprofile solved the problem:

  • BitComet.xml
  • Downloads.xml
  • cache
  • rules
  • share
  • torrents

Perhaps future BitComet installers could detect if the files & folders are still at their old directory and copy it over to the new location.

Hope this helps!

Edited by dangerism (see edit history)
Link to comment
Share on other sites

  • 3 years later...

<p>same issue but i dont see </p>

<ul class="bbc" style="margin: 12px 0px 12px 40px; padding: 0px; list-style-position: outside; list-style-image: initial; color: rgb(40, 40, 40); font-family: helvetica, arial, sans-serif; line-height: 22px;">

<li style="margin: 0px; padding: 0px;">Downloads.xml in my program file ??? all my download list has disappeared</li>


<div id="wrchoverdiv">

<div id="wrccontainer">

<div id="wrcheader">

<div id="wrctitle">WebRep</div>


<div class="wrchorizontal"> </div>

<div id="wrccurrentvote">Overall rating</div>

<div class="wrchorizontal"> </div>

<div id="wrcrating"> </div>

<div id="wrcratingtext">This site has no rating</div>

<div id="wrcweighttext">(not enough votes)</div>

<div id="wrcflags">

<div class="wrcicon" id="wrcicon_shopping"> </div>

<div class="wrcicon" id="wrcicon_social"> </div>

<div class="wrcicon" id="wrcicon_news"> </div>

<div class="wrcicon" id="wrcicon_it"> </div>

<div class="wrcicon" id="wrcicon_corporate"> </div>

<div class="wrcicon" id="wrcicon_pornography"> </div>

<div class="wrcicon" id="wrcicon_violence"> </div>

<div class="wrcicon" id="wrcicon_gambling"> </div>

<div class="wrcicon" id="wrcicon_drugs"> </div>

<div class="wrcicon" id="wrcicon_illegal"> </div>


<div class="wrchorizontal"> </div>



Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...