Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

LT Seeds connected at my office computer but no support in my home computer.

Recommended Posts

I have looked at the different forum topics regarding the issue of LT Seeds but I could not find a topic that is directly related my problem. I know you guys might be tired of answering to this sort of topic.But here it goes.

sophia0316 has posted in some topics related that the server moving has now been completed but that there maybe some issues left. My problem is that LT seeds are connected in my office but there is no LT seed support in my home computer. On previous occasions the server was maintained, seeds would appear automatically again when the maintainence was completed. But not this time. I am logged into bitcomet with the Green Light port and DHT connected just like in my office. But there is still no support for LT seeds. I have reset my modem and restarted the computer several times, even did a few clean reinstalls of bitcomet. But still no luck. The only difference I notice is that the ISP at home and the office are different companies.

I was hoping you guys could tell me if this was a problem with my home internet service provider or an issue with the Bitcomet server.

I don't think its a problem with my home ISP because this is the first time I have failed to connect to LT seeds at home after a comet passport or comet server maintainence.

Hope you guys can help me find out what is causing this problem, and thanks in advance.

Link to comment
Share on other sites

Unfortunately, there is no provision at this point in BitComet which to facilitate for a user to interactively test if the LT-Seeding server is running. If there might be some indicators of success or failure in connecting to connection-status and Passport servers, there is no such thing for the LT-Seeding server.

The only things which could let you know that LT-Seeding is working are the presence of LT-Seeds in the Peers tab or statistics of LT-Seeding uploading on the Statistics tab. Unfortunately the absence of these two doesn't necessarily mean that LT-Seeding is not working, so they can't be used as a means of diagnostic.

Anyway, right now as I'm writing this, the LT-Seeding server seems to be working since my client is uploading by LT-Seeding.

Besides, you say yourself that your client at work manages to connect to the LT-Seeding server so I don't think there is much chance that this might be server-related.

As I said, at this point, there is no easy way of polling any statistics about the LT-Seeding server (we don't even have very clear specifications on how it's working).

However bear in mind the following:

  1. A torrent swarm needs to actually have peers which use the BitComet client (and have LT-Seeding enabled) in order for you to be able to download or upload by LT-Seeding. Therefore, when testing this, make sure you use the same torrent at work and at home, simultaneously, to see if one can contact the server and the other doesn't.
  2. Since we don't know the specifications of the server (and with this being a free service it might be safe to assume that it is not a high-powered server or server cluster with redundant connections and bandwidth) it might be possible that, at times, it gets overwhelmed by too many clients trying to connect. When that happens, there are two options: either it queues the connection requests (which may get timed out on your side in the meantime) or it simply drops them. In either of these cases you probably won't be able to contact the server.

These two points above don't necessary account for the reason why you can't see LT-Seeding activity on your client but are worth considering.

Link to comment
Share on other sites

Well..... Thanks for the quick reply. One other thing i've noticed the listen port fails about two to three times before finally showing the yellow light, unless the port is open, in which case bitcomet detects the port as open on the first go. I first noticed this when the server went down. I usually don't set up the listen port because it does not make much of a difference speed wise on my net connection. Before, Bitcomet would recognise the port as blocked on the first attempt. But now..., (in my case at least) after the servers were moved...., it needs a few attempts to show a blocked port. I know there's not much you can do to help me.......just thought you would like to know about this.

On previous occations....LT Seeds have worked after formatting the computer..........though this is not a gauranteed solution as ive found out.

Anyway...I'll keep trying different things and post on this topic if I find a solution.Thanks for the help.

Edited by BlazeSeven (see edit history)
Link to comment
Share on other sites

This all seems a bit contradictory.

Are you inquiring about LT-Seeding just out of curiosity or because you miss the extra speed provided by it (when available)?

Because if you did get an extra boost of downloading speed with LT-Seeding, that obviates the fact that your net connection actually holds some extra bandwidth capacity compared to what you use at this point.

That contradicts the truth of your statement:

I usually don't set up the listen port because it does not make much of a difference speed wise on my net connection.

The open listen port is the single-most important setting in any BitTorrent client (along with limiting the global upload speed to around 80% of your tested upload capacity).

In fact if you were to choose between a working LT-Seeding feature and an open listen port your bet should most certainly go on the listen port. That's because as long as there is a swarm of peers for a certain torrent you are bound to get more or less steady speeds form them, whereas LT-Seeding is more of an extra feature; there is no guarantee that you will find LT-Seed peers for that torrent or what aggregated speed you will get from them.

Therefore if you want to get the best speeds out of any Internet connection, with any BitTorrent client, you should definitely have an open listen port. That's why I warmly recommend you to take all the steps necessary to get it open.

In case you need help with that, check the Wiki topic about Creating Firewall Rules and if you have a router the guide about Adding Port Mapping in NAT Router (the manual setting part since the UPnP doesn't work stably for you) or the port forwarding guide in this forum's guides section.

Link to comment
Share on other sites

My maximum download speed is around 60 KB/s. Bitcomet reaches this speed with or without LT-Seeds. The only difference I notice is that with LT-Seeds connected, I can reach this max speed within a matter of seconds and keep an average speed of around 50 to 60 KB/s. Without LT-Seeds I can still reach the max speed but it takes around ten to thirty minutes. Also the average speed without LT-Seeds is much more unpredictable.On my internet connection, I feel LT-Seeds help the download keep a good average speed because LT-Seeds and BT peers are both connected, hence finishing the download much quickly or at a more predictable time.

(At least that's what I think.......please correct me if I am wrong).

LT-Seeds or not, I can reach my maximum download speed. The difference is the time it takes, and maybe the average speed.

This is what I meant by saying that it does not make much of a difference.

Having LT-Seeds does not increase my bandwidth.

By the way, I configured my listen port by following the instructions on PortForward.com a few hours ago and got the green light. But when I continued to download torrents after this, my speed averaged 5 to 10 KB/s and when I checked the Trackers tab, none of the Trackers had connected and had the following error msg.

Tracker connection error: 10060 A connection attempt failed because the connected party did not respond after a period of time,...

So I reset my router and now I have a yellow blocked port but I continued to download the torrent and even as I write at this moment I'm getting an average speed of 35 to 50 KB/s. The Trackers that previously had the above error msg are now connected and has the following status.

Tracker return 50 peers.

Maybe I configured the Listen Port wrong.But that's unlikely because I followed the exact instructions and got a green light.

I will have a look at the links you have posted.

But for now, (for me at least) a blocked listen port is getting me better speeds than an open port. Strange..........

I might be the only one with this kind of problem. So again, Thanks for the replies and the help, and even if I can't solve my problem, I hope my explanations will help the Members, Admins and Developers understand the Bitcomet client better.

Edited by BlazeSeven (see edit history)
Link to comment
Share on other sites

That is an extremely slow speed, although I don't know what your connection is. But it's a very minimal speed for any sort of broadband -- and it is about in line with what I would expect, if you were in no-listen port mode or hadn't opened your port properly.

As an experiment, try changing to no-listen mode, then run the torrent for a while and see if there's any significant difference in speed.

You should be able to reach considerably higher speed if you get your listen port open. You may not be able to do so at work.

Link to comment
Share on other sites


Maybe it was just a coincidence that the trackers responded right after you closed the port. An open port means that you can connect to more peers, more peers mean a bigger possible speed.

Can you please go to speedtest.net and test your bandwidth? Also, try pingtest.net, to make sure the other peers don't disconnect you for too many hash fails.

Link to comment
Share on other sites

The tracker error you saw in the Tracker tab is not related to/provoked by your machine.

As you can see in the error message it says that the tracker didn't respond in due time. Usually most of the tracker errors reported in that window indicate a problem on the side of the tracker machine, not yours.

So, resetting the router and blocking your port was a bad move.

It is very common that some trackers do not respond at some point and that later on, they are reachable.

If you really want to test your speeds in blocked and open listen port mode, do it for a torrent with lots of peers and reliable trackers, such as the torrent for Open Office.

Link to comment
Share on other sites

Well... I know 60KB/s is a very slow speed and i'm disappointed about it too. But I live in the Maldives.......and this is the fastest home user unlimited connection available. I'll open my port again and use it a little longer to see what happens. I'm thinking of formatting my computer tonight to see if it changes the LT-Seeds status. Plan B would be to connect my brother's cpu to my internet connection. He does not have an internet connection at the moment, so maybe connecting a new cpu would get the LT Seeds back.At least with Plan B I could find out if the problem is with my internet connection or my cpu. I realize that you guys know very little about how exactly LT-Seeds work......but do you know if there might be an undetected virus in my computer that might prevent bitcomet from connecting to LT-Seeds. I'm using bitcomet 1.16 on windows 7. I will also try using a previous version of bitcomet to see if it changes anything.

These are some of the things I've been thinking about trying to solve the problem.

Its times like these that I wish there could be a status light for the LT-Seeds server......similar to the DHT, Listen Port and Login lights.

So that I we would know the exact status of the LT-Seed Server. Maybe I might check out the feature requests forum and add my suggestion. It will make an already feature packed Bitcomet client even better. I'm in no rush for this feature to be added though, as I know Bitcomet is a free service.

I'll keep you all posted on how my various attempts to solve my LT-Seeds mystery goes. I think "Operation Plan B"(The code name i've decided call it) will be my best hope of at finding out whats causing my LT-Seed problem.

Any comments or views regarding this post is welcome.


Edited by BlazeSeven (see edit history)
Link to comment
Share on other sites

  • 2 weeks later...

I finally managed to solve the problem.

About three days ago my internet connection started to freeze about every ten minutes or so. When this happened I had to reset my router every time.

So I tried scanning with a few antivirus softwares and found a couple of malware. But even after this, my net connection was freezing and I still could not connect to LT-Seeds. So I reset my router, turned it off, and then fully format my computer.After installing windows again, I turned on the router and now everything is working perfectly. I can connect to LT-Seeds again.

I guess there was an undetected virus messing with the router which also prevented bitcomet from connecting to the LT-Seed Server.(At least that's what I think).

I'm really happy now.A BIG THANKS to all who offered help.YOU GUYS ARE THE BEST.

Link to comment
Share on other sites

That is a very possible solution to the issue, so it's great that you solved it -- but not so great that you might still be vulnerable to it. DrWeb has a scan tool that seems to be doing a better job than most others. Kaspersky also has a tool that is good at detection, but not so good at solutions. These might be worth your while to install.

Link to comment
Share on other sites

@ Kluelos

Thanks for the scanner suggestions. I'll try the trial versions and see if I find any more viruses.

I've got one small question though.

I've seen the post noted above that you guys are aware of the problems signing into bitcomet passport. So again, I cant login to bitcomet. (I hope the remaining issues are fixed soon). Again I have no LT-Seeds.(It says NO SUPPORT).

My question is, right now is my bitcomet client not supporting LT-Seeds because i cant login, (Does anybody else have LT-Seeds?) or is this just only my problem again?.

I ask this question because I lost the LT-Seeds at the same time I was unable to login to Bitcomet passport.

I was just wondering? is it normal to have no support for LT-Seeds when you can't login to bitcomet?.

I know I'm kind of dragging this topic on and on (you guys must be bored.........i almost am). I hope someone can answer the final question above. Ive been wanting to clear that ever since I started using bitcomet. Its probably the only question I have left on this topic.

Anyway......eventually i'm hoping when everyone can sign into bitcomet, I'll have the LT-Seeds again. If not, i'll know that my router or computer is being messed up by an annoying virus again, and format again.


Link to comment
Share on other sites

They are one and the same effect. LT seeds come only from the BitComet server, as this is a BitComet-only concept. No other clients have adopted it.

So you must be logged in to the server, before it will respond to your client's query about LT seeds for a particular torrent.

When the server's down, you can't log in to it, therefore can't query it for LT seeds.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...