Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

[NEW] BitComet v1.21 is here!!


Recommended Posts

Dear all, BitComet version 1.21 has released.

You are all welcomed to download and test this version from the official website.

v1.21 2010.05.28

GUI Improved: support open magnet URI with multiple tracker parameters

GUI Improved: include multiple tracker parameters when copy magnet URI from BitTorrent task

GUI Improved: download installation package of new version in background automatically if enabled

GUI Improved: support SHA1 verification for downloaded file in HTTP task properties dialog

GUI Improved: display confirmation dialog when choose re-download HTTP task

GUI Improved: improve icons in context menu of task list

GUI Improved: rename "Web Interface" to "Remote Download" in Option dialog

GUI Improved: username, password and referrer can be specified when add HTTP download in Remote Download web page

GUI Improved: add log list for HTTP task connections in Remote Download web page

GUI Improved: add start/stop operations in task info web page of Remote Download

GUI Improved: Firefox extension supports capture .hlv video file

GUI Improved: when using multiple user accounts of Windows, each user has individual task list and program settings

GUI Bugfix: share ratios of BitTorrent tasks are displayed incorrectly when program just started

GUI Bugfix: displaying tooltip in toolbar may lead to crash

Core Improve: support file path longer than 260 characters

Core Improve: remove LUA scripts support for intelligent rename of HTTP download

Core Improve: update BitTorrent client identification code

Core Bugfix: fail to download HTTP URL containing single quotes

Please kindly leave your suggestions, feedbacks, and bug reports here.

Thank you for your support!

The BitComet Team

Link to comment
Share on other sites

Downloaded , installed

All my tasks has gone ! There is nothing to seed / downlaod , all settings reset by defualt !

We cannot begin to diagnose why this is until you provide the essential information.

Read This Before Posting Support Requests

Link to comment
Share on other sites

SFD, relax already. Calm, calm. Panic doesn't help and there's no reason for it. Nothing is lost.

There is even a FAQ entry on this subject, so if you calmed down and looked, you'd find it.

BitComet used to store things in the Program Files tree. Random junk shouldn't be put there, it's for Program Files only. This is Windows' environment, and Windows is finally paying some attention to keeping its environment clean. So now we store things in another place the %appdata% tree. That's all.

If you install the new version (or the older version) right on top of the existing version, everything is fine. But if you uninstall the old version, then install the new one, you run into this issue. The new version looks in the new place, doesn't find anything, so apparently all your settings and tasks are lost. They're still in the old place.

Look here for the FAQ entry.

Link to comment
Share on other sites


I've been using BitComet for sometime, altho I was stupid not to think of making a backup of my torrent list before upgrading to 1.21. I read the link that has been circling in this thread, about retrieving your torrent history/download list. I've tried what is says in there, to no avail. All I've been able to do is restore the port I was using as the listening port before upgrading.

There was also mention of the \Torrents folder under \Program Files, but there's nothing listed in that folder. And I tried simply clicking Import Unfinished Download, and that keeps telling me the file doesn't exist.

Does anybody have any more suggestions if the earlier mentioned directions fail? Or tell it to me straight: am I just screwed and gotta find them again? :) Also, what can I do to have downloaded files relisted so I can set them to upload again?

And now, for the Essentials:

I'm now using BitComet 1.21

I have Windows Vista Home Premium as my OS

Since I'm not having a problem with downloading or my router and dl/ul speeds, I'll leave that out unless requested

I have a particular folder for my downloads in my C: drive, altho I don't think that'll be necessary to know.

Any help would be appreciated. Thanks, guys!

Link to comment
Share on other sites

That topic states very clearly that if you use Vista or later you should look for your configuration files in the C:\Users\%userprofile%\AppData\Local\VirtualStore\Program Files\BitComet folder not into C:\Program Files\BitComet.

Did you search in there for them?

Also, based on what version you were using before, your files might have been already moved to C:\Users\%userprofile%\AppData\Roaming\BitComet.

What is the status of the system.use_app_data setting on the Options-->Advanced settings page? (Just read it to us, don't touch it, for now.)

Link to comment
Share on other sites

If it all sounds a bit pedantic, thank Vista for that. As I said, Windows finally figured out it was a bad idea to have people messing around in its environment -- so it decided to HIDE that environment from you. If you casually go into c:\Program Files\Bitcomet, you are not where you think you are. Vista has deceived you and put you elsewhere, into Virtual Store.

Gotta love it. You just THINK you're in the program files tree, and nothing's there. You're REALLY somewhere *else* in %appdata%, and of course nothing is there. BitComet was using the REAL program files directory, not the fake one.

So bone up on Virtual Store and how to get around its tricks.

Link to comment
Share on other sites

Guys, don't take this sounding snappish, but I'm a little more aware of how to navigate my computer than others you might talk to. Of course, I sometimes read too quickly on some things. I figured out my solution; completely read without registering the suggestion to look in \Torrents and add the Bitcomet files was talking about the folder in the VirtualStore, not the Documents and Settings. I had looked into the archive and share folders, but didn't know if the files in those folders corresponded with the torrents I had in my task list and didn't bother trying them. Anyhoo, I'm hash checking them now to get 'em back up and running.

One new question: Like I said earlier, I found my files under C:\Users\%userprofile%\AppData\Local\VirtualStore\Program Files\BitComet and not C:\Documents & Settings\%userprofile%\Application Data\BitComet. I read this particular section on the FAQ--

"If you're upgrading from an older version to a newer one and all your tasks/settings vanish – if you've been caught by the store-in-programfiles vs store-in-appdata issue that was mentioned above, then you'll need to copy the files from the “program files” location to the “application data” location. Make sure BC is stopped. Copy all of the files of type ”.xml” from the one to the other. "

So, just to confirm, this is saying to switch from the former file path to the latter, yes? With BitComet off of course; I made sure to read this slowly. :) I'm a bit fuzzy about the FAQ saying that if I was simply upgrading from an old version to a new version, that the new version would keep the same settings as the old. Well, that didn't seem to happen, from seeing that I had to change the listening port back and my max dl/ul rates, etc., to what I had had. So yea, nay, on whether I should just leave the pathway as it is or change it to where the BitComet folder should be? Copy ALL files and folders under \BitComet, or just .xml? I just don't want this to continue with each upgrade, altho I will be making backups from now on.

Edited by unicornofatlantis (see edit history)
Link to comment
Share on other sites

What is the status of the system.use_app_data setting on the Options-->Advanced settings page? (Just read it to us, don't touch it, for now.)

As I said, if you told us the value of this option we would know what your client's setting is at present time.

If it's FALSE then by setting it to TRUE, BitComet should automatically move all the configuration files from the VirtualStore to the APP_DATA folder.

As for the upgrading process, obviously, something went wrong in your case, otherwise you wouldn't have lost your Task List.

Starting with Vista, Windows won't allow any program to write in the system folders (Program Files being among them) unless it's running in elevated privileges mode.

Since during normal operation most applications (BitComet included) don't run in elevated mode when they try to write/read in the Program Files folder they will get redirected transparently to the VirtualStore\Program Files\ folder (that is the application doesn't know that it's not writing/reading in the real folder, and will be fooled into thinking that it works as is did before, in previous versions of Windows).

This is called the data virtualization feature of Windows and it's part of the new User Account Control (UAC) system implemented in Windows, starting with Vista.

That's why your files are in the VirtualStore folder; because there is where they should be under Vista.

The thing is that if you disable for whatever reason the UAC system in Vista, the data virtualization won't work anymore and all programs will be able to write/read again in system folders (Program Files included).

The data virtualization feature was introduced in Vista as a means to make older applications (i.e. all applications which haven't been updated as to be Vista-compatible) still work in the new operating system.

But Microsoft's recommendation is to avoid trying to write in Program Files anymore, and use the alternate locations for storing configuration or data files created during normal operation.

I guess you can start to see what mess this can create on a user's PC which unknowingly may switch off and on UAC, repeatedly.

We had to deal with endless complaints about lost tasklists and configuration files, and that's why starting with v.1.18 the development team decided to use the %AppData%\BitComet folder for storing configuration files instead of leaving BitComet being redirected to the VirtualStore anymore.

They had to deal somehow though, with the zillion of users which already had older versions installed and for which and upgrade over the old version would have meant loosing all their configuration files (tasklist included).

That's why they created this option system.use_app_data and decided that BitComet would first search for previous installations and if any was found it should keep the old configuration folders instead of using the App_Data folder (i.e. set the option to FALSE), to avoid any problems at installation time.

But if you manually change the value of the option from FALSE to TRUE, BitComet should move all the files from one place to another.

Now back to your case.

The problem you faced shouldn't have happened. However, be aware that most probably your tasklist is not lost (at least that's what I gather from your saying that you found the .torrent files in the VirtualStore location); it's rather a problem of BitComet looking for them in the wrong location.

But in order to start figuring out which is what we'll need to know:

  1. What is the current state of the system.use_app_data option now (after upgrading)?
  2. What was your BitComet version before upgrading?
  3. Is your UAC on or off?
  4. Was it on or off before and during the upgrade process?

Link to comment
Share on other sites

Keep in mind that this whole Virtual Store thing can appear just as confusing to BitComet, depending on the privileges of the account it's running under. BitComet has no magical way to set aside Virtual Store. (I wish!)

So what we're talking about is what BC TRIES to do, using one location or the other subject to vagaries imposed by Virtual Store. This is compounded by a usually-incomplete picture of what actions the member took beforehand.

We have to try to write the FAQ so it's accessible to a wide variety of knowledge and skills, but also to older versions. That's a tricky thing to do. Likewise with questions in this forum. We encourage people to search the forum first, because their question may have been answered before. That also means trying to tailor the answer to an unknown future audience with variable skill levels. That's a LOT harder.

Link to comment
Share on other sites

  • 2 weeks later...

1) True

2) 1.20

3) On

4) On

All I did was upgrade. I has windows vista. My torrent list is blank. I found the downloads.xml.bak file in the hidden appdata folder but I don't know hoe to import it to Bitcomet. I wish we got a little more warning about this new implementation in how windows vista store data on the computer and how Bitcomet was gonna integrate this functionality. A heads-up next time. Had I known about this, then I'd probably wouldn't had upgrade.

Link to comment
Share on other sites

A heads-up next time. Had I known about this, then I'd probably wouldn't had upgrade.

Well, microsoft did announce all this, but in their usual vastly overcomplicated language making it fly virtually over the heads of the average users.

Or are you saying that BitComet should have warned you that Microsoft is about to vastly overcomplicate your life if you upgrade to vista/seven?

Well, you can always go back to Windows XP, but in my opinion, Windows Vista and Seven are a better product and are worth learning.

Link to comment
Share on other sites

  • 2 weeks later...

pls i am using aircard and i cant port foward but i used to get a speed of 100 - 180kb/s if the torrent file has many seeders and leechers but since i upgraded to 1.21 my download speed has drastically reduced to a max of 36kb/s.i have been looking for a way to increase it back but up to no avail.pls does anyone know what is wrong cos i now download a movie for 6 hours plus.HELP PLS

Link to comment
Share on other sites

pls i am using aircard and i cant port foward but i used to get a speed of 100 - 180kb/s if the torrent file has many seeders and leechers but since i upgraded to 1.21 my download speed has drastically reduced to a max of 36kb/s.i have been looking for a way to increase it back but up to no avail.pls does anyone know what is wrong cos i now download a movie for 6 hours plus.HELP PLS

Try reading the rules before posting a support request. Also post in the correct area, we do not open a support request within other topics, doing so will only confuse the original topic.

Also, when you make your topic, if you don't post the required info, then expect to get a reply asking for you to read the rules (again). I'll also point out that doing so wastes your time much as it does ours.

However, if your looking for a wild guess from what little info you posted, I'd say its the torrent at issues here, not your client or your settings. Since your firewalled, no other peers can reach you when THEY are willing to trade, so you have to get lucky and send a connection to them at the time they are accepting trade (unchoked).

One "less then perfect" alternative to an open port would be NAT Traversal (last supported in version 1.02). It has drawbacks, which is why it's no longer supported, but it can allow for some remote connections to get through. If you had given us the proper history and info, then we would know if you were using this in a prior version or not. In any case, your welcome to try.

Link to comment
Share on other sites

  • Create New...