Jump to content
Comet Forums
deshpande

Listen port open...but, UPnP NAT port mapping: Failed [UPNP device not found!]

Recommended Posts

Listen port open(there in green light)...but, UPnP NAT port mapping:Failed [uPNP device not found!]

since green light is there, can i neglect this part

"UPnP NAT port mapping: Failed [uPNP device not found!]"

my listen port of tcp and udp are open...

  • Like 1

Share this post


Link to post
Share on other sites

UPnP is an unreliable automatic router configuration. Many routers don't support it, others support it badly. When something goes wrong, it's impossible to diagnose.

If UPnP happens to work for you, great, but if it stops working, you're generally stuck. Manually configuring your router has proven to be much more reliable, and if the configuration changes, you can do something about it.

If your router does not support UPnP, then you get the message, "UPnP device not found".

Share this post


Link to post
Share on other sites

OS: Windows 7 64Bit

My router: DLINK DIR-655

BitComet Version: 1.24 Stable Release for 2000/XP/Vista (Help\About\????? did not show Win 7)

The green light is ON! BUT BitComet\Statistics\UPnP NAT port mapping: Failed [Windows version Not Supported!]

That's the problem why UPnP is not opened. Is Bug is software, BitComet_1.24_setup.exe 7,890,192 byte!

Please give a new update asap to solve the above problems.Thank you

Share this post


Link to post
Share on other sites

Hey, gwenkent.

Your "issue", which is incredibly similar to the one of the first poster has just been answered by kluelos in the post above yours. Have you not seen it or are you pretending not to see it?

If you have read it and didn't understand it, then you'd better ask for clarifications than pretend not seeing it, 'cause it just sounds plain rude, when someone is bothering to give you an explanation, and you're pretending not to hear him and just turn up the microphone, get up on the scene and ask loudly the same question again.

Share this post


Link to post
Share on other sites

Hey, gwenkent.

Your "issue", which is incredibly similar to the one of the first poster has just been answered by kluelos in the post above yours. Have you not seen it or are you pretending not to see it?

If you have read it and didn't understand it, then you'd better ask for clarifications than pretend not seeing it, 'cause it just sounds plain rude, when someone is bothering to give you an explanation, and you're pretending not to hear him and just turn up the microphone, get up on the scene and ask loudly the same question again.

My router DIR-655 does support UPnP for all my recents clients inculding prior BitComet v1.23. But after the upgrade to v1.24, the UPnP failed to connect. Therefore, I assumed that there is problems with the new v1.24. If there is no "cure or updates", I will revert back to v1.23.

I did see kluelos threads. He did not ask any similar questions or statements made by me; undefined or ambiguous words that is not to ridicule me and to peace me.

Edited by gwenkent (see edit history)

Share this post


Link to post
Share on other sites

The purpose of the UPnP mapper is to provide you with an open port, automatically (read: without tedious configuration from the user's part) when you're using a router.

As kluelos stated above, sometimes that works other times it doesn't.

If you ALREADY HAVE a green light (a.k.a. an open listen port) for your BitComet client, the status (successful or failed) of the UPnP mapper is irrelevant.

So you have nothing to worry about. Even if you didn't have a green light (open port) there is still the possibility of manually opening a port on your router (and there is a detailed guide about that in the Wiki).

So, unless you liked any of the previous versions better (for entirely different reasons) you have no gain from reverting back to an older version.

Share this post


Link to post
Share on other sites

I think I could have been clearer about something.

If you have disabled UPnP, either on the router end or BitComet's end, then BitComet will ALWAYS report, "UPnP Device not found!" and "UPnP Failed!" and suchlike.

But since you've disabled it, this is no cause for concern at all. "Failed? Of course it failed, (You eedjit!) I turned it off. The problem would be if it DIDN'T fail!"

Really should request a fix for that someday.

UPnP depends on a fairly fragile and mostly invisible chain. If something goes wrong with it, there's usually nothing you can do about it. You may get an incomprehensible diagnostic message, but even if you knew what it meant you couldn't change the router's BIOS or the program's code. There are no user-adjustable parameters on either end.

Manual configuration, on the other hand, is always going to work, and will let you change clients, client versions, routers and gateways and still be in control of things. This is worth learning.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...