Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Hashing Problem


Recommended Posts

I have had a large file loading for quite a while now (due to a rural location, my internet is quite slow).

After stopping my loading for a little while, my progress read as 0.00%.

I ran a Manual Hash Check and it was unable to locate what had already been loading (about 25%).

Is there a way that I can help locate these file or something else that I can do to get the progress back? If not, it will be quite frustrating.

Thank you!

Link to comment
Share on other sites

The manual hash check computes the SHA5 hash index (q.g.) for each completed piece of the torrent you've downloaded so far, and compares it with the value for that piece contained in the .torrent file you first downloaded. If there's a mismatch, this indicates a transmission error, and that the piece is garbled, so BitComet deletes that piece in order to try again.

If your progress when you stopped was 0%, you did not successfully download any part of the torrent. That's not usual unless a torrent isn't being seeded.

But then you indicate that you'd already downloaded about 25% of it. I don't understand where that number came from. Why do you think you had downloaded 25% of it if BitComet was saying that the % downloaded was zero?

Link to comment
Share on other sites

I still don't get that.

If I have BitComet running along with a torrent, and I've downloaded 31%, then I stop it, BitComet still shows me that 31%.

If I shut BitComet down, turn my computer off, then come back and restart, BitComet still shows me I have 31% of the torrent.

The only time it would show 0% again is if I removed the task from BitComet completely, then added it again. Even then, BitComet would normally detect the partial download, hash-check it, then resume it at 31%. I'd have to remove the partial download manually or tell BitComet to delete the downloaded files, to get it to disappear.

So I still don't get what's happening to you.

Link to comment
Share on other sites

Sorry, I wasn't being clear. Let me try again.

My file had loaded about 25%.

I stopped the loading temporarily. When I tried to restart it the progress read 0%.

So, BEFORE I stopped loading, the progress read 25%. AFTER I stopped loading, the progress read 0%.

There have been other occasions when the wrong percentage has appeared after a file has been stopped from loading. On these occasions I have been able to run a manual hash check to obtain the correct amount of progress.

Recently when I have tried hashing, the following occurs:

1. Progress reads 11.2%

2. Bitcomet proceeds hashing until the progress is 100%

3. The progress for my file returns to 0%.

Other information:

Bitcomet 1.22

Satellite Internet

- connects to SurfBeam

Windows XP, AVG Antivirus

Anyway, hopefully I can get this sorted out. I’ve been using Bitcomet for years without a problem. =)

Link to comment
Share on other sites

BitComet does not observably behave like that. When you stop the task the downloaded amount will remain, unless some external process deletes it or you act to alter the task parameters.

Some other intervention is required to produce this behavior, or you are mistaking the % downloaded for something else.

Can you post screen shots showing the % downloaded before you stop the task, and the situation immediately after you've stopped the task?

Perhaps with these we can figure out what's going on.

Link to comment
Share on other sites

The only time I've seen this behavior is when a user was disabling files within a torrent, thinking that was a good way to "pause" the download, when infact they were deleting the files.

Perhaps you can explain in detail what you mean by...

I stopped the loading temporarily.

Being the terms you use aren't correct to describe the proper way to stop a task, I can only assume you have done something unusual that is causing the data loss you report.

Also, you have included none of the required info for making a support request, so a huge amount of assumption has to be made to even begin to guess what may be your problem. For example, we don't even know if your downloading a torrent task. If the file/s your "downloading" (not loading) are an http or ftp task, then you cannot stop the task unless the providing server allows stopped tasks to resume, so in that case bitcomet would be behaving normally to revert to 0%.

Link to comment
Share on other sites

I have been searching to see what I might have done to cause the problem.

I found something that struck me as odd and could possibly be the source of my issues, this is what I did:

1) Right clicked on task

2) Looked at drop-down menu

3) Held cursor over "Move file to"

4) I see that my files have been moved to a "temporary internet file."

I do not know what I did to prompt this change.

When I investigated further I saw that there were no files downloaded within the temporary file. I assume (maybe incorrectly) that this lack of downloading would be why my hash check always says 0.00%

When I look at the original location in my C: drive the files are still there and partially downloaded.

Do you know how I can "reconnect" the task with the files?

I'm sorry about my incorrect terms and such- I realize that I'm not making your job any easier and I appreciate all of the efforts you are making to help me.

Link to comment
Share on other sites

1) Files do not get saved or moved to another destination unless YOU save it to that destination when you first start the task or YOU move it to that location!

2) To get BitComet to be able to find see the partially downloaded file, you need to stop the task, right click and MOVE it back to the location you originally saved it to.

3) OR you could physically cut and paste (or move, depending on your OS)) the folder that contains the partially downloaded file to a more suitable place on your hard drive (like your downloads folder?) and THEN follow step 2 above.

4) If you do step 2 or 3 correctly, Bitcomet WILL see and correctly report the partially downloaded file when you do a manual hash check. But if you do not tell BitComet the right location, you cannot expect it to find it and correctly report its download status :rolleyes:

Link to comment
Share on other sites

You do have a working firewall, don't you? Antivirus too? Are you the only one using that pc?

If you're positive that when you opened the torrent with BitComet you chose the "Save path" to be C:\etc...etc then here's an alternative to the above post: right click the task (when it's stopped) select "Proprieties" and write that path (C:\etc...etc) in the "Save path" text box from the "General" tab. Then right click the task again and select "Manual hash check". Let me know if you need screenshots...

If the above works, go to that "temporary internet file" and delete it.

Link to comment
Share on other sites

Thank you very much! It's all sorted out. And I have added evidence to my theory that the greatest time-consumer for the non-tech-savvy person is fixing the problems that he/she cause him/herself.

Thanks again!

Well said! I'm sure most of us non-techy types (and that includes me) can identify only too well with that theory Megefl :(

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...