Jump to content
Comet Forums

Listen port open then closes


Recommended Posts

Hi Guys

Normally configuring the port forwarding is not an issue but this time it has has me pulling out my hair trying to fix it! Basically the listen port is open at start-up but after about a minute (or a couple more), it then becomes blocked.

Bitcomt 1.25


D-Link DVA-G3670B

Windows XP Pro with AVG Anti-Virus software

I have read the guides on here and around the traps so what am I missing to keep the port staying open?

Link to comment
Share on other sites

If the port is open when bitcomet starts, or is opened sucessfully by bitcomet, then suddenly is blocked, I'd suspect you have another firewall or security program thats blocking your incoming connections. You can recheck the port by hovering over it and clicking the right button, then "check again". Also, there are three colors, gray (untested or unconfirmed), yellow (blocked), green (open). It would be normal to go from gray to yellow when starting, but not green to yellow unless there is something installed that is interfering.

I can't list every program that can cause this test to fail, but if you use an IP filtering program like peer-guardian/peer-block, improper setting can make this test fail even if the port is open. Also Nvidia's network address manager is well known to block incoming connection attempts on all ports regardless of the settings you use in its configuration.

I'd say your first step would be to test the port yourself. You can do that at...


Link to comment
Share on other sites

  • 1 month later...

As I've been a little busy lately, this has not been resolved.

When Bitcomet starts, it will go from grey then to green. I notice that Bitcomet downloads at a fast speed then either a few minutes or seconds, the downloads become slow. The light will still be green but when right clicking to refresh, it then becomes yellow. So I close Bitcomet, start again and back to square one. Sometimes when starting it goes straight from grey to yellow.

Before I posted the first post I had re-formatted the hard drive so there is hardly anything on here compared to before the re-formatting. Pretty much the only programs on here area ArchiCAD, MS Office, iTunes, Quicktime, Nero 7, Winamp, WinRAR, Power Shutdown, Fallout 3 Vegas, GTA IV Liberty City and that's about it other than printer, video and sound card drivers.

I do not use those other programs you had mentioned such as Nvidia's network address manager or any other IP filtering program like peer-guardian/peer-block.

It's a little frustrating as I have set-up Bitcomet quite a few times before with never any issues but this one has stumped me.

Link to comment
Share on other sites

When BitComet says your port may be blocked, then check first to see whether you have any peers with Remote connections on any torrent. Check then with canyouseeme about whether it thinks your port is blocked.

Transitions like this, if they are real, are usually the result of a dynamic IP address configuration on your computer.

Link to comment
Share on other sites

  • 2 weeks later...
Transitions like this, if they are real, are usually the result of a dynamic IP address configuration on your computer.

Sounds like what I may have with some more testing and fiddling.

As before, grey to green and then a few minutes later right click, refresh and then yellow.

If I exit Bitcomet and re-start, starts on green.

However when I re-start my computer, it goes straight to yellow.

To solve this, I turn my modem off and on again and so repeat the cycle above.

Any other ideas welcome!

Link to comment
Share on other sites

  • 3 years later...

I know this is a very old thread but after researching my problem and ending up here I found my solution, which may help others.

I could make several downloads over a day or several days with my listening port open. Then it would become blocked so I would try resetting everything, rebooting router etc., after much messing about I would get the port open again but without knowing exactly what fixed it.

Re: post #2 - recheck the port by hovering over it and clicking the right button, then "check again".

There is another option - Retry UPN port mapping

And it worked for me, several times now. So hopefully this will help someone else in the same boat.

Link to comment
Share on other sites

And how come there's no 'edit post' option?

There is a time limit for editing a post. We've had many members who when asked for additional info would edit it into the original post instead of replying which made the entire post hopelessly confusing to anyone trying to seek help on their own. I don't recall exactly but I think you have about 30mins to edit a post.

If there is an urgent matter you can contact any staff member for help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...