Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

desperate help needed before virus kill my computer

Recommended Posts

can someone please please help. im trying to use bitcomet to download.

it has a grey light on the bottom right corner stating listen port staus is unknown!

my antivirus has expired and im desperate to download a new one.

i have allowed bit comet through my firewall, and still no such luck.

if anyone has any suggestions please help


Link to comment
Share on other sites

We're all eager to help, but since our crystal ball has broken, we can't divine anymore what is your system configuration. :rolleyes:

In the meantime you could try using the "Read This Before Posting" link, on top of this page and provide some info. Perhaps then we'll be able to give you a hand.

Link to comment
Share on other sites

Oh, it's not broken anymore, the shop returned it Friday. I took it to the cleaners. Filthy, just filthy it was, sawdust and grease all over it, scratches ... It should be back Thursday. I hope they don't use too much starch like last time.

BitComet tries to contact a remote server and ask it to probe your listen port while it listens for the probe. A gray light means that BitComet could not, for whatever reason, contact that server. Possibly you have an IP blacklist preventing it, or your ISP has blocked that address, or it's just temporarily unreachable for you.

Without much more information from you, we can't be of help.

Link to comment
Share on other sites

1) What version of BitComet are you using? Bitcomet 1.20

2) What type of Internet connection do you have (ADSL, etc.)? ADSL.

3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port? NETGEAR WIRELESS ROUTER.

5) What version of Windows, Firewall and Antivirus do you use? WINDOWS VISTA, AVG FIREWALL AND AVG ANTIVIRUS.



Link to comment
Share on other sites

Please tap your CAPS LOCK key so you're not typing in ALL UPPERCASE. It's difficult to read and is considered rather rude.

Having a blocked listening port will not prevent you from downloading. BitComet will work just fine, if more slowly, without a listen port at all. It's important not to conflate issues.

The built-in windows firewall is perfectly adequate for most people. I do not recommend any third-party firewalls unless you understand them very well and know exactly what you're doing with them. Having more than one firewall does not make you more secure, but it does multiply your configuration headaches. At this point, you have the firewall in your router, the built-in firewall in Windows, and you've added the AVG firewall. I strongly recommend you uninstall that last one.

BitComet will, if so configured, automatically control the Windows firewall for you.

For the router's firewall, you will need to properly forward your chosen listen port through it. Let me reiterate though, that BitComet does not need an open listen port in order to function. It's better to have one, it's faster, but not necessary.

Link to comment
Share on other sites

hi again i really am struggling to find help.

ive tried google, wiki, and the help hints on here.

if i dont need a listening port in order to be able to download, does anyone have any idea why my downloading has just suddenly stopped orking.

nothing has changed on my computer i still have bitcomet checked to allow through firewall, i cant find any other reason for it to have just suddenly stopped downloading.

ive also tried downloading a song with 7843 feeders and still no download!

dht connected

Link to comment
Share on other sites

grey wizard, ive clicked on the link, choosen open, download now, its appearing in my bitcomet files as downloading, but ive just checked it and still no download.

kluelos, i was told if i choose a file on btjunkie to download with a lot of feeders (people allowing others to download off them), it would download, but still no such luck.

my port number is 22472.

is it worth unloading bitcomet and re-installing it?

thanks guys for the suggestions so far.

Link to comment
Share on other sites

nikkibra3, you probably weren't. You were told to pick a *torrent* with a lot of *seeders*, not a *file* with a lot of *feeders*.

I foresee a great deal of difficulty for you in the future, if you continue to casually substitute casual synonyms for vaguely understood technical terms.

The number of seeders is not too important, since you will be getting most of your download from other leechers under normal circumstances. That's the first thing to understand. Some well-meaning person is trying to tell you that you want a torrent for which all of the pieces are available. Torrents with many seeders in the past will likely still be such, but not only those and not exclusively. What matters is the torrent's "health" being above 100%. You won't know that until you've started your download.

The next thing to grasp is that the counts listed on index sites are almost always out-of-date, from a little bit to a lot. What matters to you is what the swarm composition is NOW and in the immediate future, when you're trying to download it. What it WAS at any point in the past, makes no difference. You are trying to download now, not yesterday, last week, last month.

The port number that you choose does not matter. One port is fully as good as any other, technologically. Whichever one you pick will be communicated to others, and they'll know which one to use for you. It's just best to pick one that isn't commonly used for anything else, in order to avoid confusion. Use 65432 and be done with it.

You're not doing too well in the area of following suggestions here, nikkibra. Should we waste our time giving you any others to ignore?

Link to comment
Share on other sites

i have tried asking for help only to be spoken to as an idiot, treat with no respect and had people been down right rude.

i have asked for help been honest that im not fantastic with computers but i would appreciate any help offered!

you state you dont want to spend your time offering suggestions if im going to ignore them.... what suggestions may these be?

i would appreciate any help anyone would like to give, but if people feel i am ignoring these suggestions they are wrong.

i dont feel ive been given any constructive advice as to what may be causing the problem or how to deal with it.

Link to comment
Share on other sites

The fact that the status light is gray is probably a sign that BitComet can't achieve even outgoing connections.

If you say that you can connect to nil peers for any torrent you add to the Task List, this only confirms that.

You may try upgrading to the latest version. That doesn't grant that you'll solve your problem, just that there won't be any issue with the BitComet installation itself.

This issue most probably would be caused by misconfiguration of a firewall or lack of configuration in any of them. You need to acknowledge that you have (at least) 2-3 firewalls standing at this point between you and the Internet:

  • Windows firewall
  • AVG firewall
  • your router's firewall.

Out of these BitComet can automatically configure only the Windows firewall (and that only if told to do so, on the Options-->Connection page).

The rest of them are up to you. Since we can't see the configuration for any of these, is kind of hard to draw an informed conclusion.

1. Post a screenshot of the tab of BitComet and a screenshot of the Options-->Connection page.

2. Disable/unistall entirely the AVG firewall (Third party firewalls are recommended only for people who are sure that they know how to configure them properly. For now, you're better off without it, in order to solve this issue. Besides, even if you want to use it again later, you should be running only ONE software firewall at any time, not multiple ones.)

3. Look into your router's web interface (BTW you failed to report the exact model of your router) and report back the state of its firewall (enabled/disabled and if enabled: standard/custom state).

Then we'll have a little more info to start guessing what's happening.

Link to comment
Share on other sites

nikkibra3, you were asked for the make AND MODEL number of your router. You only reported the brand and ignored the model number.

Wiz suggested that you try downloading the Open Office torrent as a test. You ignored him.

I suggested you disable the AVG firewall. You ignored me.

As I reckon the rudeness score, it's Nikkibra:3, Support Team:0

Wiz just politely resummarized why we suggested these things, as we have been at pains to explain to you all along. If you don't want to listen and you don't want to take any of our suggestions, why waste your time and ours asking for help that you're not going to bother with?

Link to comment
Share on other sites

Grey wizard i am truely truely grateful that you are able to remain professional and i appreciate the fact that you seem to understand that not everyone on here is a computer genius.

a screenshot of the bitcomet is attached.

screen shot bitcomet.doc

a screenshot of connections is attached

screenshot of options, connections.doc

i have totally uninstalled avg firewall, and as i said in a previous post i tried downloading the link you provided but still no such luck.

apologies for missing the router number off this is, DG834G v3

the firewall on the router is disabled.

again thankyou for your patience in tying to help and i hope ive done everything correct that you suggested.

i have also tried upgrading to the latest version of bitcomet but it just shows up in my bitcomet tasks but isnt downloading.


Link to comment
Share on other sites

Nikkibra3, you have red X's beside your tasks.

As it says in the FAQ, if you had read it. this indicates that there's a system error of some sort (such as not being able to write to disk) associated with the task, and that if you mouseover the X, it will tell you what problem each is encountering.

This is what you should have reported originally. I understand that you are not a computer expert, but you need to understand that too. If you substitute your judgement for those who are, you end up chasing red herrings like port detection, when your issues are elsewhere entirely. Now, you may need to resolve the port issue someday, or you may not, but you definitely need to resolve the red X's, for you won't be able to download further until you do. They grey light isn't stopping you. The red X assuredly is.

Now with BitComet running, move your mouse cursor over the red X, and a tooltip will pop up, telling you what the problem is. It may be something that you understand immediately (like "disk full"). It may be something you don't quite understand. If the latter, then we will need to know precisely what the message is -- not "approximately" and not "something like". Not "feeders" instead of "seeders", for example.

When you do have a problem in the future, the FAQ should be your first resource. We collectively spend a lot of time writing them and keeping them up to date, to deal with commonly encountered issues. If there is a quick and easy solution to an issue, this is where you will probably find it.

Link to comment
Share on other sites

I'm sorry, I meant to tell you to post a screenshot of the Statistics tab, it just got lost in typing. Also a screenshot of the Trackers tab for the Open Office torrent would be good.

Try posting your screenshots directly in JPG or PNG images instead of Word documents; they are much easier to view.

You can save them even in Paint which is included in every Windows installation if you don't have installed another graphics program.

You don't have to download the new installer of BitComet within BitComet. Just download it in your browser and don't let BitComet download it, if it offers to do that. If you can't get around it, just go to the Options-->Integration page and disable the click-capturing feature of BitComet.

What are your connection's tested download/upload speeds? (Try a site such as http://speedtest.net.)

Link to comment
Share on other sites

the red x's all say, stopped[failure to connect to any available source. retry limit reached]



ive also gone through options etc etc, to download the latest version of bitcomet.

done a speed test this is,

download- 3.70mb/s



thanks for your help again

Link to comment
Share on other sites

I'm thinking this looks like a firewall issue to me. You may have something that works like a firewall installed that your unaware of, but something is blocking every connection attempt bitcomet is making.

Regarding the red "x"s, that is normal for an http/ftp task after it "times out", but since the bittorrent tasks don't have the red x on them, the problem isn't there, its simply that no connection to the internet, outgoing or incoming can be achieved.

support staff: note that besides no connected peers, and being unable to test port status, it is also likely he is unable to login to comet id.

A complete list of everything installed on this PC might be helpful, especially anything related to security, network, or firewall.

Link to comment
Share on other sites

Have you tried Avast? It may not be the best antivirus going, but it is free and updated regularly. I have been running it for more than a year hand have had only one virus it couldnt eliminate.

Link to comment
Share on other sites

ive also gone through options etc etc, to download the latest version of bitcomet.

I'm not exactly sure what you mean by this, but the question is: DID you download the last version or not? If not why?

First thing, you need to install it (or just download a ZIP version which doesn't need installation) and run it to see if another version of BitComet solves the issue or it's still there.

You NEED to test this before doing anything more.

If even another version of BitComet doesn't work, then open an administrator command prompt (Start --> type cmd in the Search box and then right-click on the "cmd.exe" entry which has been found and choose "Run as administrator").

Type this command:


and hit Enter.

This will create a file named processlist.txt on the partition (drive letter) where Windows is installed. Upload it here so that we can see what processes are running on your system.

Link to comment
Share on other sites

hi again, ive downloaded bitcomet 1.26

it is still not downloading, all red x's have gone but no downloads still.

ive tried the command but it just says access denied underneath the command, so ive screenshot a copy.


thankyou for your help and patience in trying to help me sort this.

Link to comment
Share on other sites

yes i am following instructions, i did exactly as stated, the only difference is when i search cmd all that my computer finds is cmd rather than cmd.exe


i right click on cmd click run as administrator and this is what pops up,


this is where i write the task in that was suggested.

i believe i AM following advice that is suggested

Link to comment
Share on other sites

The first screenshot doesn't show an "administrator" command prompt, and it's normal to get that "access is denied" message if your not running it as administrator.

Please try again from the administrator command prompt and post a screenshot if you get the same error you got before.

Also, the reason you don't see CMD instead of CMD.exe is that you have the option to hide file extensions turned on. I recommend you disable that in "folder options". It will help you to know what kind of files your working on.

Open any folder and click "tools" then "folder options" and the "view" tab and look for "hide file extensions for known file types" and uncheck it.

Then make sure you click on "APPLY TO FOLDERS" on the TOP of the window (the "apply" at the bottom only effects the folder you have open).

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...