Jump to content
Comet Forums

Recommended Posts

MPEG4 is not a codec per se, but a compression format defined in a standard comprising several parts. And as far as the great majority of video files out there (which implement it) are concerned, it's mostly encountered in two of its flavors:

  • MPEG4 - Part 2 ASP (Advanced Simple Profile) which is implemented in the famous: DivX, XviD, 3ivX, libavcodec and others;
  • MPEG4 - Part 10 also known as H.264 or AVC (Advanced Video Coding) which is implemented by codecs such as CoreAVC, x264, MainConcept and many others.

So, which one are you trying to play?

Share this post


Link to post
Share on other sites

There is a free program you can use to detect the type of video your attempting to play called "gspot", or if you want a simple fix, you can install a good codec pack. I use K-Lite codec pack (full). It's free and contains all the codecs needed to play every type of video I've ever used. Just keep in mind that installing conflicting codecs can make your system unstable, so don't go changing the default settings unless you know what your doing. also don't install multiple codec packs.

Share this post


Link to post
Share on other sites

@TUUS: But MPC Star already contains ffdshow internally, which decodes most formats out there; installing an external codec pack seems redundant here.

My guess it that the decoding for the codec type this files uses is disabled in ffdshow. That's why I was asking for codec type.

Share this post


Link to post
Share on other sites

The codec pack you installed should have some sort of settings utility that came with it.

Share this post


Link to post
Share on other sites

Most .avi files are Divx or Xvid, which use h263/x263 codec. Video encoded with h264/x264 are usually .mkv, .mp4 or .mov. Are you sure it's an .avi file?

I suggest you examine it with gspot and report the results.

Share this post


Link to post
Share on other sites

@acura1988: You can access the ffdshow video configuration page through the menu of MPCStar in the Start menu of Windows.

There check on the Codecs page of ffdshow and make sure that h.264 playback is enabled in ffdshow.

Share this post


Link to post
Share on other sites

When you are playing a file in MPCStar, look at the file info (under the FILE menu).

MPCStar will tell you all about what it's doing, there -- what streams it detected, how encoded, what it's using to handle them, and other things. You may be able to get a handle on what the problem is from that information.

Share this post


Link to post
Share on other sites
problem solved, thx

This is not a proper response for this forum. Our forum isn't here to only help you, it's here for other users as well, to learn how to solve similar problems, so simply saying it's solved without explaining exactly how you solved it, is somewhat rude and it doesn't help anyone reading this topic.

Please post exactly how you solved it, other wise this topic will be of no use to anyone.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...