Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Web seed only

Recommended Posts


I have just installed bitcomet 1.27 on windows XP. I have tried to download some torrent. I have a few problems :

Torrent from the pirate bay :

  • Tracker connection error 10061
  • Tracker connection error 10060
  • UDP Tracker no response
  • Logged in only on 1 tracker

Only 1 tracker give me some seeds but I can not connect to them.

Torrent Debian - CD1 :

  • Tracker connection error 10060

Torrent libreoffice :

  • Tracker connection error 10060
  • Web seeds allowed me to download it

The website grc.com tells my port is closed, but the port is in the exception of the firewall. I have tried to connect to the router but I do not have any login/password (it is not the default one) and the router is shared by many people.

I have tried to force the encryption of the torrent but can not download. DHT network is not working. I have tried http://www.bitlet.org/ but can not download.

I think my ISP and/or the router prevent me from using bittorrent.

Any idea to help?



Link to comment
Share on other sites

The best suggestion for you at this point is to look on top of this page and read the "Read This Before Posting" topic.

My wild guess is that no one is preventing you from using BitTorrent save for yourself, inadvertently.

Post the required info and after that try to ask a specific question. From your post I can't tell for sure if your question is about trackers, about port forwarding, connecting to peers or something else that's eluding me.

As for adding an exception in your firewall think of this: If your friend was coming to see you and you'd tell him that the door to the house is open, yet the gate facing the street, the door on the hallway and the door of your room were locked, could he reach to you?

All it takes is a single obstacle to block incoming connections. Adding an exception in a firewall won't magically configure the rest of the possibly existing firewalls sitting between you and the Internet, nor the NAT process running on a router.

So, bottom line:

1. Provide the required info.

2. Figure out what you want to ask about, then ask.

Link to comment
Share on other sites

One thing you should know, everybody should know by now, is that The Pirate Bay permanently took its tracker down last year. You will never get any response from the tracker url other than "not found" (the error codes you got, and should have looked up) because it's not there anymore.

TPB relies on DHT and PEX exclusively now. If you didn't know that, make a note of it and tell all of your friends. TPB's tracker is gone, has been for months, and will not be coming back.

Expect to get errors from UDP urls. Very few trackers use UDP. Demonoid is one of the few. If a torrent uses both HTTP and UDP urls, this simply hits the tracker twice for exactly the same information, doubling the burden on the tracker for no gain or profit at all to the client. People who create torrents with both urls need to be kicked in the head.

People who create torrents with UDP urls for trackers that don't support UDP, need to be kicked in the other side of the head. Wear heavy boots.

Link to comment
Share on other sites

Thanks for your answers. Here is a little more information

1) What version of BitComet are you using?

Bitcomet version 1.27

2) What type of Internet connection do you have (ADSL, etc.)?

I do not know. I and many people connect on a shared router. I think it is ADSL.

3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port?

I connect on a router (linksys rv082), but can not administrate the router. There may be other routers after the one I am connected to.

4) If you have more than one router, be sure to mention the make and model of both devices, how are they connected (i.e. in which connector of both devices is the network cable plugged) and which one of the devices is connected to or is the modem. Also, if you have more than one computer make sure to mention in this case, to which router is every one of them connected.

My computer is connected to the router using wifi IEEE 802.11g

5) What version of Windows, Firewall and Antivirus do you use?

Windows XP SP3, Windows firewall, antivirus avira antivir

To be more specific, I do not understand :

why official torrents like Debian or LibreOffice are not working at all, except for web seeds on LibreOffice?

why I can not connect to seeds even if a tracker gives me some?

Maybe you can link me to trackers using different protocols (dht/udp/http/...) so I can try different way to get a torrent.

Link to comment
Share on other sites

It's possible that whoever administrates your LAN has blocked p2p traffic. Many universities do, but webseeds use http protocol, which wouldn't be detected as bittorrent.

I think blocking someone from downloading a Linux distribution is crazy. Blocking all p2p is like outlawing trucks, since every now and then one carries stolen goods.

You can try different settings for protocol encryption, Default usually enables it, and then attempts to use it after connection is established, but will disable it if the peer doesn't respond. There is also settings for "always" and "forced". There is an exact description on wiki.bitcomet.com that explains them all.

However, the highest encryption setting will only allow connections to peers that use a client that supports encryption and has it enabled.

Link to comment
Share on other sites

Well, the next question in line is: "Do you have an open port or not?"

You said that grc indicates you don't, which is a pretty strong clue that this may be the case but just to double-check, what does BitComet say? Do you have a green status light (in the lower right area of the status bar)?

Also go to the Statistics tab, right-click inside the tab and choose "Copy All", then paste the info here.

As for the torrents you speak about post the links here so that we may try them and see if we get the same results as you.

Generally speaking, if you have a blocked port and you don't control the router, short of asking the administrator of the router to open a port for you there isn't very much you can do (other than get your own Internet connection if that's possible). There could be a small chance that you could open a port on the router through UPnP (that's why I was asking about the Statistics info), provided that UPnP is enabled on the router and your PC manages to "agree" with the router on that, using UPnP.

Other than that, you need to configure manually the router in order to get an open port. In case you will consider getting your own Internet connection steer away from any mobile/wireless offer where you don't control the other end device of the wireless link, as you'll be always firewalled and actually get only half of the services/capabilities of a standard Internet connection, pretty much as it seems to be the case now.

If you can't/won't change your current Internet link then you may want to consider other sources than BitTorrent (and P2P in general) for getting your materials, since most P2P clients rely on you having an open listening port so that other peers can contact you and initiate connections with you.

The other alternatives out there would be Usenet and HTTP/FTP sites/protocols which don't require an open port and can be used on any type of Internet connection.

Link to comment
Share on other sites

I only have a green light status on DHT. All the others light are not green (cometID sign in and the other on the right). Regarding, UPnP, I have activated it but it seems to fail. Here is attached the statistic tab from bitcomet. Looks like bittorrent/P2P will not work for me.

Up Time: 0:02:44

Ensemble des tâches : Total: 3 / Actives: 2

Connexions TCP : Établies: 0 (Max: Illimité) / Semi-ouvertes: 76 (Max: 98)

IP du réseau local :

IP du réseau étendu :

Port écouté en TCP : 13261 (La détection a échoué.)

Port écouté en UDP : 13261 (La détection a échoué.)

Pare-feu de Windows : Ajoutés [TCP opened, UDP opened]

Mappage des ports NAT : Échec [uPNP device not found!]

Débit de réception total : 0 ko/s (Max: Illimité) Limite de connections maxi: 50 par tâche

Débit d'envoi total : 0 ko/s (Max: Illimité) Seeding LT: 0 ko/s (Max: Illimité) Tous les slots de téléversement BT: 0

Mémoire physique libre : (Minimum à garder: Mo)

Memory Usage: Working Set: 28.07 MB, Commit Size: 12.66 MB

Taille du cache disque : 0 B (Min: 6 Mo, Max: 50 Mo)

Statistiques de lecture du disque : Requête : 0 (freq: 0.0/s), Disque actuellement en lecture : 0 (freq: 0.0/s), Ratio: 0.0%

Statistiques d'écriture sur le disque : Requête : 0 (freq: 0.0/s), Disque actuellement en écriture : 0 (freq: 0.0/s), Ratio: 0.0%

Total des téléchargements : 231 MB (this session: 3.61 KB)

Total des téléversements : 456.75 KB (this session: 1.75 KB)

EDIT: I am downloading http://torrents.thepiratebay.org/6240064/Rango.2011.TS.XViD-IMAGiNE.6240064.TPB.torrent http://cdimage.debian.org/debian-cd/6.0.1a/i386/bt-cd/debian-6.0.1a-i386-CD-1.iso.torrent and http://download.documentfoundation.org/libreoffice/stable/3.3.2/win/x86/LibO_3.3.2_Win_x86_install_multi.exe.torrent

Edited by Al_Freydde (see edit history)
Link to comment
Share on other sites

The torrents you posted are working fine. The first one showed when I started it first, over 4000 peers. The other two also got peers.

Indeed for the first one there were some trackers which were returning error codes and also the second time I stared it some of them reported 0 peers instead.

What you should understand is that trackers often are overloaded or down or unreachable temporarily due to network congestion. Usually most of these issues sort themselves out so the best thing to do for them is to wait. OTOH in the other cases (i.e. the tracker doesn't track that torrent anymore, or is down or refuses connection because some dumb user added it at torrent creation time even though that tracker never tracked that torrent in the first place, etc) there is nothing you can do about THAT specific tracker and it is best to actually remove it from the tracker list.

Nevertheless this is not a great tragedy; a single working tracker is all you need for your torrent. Moreover, BitComet doesn't rely only on trackers to acquire peers, but uses also DHT and PEX; thus you may have a trackerless torrent which downloads just fine (like most of the PirateBay torrents do these days).

Now going back to your client, if you don't have a green status light that means you have a blocked listening port, which in turn will prevent other peers from connecting to you; you will be left only with the connections you initiate towards others and consequently with poorer download speeds. UPnP doesn't seem to be enabled on the router device so that doesn't look as a valid option.

You could try to revert to v.1.02 which still uses NAT Traversal. That may help you get some remote peers and increase your dl speed to some degree.

Anyway, no matter what you should still be able to download even though at reduced speeds. If you can't connect to any peer at all, that's a bit weird.

What is your tested upload speed?

What are your connection settings in BitComet?

Link to comment
Share on other sites

I have tried BitComet v.1.02 and it has increased my download rate by 2000% ! by the way, 0 kB, even increased by 2000% is still 0 kB. It looks like I am having exactly the same problems on both versions.

The torrent from TPB gives me a few hundred peers from *DHE* but there is no way to connect with them.

Regarding my upload speed, it is 0 in BitComet... I do not know the exact speed. I can attach a 3.3 Mo PDF file in gmail in ~3 minutes.

I have pasted at the bottom of the message the configuration of BitComet in v.1.02 from the xml file. How to do this with a recent installed version?

Thank you for your help greywizard

EDIT : I am unable to sign in CometID from BitComet. Is it normal?

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>



































<LastTorrentDirectory>C:\Documents and Settings\*********\Bureau</LastTorrentDirectory>








<ServerList>ip=;;;;;; ip-us=;;;;;; ip-cn=;;;;;; mirror-url=; mirror-url-submit=; mirror-url-cn=bc3.85851.com:8080;bc4.85851.com:8080; mirror-url-submit-cn=; mirror-hash=; mirror-user=;; mirror-user-submit=;;; mirror-user-cn=bc1.85851.com:8080;bc2.85851.com:8080;; mirror-user-submit-cn=;;; filehash-hashset=; filehash-hashset-submit=; stats= torrent-cache=; torrent-cache-submit=; torrent-filehash=; torrent-filehash-submit=; inside-stats=; taskinfo-main=; taskinfo-torrentshare=; sup-cn=;</ServerList>







Edited by Al_Freydde (see edit history)
Link to comment
Share on other sites

Go to http://speedtest.net. Test your connection speed.

Transform your tested upload speed into byte multiple (roughly dividing it by 8 will do for now).

Multiply that value with 0.8 and the result is the limit you should impose on upload for BitComet, on the Options-->Connection page.

See if that makes any difference.

If not, then something else than BitComet is wrong with either your system or your connection. Or it could be that, simply, BitTorrent traffic is being monitored and actively banned on your network.

But I'm not sure what to think so far.

Link to comment
Share on other sites

Applying your procedure, I have found 17kb. Limited my upload to this value in bitcomet and my download to 50. All the peers are still oscillating between bt_connecting and bt_disconnect. Every peer is marked as 'dead[n]' with n between 1 and 9.

There is one difference between connection speed limited and unlimited : now, the peers are not marked anymore as *DHE*...

Anyway, thank you for your help.

Considering torrent downloading has already worked on my system, I think something is wrong with my connection. Is there any easy-way to download a torrent using encapsulation ?

Link to comment
Share on other sites

Well the first link to the forum topic is a place where ideas are bounced back and forth about possible ways to obfuscate BitTorrent traffic and how that could be implemented in the open standard or in an open extension to the standard. There is nothing concrete, nothing which passed the level of a discussion, so far.

On the other hand, the second link leads to a commercial site which offers a service (proxy servers specially configured to carry and forward BitTorrent traffic). This isn't a new thing, the ability to use this technology exists for a while in many clients (BitComet included) but... you'll have to put your hand in your pocket.

At present time, indeed, some of the valid options for hiding your identity while torrenting are proxy servers (such as the offer in your second link) and VPN connections. The downsize is that you'll have to pay for the service.

However, these are meant to mitigate tracking from MPAA/RIAA hound dogs (read anti-p2p monitoring agencies) so that you won't get citations to a courtroom in your mailbox in case you download stuff you shouldn't or simply to hide your activities/interests from prying eyes.

But if your ISP decides to throttle BT traffic it does it for different reasons (preserving bandwidth) and as you read in the first thread you provided a determined and motivated ISP has the means to figure out what type of traffic you're moving on its network, so these solutions wouldn't help you much in this case.

Still I'm not 100% sure that this is your case. Given the fact that you don't have an open port the only thing you could/should diagnose is whether BitComet can reach out towards other peers (i.e. is not prevented from establishing outgoing connections).

The fact that you don't control the router makes that task even harder.

The only test I can think of which wouldn't have too many variables to discuss here would be to use a clean partition of a hdd to install a fresh copy of windows (just for testing purposes) and BitComet configured with only the above discussed upload limit and all the rest of the settings on default. This way any firewall, third-party application or misconfiguration would be out of question.

If in this way you still wouldn't be able to get any connections or data downloaded then it means the problem lies out of your system.

That is, if you really want to follow this through.

Another test worth trying (and a bit simpler) would be to install another BT client and see if you still can't get anything moving. But in case it doesn't work either, this still wouldn't eliminate the possibility of something not working right or standing in the way, on your system.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...