Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

About to give up. Every port seems blocked

Recommended Posts

I'm using version 1.28 for BitComet. My ISP is a cable isp with unlimited bandwidth at rated at 15mbs (usually I get twice that). The router is a Netgear WNR2000v2 hardwired into a Motorola SB5101 modem, which is connected into my computer. The modem itself is hooked into port 4 of the router. I've tried unchecking upnp from both the modem and bitcomet. Nothing. I'm on windows 7 32 bit with the latest updates (I will admit that I'm just using the internal windows firewall and most recent version of Microsoft security essentials). I've been working with the software from Port Forward, which you can see here: http://screencast.com/t/vQJLYqXu8t (these are the actual settings). I've also forwarded 141492 apparently successfully as you can see here: http://screencast.com/t/kFbQjOPQPrh.

I also use HideMyAss Pro, which works well and connects to (illinois) and that I also use for work. I get decent speed I guess (around 80 kbps {much better than when I was with a BIG telco!] but I'm still blocked and have the yellow light. I must be missing a thing or two, and could use the advice. I just want to get the best speed I can get.

Link to comment
Share on other sites

Disable the VPN software in order to test if your port forwarding works.

Most VPN providers do not forward ports for incoming connections (except those who offer services tailored for P2P) and while using the VPN all your incoming connections will be inbound through the VPN server.

At present time you have one more unnecessary unknown to the equation.

So always start simple and once you solved the main problem, start adding back services you disabled, to see which one was causing it.

Besides, you say your modem is plugged in port 4 of your router. The thing is we have not idea which is port 4 of your router.

If you're saying that your modem is plugged into a LAN port of your router instead of the WAN port, then this means you're bypassing altogether your router and you're using just the LAN switch part of the device.

In that case you wouldn't even need port-forwarding and the whole issue lies in the software configuration of your PC (firewall, VPN and whatever other firewall-like application running on your PC).

If after disabling the VPN it still doesn't work, paste here the info from Statistics tab, in BC.

Link to comment
Share on other sites

Thanks that fixed it. Now I've also set it up with a STATIC ip (as shown in the previous screen shots) Do I still need this or can I switch it back to dynamic? As I do a lot of internet work (submissions, SEO stuff software etc) will it make a difference?

And here's what the statistics tab tells me, I'm currently getting 250-300 kbps download, much better. Can I improve it at all?

Up Time: 0:03:54

Overall Tasks: Total: 1 / Running: 1

TCP Connections: Established: 35 [MAX:Unlimited] / Half-Open: 15 [MAX:200]


WAN IP: 24.x.y.z

Listen Port of TCP: 14192 (Opened in Firewall/Router)

Listen Port of UDP: 14192 (Opened in Firewall/Router)

Windows Firewall: Added [TCP added, UDP added]

UPnP NAT port mapping: Added

Disk Boost Service: Running

Overall Download Rate: 289 kB/s [MAX:Unlimited] Max Connection Limits: 50 per task

Overall Upload Rate: 110 kB/s [MAX:Unlimited] LT Seeding: 0 kB/s [MAX:Unlimited] All BT Upload Slots: 17

Memory Usage: Working Set: 101.22 MB, Commit Size: 79.45 MB

Free Memory: Phys: 1.36 GB (Min to keep: 50 MB), Pagefile: 3.93 GB, Virtual: 1.66 GB

Disk Cache Size: 50 MB (Min: 6 MB, Max: 50 MB)

Disk Read Statistics: Request: 1197 (freq: 6.2/s), Actual Disk Read: 149 (freq: 0.8/s), Hit Ratio: 87.5%

Disk Write Statistics: Request: 2005 (freq: 12.4/s), Actual Disk Write: 330 (freq: 3.1/s), Hit Ratio: 83.5%

Total Downloaded: 199.36 GB (this session: 34.52 MB)

Total Uploaded: 84.78 GB (this session: 20.07 MB)

Edited by greywizard (see edit history)
Link to comment
Share on other sites

Frankly, it's still unclear to me what your network setup is. Is the cable from the modem going into the WAN port of your router or into a LAN port?

Because that would make a huge difference.

Anyway, I can see that BitComet also reports having added a UPnP port mapping. Therefore, in case it's UPnP that really opened your listening port then it wouldn't make any difference for BitComet if you made your IP dynamic again. Except you'd have to keep a keen eye and watch for a while to see if UPnP is working for you all the time, not just randomly (in some configurations it happens).

At any rate, I'm just guessing here since I don't know if your PC got it's IP from the router or from the modem.

What IP do you get if you connect your PC directly to the modem and set it to get and IP from DHCP?

And no, it doesn't make any difference if your IP is acquired by DHCP or set in a static manner; it's just simpler by DHCP but if UPnP doesn't work you NEED a static one for port-forwarding.

Link to comment
Share on other sites

We are talking about a static IP address between your computer and your router -- that is, on your LAN.

On the other side of your router, the WAN side, the router has its IP address assigned by your ISP. It is dynamic. This is the address that the world "sees", the router's address. It doesn't know what's behind that router, and doesn't need to know. So it won't make any difference to anyone else what the LAN setup is.

Your VPN service, HMA Pro, carefully avoids mentioning peer-to-peer, which is what most people would want the service for.

For maximum speed in P2P, you need to be "connectable", that is, people need to be able to call you. (With your normal internet connection and a decent firewall, you can call them but they can't call you. That's because most unrequested incoming traffic wants to do you harm. A firewall blocks it.) For them to call you, there has to be an open port in the firewall that they can connect to, where your client is watching for that traffic (and discarding any non-bittorrent traffic that comes in.)

Now with your VPN service, there's no way to tell who an unsolicited incoming connection is intended for -- you, or any one of their thousands of other customers? So there's no way to forward it to you. Effectively, you cannot be connectable.

For that, you need much more configuration on the VPN end of things, which takes more equipment and is more expensive. Services like iPREDator do offer this, but naturally cost more.

IMO, your VPN service doesn't actually do anything for you that is worth paying for.

Link to comment
Share on other sites

Well, except let me view US content from Vudu/Netflix. My status is green with the ip set to static. If I set it to dynamic it goes yellow. And apologies GreyWizard, I do try to be complete. My modem is plugged into my routers "Internet" port (assuming that's their word for LAN?) and the the other ethernet cable goes from the ethernet port 4 to my computer.

Link to comment
Share on other sites

Your router has a WAN port, and several LAN ports. It's designed to plug the modem into the WAN port, which your's calls "internet".

The WAN (wide area network) consists of the entire internet and your router (not your computers).

Your LAN (local area network) consists of your computers and your router. All connections to the internet WAN have to be handled by your router.

By the way, when you installed this router, you made yourself a Network Administrator, without it your computer would be part of the WAN and opening ports wouldn't be an issue.

Link to comment
Share on other sites

Well, except let me view US content from Vudu/Netflix.

But you can do that with one of the hundreds of free proxy services available. I use them to view content that is barred to U.S. IP's. There's no point in paying for this when you can get it free.

Link to comment
Share on other sites

Please post your problem in one location. From the combination of this post and your other, I can see you have two problems.

Check that your IP address matches the setting in your router.

Don't try to use the same port number for more then one app.

Link to comment
Share on other sites

Ok, you didn't specify you were using uPnP to open your port. Since you had two programs attempt to open the same port using upnp, I have no idea how your router has handled the conflict. There is no conscious on making all uPnP devices work the same.

I think it would be easier to simply setup a portforwarding rule for bitcomet, but if you want to use uPnP, that's fine, but when it doesn't work, it's very difficult to track down the reason.

You can try resetting your router then enabling uPnP, then start bitcomet with upnp enabled, and see if it's able to open the port for you, or of course you can simply setup a portforwarding rule for bitcomet.

Link to comment
Share on other sites

hmmmm.....So for fun I just fired up my VPN and started up Bitcomet. Got the yellow light but it DID sign in and didn't have an issue with the port. Disconnected from the VPN. Shutdown Bitcomet completely and unchecked the randomize feature so I could use the same port...And it wouldn't log in and "couldn't listen". So what does this mean now?

Set up port forwarding to 15442 and made my ip static. Still the same issue. All this because I bloody restarted my router.

Edited by cypherslock (see edit history)
Link to comment
Share on other sites

If UPnP mapping is giving you troubles then you should focus ONLY on setting up a static IP and performing a MANUAL port forwarding.

Mixing UPnP, with VPN and manual port-forwarding techniques can yield unpredictable results and since we're not in front of your computer we can't say just by guessing what's going on.

So, restart your PC disable UPnP in BitComet and focus on getting manual port-forwarding to work.

I'm not sure what exact steps you imply when you say "tried port forwarding" or "set up port forwarding" but the exact steps to be followed are detailed here: Manually Configure Port Mapping at Router setup page. Just forget about that program which it's supposed to do the work for you automatically, for now.

If you stumble at any step or don't understand why or exactly how it's supposed to be done feel free to ask.

Also, if you get any errors in the process make sure you quote the exact error message or post a screenshot of it; the phrase "couldn't listen", for instance, may mean several things and we can't tell for sure which one is it.

Now, at least we will refer to the same guide as a common denominator for troubleshooting your issue.

Bottom line:

1. Read the guide first without doing anything, just to see if you understand the whole picture.

2. Try following the steps of the guide. If that solves your issue then it's fine. If not then:

3. Take your router out of the loop temporarily. Connect your PC directly to your modem set your PC to get an IP through DHCP again and check if you get a green light.

If you do get a green light this will tell you that your issue lies on your router configuration and you'll need to find and fix the errors on it. If you still don't get a green light this means that your modem may have a firewall or NAT on it. Post the results of an ipconfig /all command, here, in that case, so that we can see what type of IP address your PC obtains when connected to the modem.

4. If when connecting the PC directly to the modem you GET a green light then double check that you have a static IP again, and post here the results of an ipconfig /all command (not just ipconfig) so that we can also verify that you DID set a static IP correctly.

5. Now, if all the above are done with, all the work that remains will have to be done on your router, making sure that the port forwarding is correctly done.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...