Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Hash checking bugged

Recommended Posts

Hi....I have been a bitcomet user for many years. Recently I ran into a hash checking problem---

hash check always hangs at 0.3%.CPU works like mad till the fan roars. Attempting any further action freezes Bitcomet.

I tried the following

Moving the file to a different physical drive and hashing again > same probelm

downloading a torrent file instead of using magnet link, hash again > same problem

tried on 1.31 x86 and x64, 1.29 x86, all having same result

**Used uTorrent and it hashed perfectly to 99.8%, finished the download eventually

Tried hashing the file (finished by utorrent) using bitcomet, hangs at 0.3% still

Bitcomet has been my client of choice and i really hope the staff could look into it. Thanks!

Edited by divingbirdie (see edit history)
Link to comment
Share on other sites

I started the torent, it began downloading normally. I then stopped it and did a hash check which completed then I resumed download. Seems to work fine for me.

Perhaps other staff members can try it, see if anyone else has a problem.

Link to comment
Share on other sites

  • 4 weeks later...

I have now two torrents that are doing the same thing and wiping the download and starting over DOES NOT FIX IT AT ALL!

No matter what I do, hash checking the file causes 50%+ CPU time with no percent increase in the hash check, it just keeps pushing the CPU. The only thing you can do is stop the HASH which freezes Bitcomet and you have to Cntrl-Alt-Del and kill the process...


Link to comment
Share on other sites

ranosb, we do need the basic information from you.


You wanted me to be specific but you were not sir

Using Bitcomet 1.29-history ugrades do not show any changes with hash checking

Certain torrents won't hash check without crashing.

Link to comment
Share on other sites

Ranosh, there is a "sticky" topic at the beginning of this forum, in bright red lettering, that says, "PLEASE READ BEFORE POSTING".

The bird links to it in his signature -- the one that says, "READ BEFORE POSTING"?

You are supposed to read it before you post.

It tells you what information you need to supply in your original post.

Since you still haven't done that, you need to read that message and supply that information before it's possible to help you any further.

Link to comment
Share on other sites

1) What version of BitComet are you using?

Bitcomet 1.29

2) What type of Internet connection do you have (ADSL, etc.)?

Cable but that has nothing to do with a hash check which doesn't use the internet

3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port?

Dir-100 Router, Port forwarded, green light for WAN on Bitcomet, Motorola Sb5101u Modem

4) If you have more than one router, be sure to mention the make and model of both devices, how are they connected (i.e. in which connector of both devices is the network cable plugged) and which one of the devices is connected to or is the modem.

Also, if you have more than one computer make sure to mention in this case, to which router is every one of them connected.

Only 1 router modem theres nothing wrong with my internet connection

5) What version of Windows, Firewall and Antivirus do you use?

WinXP Media Center, No firewall, No antivirus

6) If you are asking about a specific torrent or file that you have downloaded, make sure that you include the complete torrent name, as well as the complete names of the files and their respective extensions/formats (e.g.: .rar, .wma, .bin, .cue, etc.).

Belly Of The Beast (2003) 720p BluRay x264-Japhson.torrent


Footloose (1984) 720p BluRay x264-Japhson.torrent


The Phantom of the Opera at the Royal Albert Hall 2011 Part 1 720p BluRay x264-SAiMORNY.torrent

The Phantom of the Opera at the Royal Albert Hall 2011 Part 1 720p BluRay x264-SAiMORNY.mkv

7) For speed-related issues, please run various speed tests at a site such as speedtest.net (make sure that no other computer is using your Internet connection and that all other programs - including BitComet - are closed, during the tests).

Include the results, along with the settings that you are presently using, in your post, so that we may review and offer suggestions to improve its performance.

Speedtest shows what my connection speed is, its not an internet problem, Hash check can be done OFFLINE has no effect on connection

Link to comment
Share on other sites

Why can't posts be edited?


The Phantom of the Opera at the Royal Albert Hall 2011 Part 1 720p BluRay x264-SAiMORNY.torrent


Link to comment
Share on other sites

All three of your examples appear to be dead. Certainly they're all several months old, and the "Phantom" example seems old enough to have been scrolled off the rolls of trackers that were carrying it.

Any particular reason you're still running XP?

Link to comment
Share on other sites

I just downloaded those like I mentioned and are seeding them! I had to use Bitspirit to successfully hash check them.

Don't know where you got the torrents from.

I'm using XP cause I use alot of programs that still don't run correctly in Win7.

Neither of those two issues have anything to due with the intial topic...

Link to comment
Share on other sites

As you were told in the initial reply to your topic,

We can report a bug if we can reproduce it. I suggest you provide the torrent and one of our staff can check it (time permitting). If we can confirm it, the data will be sent to development.

You've yet to provide a torrent that we can obtain to test.

To whatever extent the problem may be related to your OS, none of us run XP Media Center, so we can't rule an OS version-specific issue out.

At this point you have an anecdote, nothing more. We are trying to turn it into a reproducible defect that can be reported and hopefully fixed.

Link to comment
Share on other sites

Hi. Unfortunately i ran into the same problem again. On this torrent. And since so many others have the same issue i think it's not an isolated case. Hope this bug can be fixed as right now the only way is to start downloading all over. I suspect this problem occurs when bitcomet is exitted abruptly while DL is in progress. I am not able to reproduce the problem everytime though

hash check hangs.torrent

Link to comment
Share on other sites

Not sure if God is going to reply to you or not, but I'm willing to try the torrent in the meantime, however... it would be nice to have been given a torrent that isn't over 6gb to test with, unless you're saying it only happens with large torrents like this.

It's downloading now, I'll reply and let you know what I find out.

Link to comment
Share on other sites

  • 3 weeks later...

Hello, I used the latest Bitcomet available on the official website. I downloaded a few torrents (720p movies) and when they are completed the hask checking freezes at 0.2%. Whatever I do next crashes bitcomet. i've had this problem with several torrent files, and it's really annoying.

Is there any solution for this?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...