Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Need help!

Recommended Posts

Is there anyway I could fix my download problem? I'm from Canada and torrent speeds were great when I was using it there, but now I moved to Macau (Island very close to Hong Kong) and I can't get any downloads going at all.

I'm using CTM ISP in Macau (the only ISP available here). I'm using a ASUS G73SW notebook running Windows 7.

Link to comment
Share on other sites

Sorry didn't mean to make duplicate. The other was removed before I posted here.

1) What version of BitComet are you using? 64Bit v1.33

2) What type of Internet connection do you have (ADSL, etc.)? PSTN (7MBPS Download/ 512KBPS UPLOAD)

3) I have the ISP's modem/router in the living room, and have a DLINK 655 connected to it. I'm using WIFI to connect to the DLINK router. The living room has a concrete wall that blocks the signal from where I need to use my computer so I extended the DLINK router to my room so I could use internet all around the house.

4) The ISP router/modem is the main source. I connected a DLINK 655 to the main source with an Ethernet cable. I have my computer using WIFI to connect to my DLINK 655.

5) I'm using Windows 7 Home, and using only Windows implemented firewall. No anti viris installed.

6) Speed test: PING 25ms, Download 6.36MBPS, Upload 0.49MBPS. http://www.speedtest.net/result/2114221336.png

Link to comment
Share on other sites

First thing I'd do is set your global max upload to 50kB/s. This is about 80% of the max you can upload so this setting will reserve just enough bandwidth so your responses to requests are answered promptly. Since bittorrent protocol gives the most to those who upload the most, you're rarely going to see downloads anywhere near your max download speed of about 795kB/s. Most healthy torrents if run one at a time will download at 100-300% of your upload speed, so I'd expect to see speeds in the 50-150kB/s range, with some exceptions that exceed 500kB/s, however if one does download fast you're still expected to keep it running until your share ratio is above 1.000. If users don't upload as much as the download the system will collapse and we won't have torrents anymore.

Next issue is your listening port. My guess is you have a yellow light on your WAN port indicating that you cannot receive any incomming connection attempts. If so, the easiest way to fix this would be to setup portforwarding in both routers. The first router you can optionally setup to put the second router in DMZ, so all unspecified traffic goes to the dlink, then you can setup portforwarding so all connections that specify your bitcomet port will go to your laptop. Check our portforward guide for more information.

Link to comment
Share on other sites

Sorry I'm really bad at this. I tried port forwarding the main router to see if I can get rid of the yellow light first, but I'm having some trouble. So I logged into the modem/router and tried port forwarding, but I don't know if I'm doing it correctly.

In my router to went into the; NAT Tab ---> Virtual Servers ---> and did the follow...

Server Name External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address Remote Host

Danny123 14907 14907 TCP/UDP 14907 14907

Then I went into the; NAT Tab --> Port Triggering --> and did the follow...

Application Trigger Open

Name Protocol Port Range Protocol Port Range

Start End Start End

Danny123 TCP/UDP 14907 14907 TCP/UDP 14907 14907

I didn't do the DMZ yet. I'm suppose to enter my DLink's router IP?


Edited by Danxity (see edit history)
Link to comment
Share on other sites

You don't need the port triggering at all and can delete that rule.

As you have set up the forwarding rule, your computer must be at the IP address that you are forwarding the port to, and that address must be on that network.

Since you have set it up as 122.100.xxx.xxx, it is almost certainly NOT on the network. The networks' addresses are going to be in the 192.168.xxx.xxx or 10.xxx.xxx.xxx blocks -- those chiefly reserved for private LANs. Your computer should also have an IP address in the appropriate block, and it must be a static address.

Your router has a WAN side, and a LAN side, and it does network address translations between the two. From the computer, the router is its gateway to other networks, but it cannot see them. All it can see is the LAN, at one of those two reserved blocks.

The 122.100.xxx.xxx address is WAN side. You don't mess with that, it's assigned by your provider.

Find the LAN-side address for your router. This will be the address you use to configure it. Typically, it will be something like

You willl typically be using a netmask of Put that together with the router's base address and all of the devices on your LAN will have addresses that start with 192.168.1 and the final number of the quad will be between 0 and 255. We generally don't use the 0 address. That still leaves you with 255 numbers to play with. Very few people have 255 devices that need network connections.

Your router itself is taking up the first one. You can set your computer up to take the last one, that's

In your network settings, adapter properties, Internet Protocol Version 4 properties, uncheck "Obtain an IP address automatically", and instead fill in your computer's address, your netmask, and your gateway address. For now use the gateway address for your first DNS server and leave the second blank.

Edit your router's rule to point to your computer's IP address as you've just set it up. Now your listen port should be open.

Link to comment
Share on other sites

  • 5 weeks later...

>_< I still can't get it to work. I don't know what I'm doing wrong, but I guess I don't know what I'm supposed to do in one of the parts. I use to do port forwarding for pc games and now I just want to use BitComet and don't know what I'm doing wrong.

I want to forget about my second router now. I want to at least get my main router to start making my BitComet work.

I did the port forwarding guide on my computer like how I use to do when I played PC games and did some port forwarding. But incase I'am doing something wrong with the port forward on the PC I will list below the steps I did.

1. I went into the properties of the connection I'm using.

o Checked "Use the folowing IP address:"

o IP address: (ipconfig/all shows me IPv4 address)

o Subnet Mask:

o Default Gateway:

o Preferred:

2. Went into my ISP's router setting. I think this is the part I'm not sure how configure.

o Went into NAT > Port Triggering.

o Add (I did this 3 times since I don't know what to input for some of the things it's asking me)

o Name Application: BitComet [] Protocol:TCP, start: 25882, end:25882 [] Protocol:TCP, Start:25882, End:2588 []

o Name Application: BitComet [] Protocol:UDP, start: 25882, end:25882 [] Protocol:UDP, Start:25882, End:2588 []

o Name Application: BitComet [] Protocol:TCP/UDP, start: 25882, end:25882 [] Protocol:TCP/UDP, Start:25882, End:2588 []


Edited by Danxity (see edit history)
Link to comment
Share on other sites

Are you trying to setup portforwarding or port triggering? It sounds like you're making this more complicated then it needs to be, portforwarding is much simplier. Also, you can't "forget" about your second router unless you remove. If the data passes through a device, that device has to know how to handle it.

Your remote peers will send a connection request to your modem or combo modem/router located at 122.100.204.XXX on your specified port 25882, and when it gets to your first router you need to have a rule telling it to send all connections on port 25882 to the computer located on your LAN at That's all that is required if you have only one router, but if you have a second router you need to have the first router set to send the data to the second routers IP address, then set the second router to forward it to the address and assuming that computer doesn't have any software blocking the port, bitcomet will receive the connection.

Link to comment
Share on other sites

Ah no wonder. Yeah I'm trying to port forward. I assumed forward and trigger was the same my bad. Since I'm in asia I thought there might of been some translation errors, like when I go to the banks here I always see the ATM's with incorrect translation.

>_< Still I can't find Port Forwarding on my main router (ISP's router). I went through the list and theres only;

Device Info - [] Statistics [] Wan [] Route [] ARP [] DHCP []

Advanced Setup - [] WAN [] NAT - Virtual Servers, Port Triggering, DMZ Host [] LAN [] Routing [] DNS - DNS Server []

Wireless - [] Basic [] Security [] Advanced [] Station Info []

Settings - [] Restore Defaults [] Passwords [] Save/Reboot []

Link to comment
Share on other sites

NAT-Virtual Servers is what you're looking for, on your modem/router device; this is just another name for "port forwarding".

Your situation is one of "cascaded routers" as my colleagues explained to you above.

We already have a whole section dedicated to this in the updated Port Forwarding Guide on the BitComet Wiki here: Port Mapping in NAT Router.

The section is called exactly "Cascaded routers" and it has quite ample explanations on the whole shebang, along with pictures.

Read it and it should walk you through every step of the way.

If you get stuck at any point then come back and ask; at least we'll have some common ground.

Good luck!

Link to comment
Share on other sites

You're mixing apples with plums.

You can either try to perform automatic UPnP port forwarding (which is described in the FIRST half of the topic I linked you to) OR you perform manual port forwarding which is what we've been talking about all this long topic, until now.

The fact that the two methods are ALTERNATIVE means of forwarding a port, not cumulative ones is very clearly explained in the introduction to the whole topic.

Besides the fact that the "cascaded routers" subsection is found under the Manual Forwarding section has a very specific reason: In case of cascaded (daisy-chained) routers UPnP will not work !

I told you the specific part of the guide you need to read in order to fix your issue and yet you quote back to us a totally different part of the ALTERNATIVE method, as the step where you got stuck.

Forget about UPnP if you want to use your actual topology. Then go back and read the Manual Forwarding section and specifically pay attention to the Cascaded Routers, since you have TWO of them, and only after that report back if you're still stuck, but indicating the step of the correct guide, where you stumbled.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...