Jump to content
Comet Forums
Nirjonadda

Bitcomet video downloader is incompatible with firefox

Recommended Posts

I am installed bitcomet in my windows but extensions for firefox it doestnt work, It showing disabled. Please do update Bitcomet video downloader extensions for firefox.

 

MZLIyoy6QWq4kzjSHtfqOw.png

Edited by Nirjonadda (see edit history)

Share this post


Link to post
Share on other sites

The latest Firefox update wrecked a LOT of plug-ins and extensions.

However,you can install other add-ons that are compatible for youtube downloading (I use 1-click myself)

Share this post


Link to post
Share on other sites

here is the issue, firefox used to do updates using minor numbers, like 3.12 to 3.13, and any 3.xx version all used the same extensions and every 2 tears or so they would change major numbers, from 1.xx to 2.xx and 3.xx, then suddenly they started using a major number with nearly every update and often every couple weeks which required all extension developers to duplicate their work and since our developers are volunteers and have their day jobs keeping them busy so updating theit extension became untenable, but it's been updated every time bitcomet is. I don't know why they started doing this, but it doesn't seem like a nice thing to do and we've published this info many times in this forum.

My solution was to use google chrome, another is to get firefox long term support version that updates security issues without changing major version numbers, or another browser, or don't allow firefox to update until a new BC version is released.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×